summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-04-25 17:18:41 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-04-25 17:18:41 +0000
commitdbbc68a9e3e86d630c45317b0468f480f0e8bd73 (patch)
tree0a1ddad9507b29ea2c6b80a8ee7a106813f10409 /dev-perl/Graph
parentstable on x86 (diff)
downloadgentoo-2-dbbc68a9e3e86d630c45317b0468f480f0e8bd73.tar.gz
gentoo-2-dbbc68a9e3e86d630c45317b0468f480f0e8bd73.tar.bz2
gentoo-2-dbbc68a9e3e86d630c45317b0468f480f0e8bd73.zip
Updates
(Portage version: 2.0.51.20-r4)
Diffstat (limited to 'dev-perl/Graph')
-rw-r--r--dev-perl/Graph/ChangeLog14
-rw-r--r--dev-perl/Graph/Graph-0.20.101.ebuild18
-rw-r--r--dev-perl/Graph/Graph-0.20.105.ebuild (renamed from dev-perl/Graph/Graph-0.20101.ebuild)11
-rw-r--r--dev-perl/Graph/Graph-0.63.ebuild (renamed from dev-perl/Graph/Graph-0.20105.ebuild)4
-rw-r--r--dev-perl/Graph/Manifest12
-rw-r--r--dev-perl/Graph/files/digest-Graph-0.20.101 (renamed from dev-perl/Graph/files/digest-Graph-0.20101)0
-rw-r--r--dev-perl/Graph/files/digest-Graph-0.20.105 (renamed from dev-perl/Graph/files/digest-Graph-0.20105)0
-rw-r--r--dev-perl/Graph/files/digest-Graph-0.631
8 files changed, 49 insertions, 11 deletions
diff --git a/dev-perl/Graph/ChangeLog b/dev-perl/Graph/ChangeLog
index d889237c65f5..9bddfd357212 100644
--- a/dev-perl/Graph/ChangeLog
+++ b/dev-perl/Graph/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for dev-perl/Graph
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Graph/ChangeLog,v 1.10 2005/04/24 03:14:50 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Graph/ChangeLog,v 1.11 2005/04/25 17:18:41 mcummings Exp $
+
+*Graph-0.20.101 (25 Apr 2005)
+
+ 25 Apr 2005; Michael Cummings <mcummings@gentoo.org> +Graph-0.20.101.ebuild,
+ +Graph-0.20.105.ebuild, -Graph-0.20101.ebuild, -Graph-0.20105.ebuild,
+ +Graph-0.63.ebuild:
+ Advance apology for what may appear to be a downgrade for users. There is no
+ change in the 0.20101 and 0.20105 vs 0.20.101 and 0.20.105, but the name
+ change necessary in order to be able to provide newer versions (which use only
+ a 2 diget nomenclature). This is probably why this package has been neglected
+ for so many years - a sheer inability to provide a newer version that portage
+ would recognize as newer over the 5 digit number.
24 Apr 2005; Michael Hanselmann <hansmi@gentoo.org> Graph-0.20101.ebuild:
Stable on ppc.
diff --git a/dev-perl/Graph/Graph-0.20.101.ebuild b/dev-perl/Graph/Graph-0.20.101.ebuild
new file mode 100644
index 000000000000..513d365c9761
--- /dev/null
+++ b/dev-perl/Graph/Graph-0.20.101.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Graph/Graph-0.20.101.ebuild,v 1.1 2005/04/25 17:18:41 mcummings Exp $
+
+inherit perl-module
+MY_PV=${PV/20.101/20101}
+MY_P="${PN}-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Data structure and ops for directed graphs"
+SRC_URI="http://www.cpan.org/modules/by-module/Graph/${MY_P}.tar.gz"
+HOMEPAGE="http://www.cpan.org/modules/by-module/Graph/${MY_P}.readme"
+IUSE=""
+SLOT="0"
+LICENSE="|| ( Artistic GPL-2 )"
+KEYWORDS="x86 amd64 ppc sparc alpha"
+
+DEPEND="dev-perl/Heap"
diff --git a/dev-perl/Graph/Graph-0.20101.ebuild b/dev-perl/Graph/Graph-0.20.105.ebuild
index 6e9ad9915295..c55b91334a93 100644
--- a/dev-perl/Graph/Graph-0.20101.ebuild
+++ b/dev-perl/Graph/Graph-0.20.105.ebuild
@@ -1,15 +1,20 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Graph/Graph-0.20101.ebuild,v 1.13 2005/04/24 03:14:50 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Graph/Graph-0.20.105.ebuild,v 1.1 2005/04/25 17:18:41 mcummings Exp $
inherit perl-module
+MY_PV=${PV/20.105/20105}
+MY_P="${PN}-${MY_PV}"
+S=${WORKDIR}/${MY_P}
+
DESCRIPTION="Data structure and ops for directed graphs"
-SRC_URI="http://www.cpan.org/modules/by-module/Graph/${P}.tar.gz"
+SRC_URI="mirror://cpan/authors/id/J/JH/JHI/${MY_P}.tar.gz"
HOMEPAGE="http://www.cpan.org/modules/by-module/Graph/${P}.readme"
IUSE=""
SLOT="0"
LICENSE="|| ( Artistic GPL-2 )"
-KEYWORDS="x86 amd64 ppc sparc alpha"
+KEYWORDS="~x86 ~amd64 ~ppc ~sparc ~alpha"
+SRC_TEST="do"
DEPEND="dev-perl/Heap"
diff --git a/dev-perl/Graph/Graph-0.20105.ebuild b/dev-perl/Graph/Graph-0.63.ebuild
index 9fac42eef25b..2630a07d160e 100644
--- a/dev-perl/Graph/Graph-0.20105.ebuild
+++ b/dev-perl/Graph/Graph-0.63.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/Graph/Graph-0.20105.ebuild,v 1.4 2005/03/30 22:28:05 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Graph/Graph-0.63.ebuild,v 1.1 2005/04/25 17:18:41 mcummings Exp $
inherit perl-module
DESCRIPTION="Data structure and ops for directed graphs"
-SRC_URI="http://www.cpan.org/modules/by-module/Graph/${P}.tar.gz"
+SRC_URI="mirror://cpan/authors/id/J/JH/JHI/${P}.tar.gz"
HOMEPAGE="http://www.cpan.org/modules/by-module/Graph/${P}.readme"
IUSE=""
SLOT="0"
diff --git a/dev-perl/Graph/Manifest b/dev-perl/Graph/Manifest
index ff36e3a53f1f..b2dbecdcced7 100644
--- a/dev-perl/Graph/Manifest
+++ b/dev-perl/Graph/Manifest
@@ -1,6 +1,8 @@
-MD5 b50267e630325386ab3cff7ae344629b Graph-0.20105.ebuild 560
-MD5 ab9498fa570b849d8618e396486b6230 Graph-0.20101.ebuild 540
-MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
MD5 1c0b8bf92edb053457fda70cbe787040 ChangeLog 1161
-MD5 6b956a3803d81868f15408ac1e2a3561 files/digest-Graph-0.20105 64
-MD5 a71dcc0962a8adef82720ed56da486be files/digest-Graph-0.20101 64
+MD5 e2d8f1bf77722def1dd432e26455c818 metadata.xml 305
+MD5 b27d5aaf9cf8015262140a08fd6d057c Graph-0.63.ebuild 550
+MD5 f4146b4f048bdeed5f2d3cabe816bb0b Graph-0.20.101.ebuild 516
+MD5 f25caeabe8ab991660f39f9292a11ec6 Graph-0.20.105.ebuild 622
+MD5 45c74e340ac2ba7aa79c92f491003594 files/digest-Graph-0.63 61
+MD5 a71dcc0962a8adef82720ed56da486be files/digest-Graph-0.20.101 64
+MD5 6b956a3803d81868f15408ac1e2a3561 files/digest-Graph-0.20.105 64
diff --git a/dev-perl/Graph/files/digest-Graph-0.20101 b/dev-perl/Graph/files/digest-Graph-0.20.101
index 5ea75a1fcbd2..5ea75a1fcbd2 100644
--- a/dev-perl/Graph/files/digest-Graph-0.20101
+++ b/dev-perl/Graph/files/digest-Graph-0.20.101
diff --git a/dev-perl/Graph/files/digest-Graph-0.20105 b/dev-perl/Graph/files/digest-Graph-0.20.105
index e4dc67c8b7c2..e4dc67c8b7c2 100644
--- a/dev-perl/Graph/files/digest-Graph-0.20105
+++ b/dev-perl/Graph/files/digest-Graph-0.20.105
diff --git a/dev-perl/Graph/files/digest-Graph-0.63 b/dev-perl/Graph/files/digest-Graph-0.63
new file mode 100644
index 000000000000..8ea4acd19fd2
--- /dev/null
+++ b/dev-perl/Graph/files/digest-Graph-0.63
@@ -0,0 +1 @@
+MD5 b0c83323cad3b9589500f51ff2ad4bc1 Graph-0.63.tar.gz 91700