summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2012-06-10 16:33:37 +0000
committerTorsten Veller <tove@gentoo.org>2012-06-10 16:33:37 +0000
commit45f8f83723c585b7a2aa1c761a16206ef7db1c21 (patch)
treec79890286656a85cded0d5e3de1c9411cd3cde0c /dev-perl/DBD-SQLite/DBD-SQLite-1.370.0.ebuild
parent[bump] dev-perl/Convert-ASN1-0.260.0 (diff)
downloadgentoo-2-45f8f83723c585b7a2aa1c761a16206ef7db1c21.tar.gz
gentoo-2-45f8f83723c585b7a2aa1c761a16206ef7db1c21.tar.bz2
gentoo-2-45f8f83723c585b7a2aa1c761a16206ef7db1c21.zip
[bump] dev-perl/DBD-SQLite-1.370.0
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/DBD-SQLite/DBD-SQLite-1.370.0.ebuild')
-rw-r--r--dev-perl/DBD-SQLite/DBD-SQLite-1.370.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-perl/DBD-SQLite/DBD-SQLite-1.370.0.ebuild b/dev-perl/DBD-SQLite/DBD-SQLite-1.370.0.ebuild
new file mode 100644
index 000000000000..b0aa78254877
--- /dev/null
+++ b/dev-perl/DBD-SQLite/DBD-SQLite-1.370.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/DBD-SQLite/DBD-SQLite-1.370.0.ebuild,v 1.1 2012/06/10 16:33:37 tove Exp $
+
+EAPI=4
+
+MODULE_AUTHOR=ADAMK
+MODULE_VERSION=1.37
+inherit perl-module
+
+DESCRIPTION="Self Contained RDBMS in a DBI Driver"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-db/sqlite-3.6.22[extensions]
+ >=dev-perl/DBI-1.57
+ !<dev-perl/DBD-SQLite-1
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=virtual/perl-Test-Simple-0.86
+ )
+"
+
+SRC_TEST="do"
+
+src_prepare() {
+ perl-module_src_prepare
+ sed -i 's/^if ( 0 )/if ( 1 )/' "${S}"/Makefile.PL || die
+ # remove bundled sqlite (rt.cpan#61361)
+ for i in sqlite3{.c,.h,ext.h} ; do
+ rm ${i} || die
+ sed -i -e "/^${i}\$/d" MANIFEST || die
+ done
+
+ myconf="SQLITE_LOCATION=${EPREFIX}/usr"
+}