summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-08-25 07:20:20 +0000
committerTorsten Veller <tove@gentoo.org>2010-08-25 07:20:20 +0000
commitea5f8e3b518e01b0e7b911048e3b7928f75d6bb8 (patch)
treed28bf0f8ede2e9a9f02685c11832070585d80c8d /dev-perl/B-OPCheck
parentVersion bump: fixed missing StringIO exception in download. (diff)
downloadgentoo-2-ea5f8e3b518e01b0e7b911048e3b7928f75d6bb8.tar.gz
gentoo-2-ea5f8e3b518e01b0e7b911048e3b7928f75d6bb8.tar.bz2
gentoo-2-ea5f8e3b518e01b0e7b911048e3b7928f75d6bb8.zip
Version bump
(Portage version: 2.2_rc69/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/B-OPCheck')
-rw-r--r--dev-perl/B-OPCheck/B-OPCheck-0.29.ebuild22
-rw-r--r--dev-perl/B-OPCheck/ChangeLog10
-rw-r--r--dev-perl/B-OPCheck/files/0.29-Perl_check_t.patch15
3 files changed, 45 insertions, 2 deletions
diff --git a/dev-perl/B-OPCheck/B-OPCheck-0.29.ebuild b/dev-perl/B-OPCheck/B-OPCheck-0.29.ebuild
new file mode 100644
index 000000000000..3c4eb23e2989
--- /dev/null
+++ b/dev-perl/B-OPCheck/B-OPCheck-0.29.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/B-OPCheck/B-OPCheck-0.29.ebuild,v 1.1 2010/08/25 07:20:20 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=FLORA
+inherit perl-module
+
+DESCRIPTION="PL_check hacks using Perl callbacks"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-perl/B-Utils-0.08
+ dev-perl/Scope-Guard"
+DEPEND="${RDEPEND}
+ >=dev-perl/extutils-depends-0.302"
+
+PATCHES=( "${FILESDIR}"/0.29-Perl_check_t.patch )
+SRC_TEST=do
diff --git a/dev-perl/B-OPCheck/ChangeLog b/dev-perl/B-OPCheck/ChangeLog
index 6c2886c6ec42..ddf70008e8cc 100644
--- a/dev-perl/B-OPCheck/ChangeLog
+++ b/dev-perl/B-OPCheck/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-perl/B-OPCheck
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-perl/B-OPCheck/ChangeLog,v 1.1 2009/06/23 07:34:08 robbat2 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/B-OPCheck/ChangeLog,v 1.2 2010/08/25 07:20:20 tove Exp $
+
+*B-OPCheck-0.29 (25 Aug 2010)
+
+ 25 Aug 2010; Torsten Veller <tove@gentoo.org>
+ +files/0.29-Perl_check_t.patch, +B-OPCheck-0.29.ebuild:
+ Version bump
*B-OPCheck-0.27 (23 Jun 2009)
diff --git a/dev-perl/B-OPCheck/files/0.29-Perl_check_t.patch b/dev-perl/B-OPCheck/files/0.29-Perl_check_t.patch
new file mode 100644
index 000000000000..77cec367f273
--- /dev/null
+++ b/dev-perl/B-OPCheck/files/0.29-Perl_check_t.patch
@@ -0,0 +1,15 @@
+https://rt.cpan.org/Public/Bug/Display.html?id=57356
+
+--- B-OPCheck-0.29/OPCheck.xs
++++ B-OPCheck-0.29/OPCheck.xs
+@@ -12,10 +12,6 @@
+ #define NEED_sv_2pv_flags
+ #include "ppport.h"
+
+-#if PERL_VERSION < 9
+-typedef OP* (CPERLscope(*Perl_check_t)) (pTHX_ OP*);
+-#endif
+-
+ STATIC AV **OPCHECK_subs;
+ Perl_check_t *PL_check_orig;
+