summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2002-08-06 21:06:20 +0000
committerAchim Gottinger <achim@gentoo.org>2002-08-06 21:06:20 +0000
commit4ab1ef2675c611dd581dcea978f10baa06058f01 (patch)
tree06b4ca9c917ca03bf65e2de2fa27335dfd33b6af /dev-perl/AppConfig
parentunmasked pcmcia-cs-3.1.34-r8 (diff)
downloadgentoo-2-4ab1ef2675c611dd581dcea978f10baa06058f01.tar.gz
gentoo-2-4ab1ef2675c611dd581dcea978f10baa06058f01.tar.bz2
gentoo-2-4ab1ef2675c611dd581dcea978f10baa06058f01.zip
A package needed for systemimager
Diffstat (limited to 'dev-perl/AppConfig')
-rw-r--r--dev-perl/AppConfig/AppConfig-1.52.ebuild22
-rw-r--r--dev-perl/AppConfig/ChangeLog8
-rw-r--r--dev-perl/AppConfig/files/AppConfig-1.52-gentoo.diff49
-rw-r--r--dev-perl/AppConfig/files/digest-AppConfig-1.521
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-perl/AppConfig/AppConfig-1.52.ebuild b/dev-perl/AppConfig/AppConfig-1.52.ebuild
new file mode 100644
index 000000000000..3811cc3c6673
--- /dev/null
+++ b/dev-perl/AppConfig/AppConfig-1.52.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/AppConfig/AppConfig-1.52.ebuild,v 1.1 2002/08/06 21:06:20 achim Exp $
+
+inherit perl-module
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The Perl CGI Module"
+SRC_URI="http://www.cpan.org/authors/id/ABW/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Artistic | GPL-2"
+KEYWORDS="x86"
+
+src_unpack() {
+ unpack ${A}
+ patch -p0 < ${FILESDIR}/${P}-gentoo.diff
+}
+src_install() {
+ mydoc="TODO"
+ perl-module_src_install
+}
diff --git a/dev-perl/AppConfig/ChangeLog b/dev-perl/AppConfig/ChangeLog
new file mode 100644
index 000000000000..e49a8b903f98
--- /dev/null
+++ b/dev-perl/AppConfig/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for dev-perl/AppConfig
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/AppConfig/ChangeLog,v 1.1 2002/08/06 21:06:20 achim Exp $
+
+*AppConfig-1.52 (07 AUG 2002)
+
+ 07 AUG 2002; achim <achim@gentoo.org> Initial version
+
diff --git a/dev-perl/AppConfig/files/AppConfig-1.52-gentoo.diff b/dev-perl/AppConfig/files/AppConfig-1.52-gentoo.diff
new file mode 100644
index 000000000000..949a8cbe1572
--- /dev/null
+++ b/dev-perl/AppConfig/files/AppConfig-1.52-gentoo.diff
@@ -0,0 +1,49 @@
+--- AppConfig-1.52/AppConfig.pm.orig Thu Oct 29 13:08:55 1998
++++ AppConfig-1.52/AppConfig.pm Wed Aug 7 00:48:17 2002
+@@ -577,21 +577,21 @@
+
+ Used to provide an argument specification string to pass to Getopt::Long
+ via AppConfig::Getopt. E.g. "=i", ":s", "=s@". This can also be used to
+-implicitly set the ARGCOUNT value (C</^!/> = ARGCOUNT_NONE, C</@/> =
+-ARGCOUNT_LIST, C</%/ = ARGCOUNT_HASH, C</[=:].*/> = ARGCOUNT_ONE)
++implicitly set the ARGCOUNT value (C</^!/> = ARGCOUNT_NONE, C</@/> =
++ARGCOUNT_LIST, C</%/> = ARGCOUNT_HASH, C</[=:].*/> = ARGCOUNT_ONE)
+
+ =item EXPAND
+
+-Specifies which variable expansion policies should be used when parsing
++Specifies which variable expansion policies should be used when parsing
+ configuration files. Constants in C<:argcount> tag set define EXPAND_NONE
+-- no expansion (default), EXPAND_VAR - expand C<$var> or C<$(var)> as
+-other AppConfig variables, EXPAND_UID - expand C<~uid> as user's home
++- no expansion (default), EXPAND_VAR - expand C<$var> or C<$(var)> as
++other AppConfig variables, EXPAND_UID - expand C<~uid> as user's home
+ directory, EXPAND_ENV - expand C<${var}> as environment variable,
+ EXPAND_ALL - do all expansions. May be logically or'd.
+
+ =item VALIDATE
+
+-Regex which the intended variable value should match or code reference
++Regex which the intended variable value should match or code reference
+ which returns 1 to indicate successful validaton (variable may now be set).
+
+ =item ACTION
+@@ -602,15 +602,15 @@
+
+ =head2 COMPACT FORMAT DEFINITION
+
+-Variables can be specified using a compact format. This is identical to
++Variables can be specified using a compact format. This is identical to
+ the specification format of Getopt::Long and is of the form:
+
+ "name|alias|aliasE<lt>argopts<gt>"
+
+-The first element indicates the variable name and subsequent ALIAS
++The first element indicates the variable name and subsequent ALIAS
+ values may be added, each separated by a vertical bar '|'.
+
+-The E<lt>argopts<gt> element indicates the ARGCOUNT value and may be one of
++The E<lt>argopts<gt> element indicates the ARGCOUNT value and may be one of
+ the following;
+
+ ! ARGCOUNT_NONE
diff --git a/dev-perl/AppConfig/files/digest-AppConfig-1.52 b/dev-perl/AppConfig/files/digest-AppConfig-1.52
new file mode 100644
index 000000000000..11277ca2ec15
--- /dev/null
+++ b/dev-perl/AppConfig/files/digest-AppConfig-1.52
@@ -0,0 +1 @@
+MD5 176d2709016aee8cf651b2aebafac90b AppConfig-1.52.tar.gz 45654