summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-03-05 08:18:57 +0000
committerTorsten Veller <tove@gentoo.org>2010-03-05 08:18:57 +0000
commit4fbad9e254b1a2c3b3301a7bf436c9ed5dc0a32a (patch)
tree25c77afd52ca21e7601612d3f13ba456bb434e46 /dev-perl/Apache-Test/Apache-Test-1.31.ebuild
parentVersion bump (diff)
downloadgentoo-2-4fbad9e254b1a2c3b3301a7bf436c9ed5dc0a32a.tar.gz
gentoo-2-4fbad9e254b1a2c3b3301a7bf436c9ed5dc0a32a.tar.bz2
gentoo-2-4fbad9e254b1a2c3b3301a7bf436c9ed5dc0a32a.zip
Version bump
(Portage version: 2.2_rc64/cvs/Linux x86_64)
Diffstat (limited to 'dev-perl/Apache-Test/Apache-Test-1.31.ebuild')
-rw-r--r--dev-perl/Apache-Test/Apache-Test-1.31.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Apache-Test/Apache-Test-1.31.ebuild b/dev-perl/Apache-Test/Apache-Test-1.31.ebuild
new file mode 100644
index 000000000000..bce497e053cd
--- /dev/null
+++ b/dev-perl/Apache-Test/Apache-Test-1.31.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-perl/Apache-Test/Apache-Test-1.31.ebuild,v 1.1 2010/03/05 08:18:57 tove Exp $
+
+EAPI=2
+
+MODULE_AUTHOR=PHRED
+inherit depend.apache perl-module
+
+DESCRIPTION="Test.pm wrapper with helpers for testing Apache"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# interactive, requires interaction with the live filesystem
+SRC_TEST="skip"
+
+need_apache
+
+pkg_setup() {
+ perl-module_pkg_setup
+}
+
+src_install() {
+ # This is to avoid conflicts with a deprecated Apache::Test stepping
+ # in and causing problems/install errors
+ if [ -f "${S}"/.mypacklist ];
+ then
+ rm -f "${S}"/.mypacklist
+ fi
+ perl-module_src_install
+}