summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-04-14 19:05:09 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-04-14 19:05:09 +0000
commitf39e4c63304b81164f12b7ab0aa64e2de833b434 (patch)
tree54b7e44293f20f28bee70bc95132cd05493f8c3b /dev-ml
parentFix crash with SQL authentication, patch by Andrejs Eigus <aei@riga.ahlers.co... (diff)
downloadgentoo-2-f39e4c63304b81164f12b7ab0aa64e2de833b434.tar.gz
gentoo-2-f39e4c63304b81164f12b7ab0aa64e2de833b434.tar.bz2
gentoo-2-f39e4c63304b81164f12b7ab0aa64e2de833b434.zip
version bump
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlnet/ChangeLog8
-rw-r--r--dev-ml/ocamlnet/metadata.xml1
-rw-r--r--dev-ml/ocamlnet/ocamlnet-3.3.0_beta1.ebuild74
3 files changed, 82 insertions, 1 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index 973f90229bbf..16f129dbde4a 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocamlnet
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.46 2011/04/14 18:40:49 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.47 2011/04/14 19:05:09 aballier Exp $
+
+*ocamlnet-3.3.0_beta1 (14 Apr 2011)
+
+ 14 Apr 2011; Alexis Ballier <aballier@gentoo.org>
+ +ocamlnet-3.3.0_beta1.ebuild, metadata.xml:
+ version bump
14 Apr 2011; Alexis Ballier <aballier@gentoo.org> -ocamlnet-3.0.3.ebuild,
-ocamlnet-3.1.ebuild, -ocamlnet-3.2.ebuild:
diff --git a/dev-ml/ocamlnet/metadata.xml b/dev-ml/ocamlnet/metadata.xml
index a9af6c577fdf..6220a6cd728d 100644
--- a/dev-ml/ocamlnet/metadata.xml
+++ b/dev-ml/ocamlnet/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>ml</herd>
<use>
+ <flag name='cryptokit'>Enables encryption support via <pkg>dev-ml/cryptokit</pkg></flag>
<flag name='httpd'>Enables net-httpd web server component</flag>
<flag name='zip'>Enables netzip support to read/write gzip data using object channels</flag>
</use>
diff --git a/dev-ml/ocamlnet/ocamlnet-3.3.0_beta1.ebuild b/dev-ml/ocamlnet/ocamlnet-3.3.0_beta1.ebuild
new file mode 100644
index 000000000000..465496725a15
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-3.3.0_beta1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-3.3.0_beta1.ebuild,v 1.1 2011/04/14 19:05:09 aballier Exp $
+
+EAPI="2"
+
+inherit eutils findlib
+
+MY_P=${P/_beta/test}
+DESCRIPTION="Modules for OCaml application-level Internet protocols"
+HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="as-is GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="cryptokit gtk ssl tk httpd +ocamlopt zip"
+RESTRICT="installsources"
+
+# the auth-dh compile flag has been disabled as well, since it depends on
+# ocaml-cryptgps, which is not available.
+
+DEPEND=">=dev-ml/findlib-1.0
+ >=dev-ml/pcre-ocaml-5
+ >=dev-lang/ocaml-3.10.2[tk?,ocamlopt?]
+ cryptokit? ( dev-ml/cryptokit )
+ gtk? ( >=dev-ml/lablgtk-2 )
+ ssl? ( >=dev-ml/ocaml-ssl-0.4 )
+ zip? ( dev-ml/camlzip )
+ "
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+ocamlnet_use_with() {
+ if use $1; then
+ echo "-with-$2"
+ else
+ echo "-without-$2"
+ fi
+}
+
+ocamlnet_use_enable() {
+ if use $1; then
+ echo "-enable-$2"
+ else
+ echo "-disable-$2"
+ fi
+}
+
+src_configure() {
+ ./configure \
+ -bindir /usr/bin \
+ -datadir /usr/share/${PN} \
+ $(ocamlnet_use_enable cryptokit crypto) \
+ $(ocamlnet_use_enable gtk gtk2) \
+ $(ocamlnet_use_enable ssl ssl) \
+ $(ocamlnet_use_enable tk tcl) \
+ $(ocamlnet_use_enable zip zip) \
+ $(ocamlnet_use_with httpd nethttpd) \
+ || die "Error : econf failed!"
+}
+
+src_compile() {
+ emake -j1 all || die "make failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "make failed"
+ fi
+}
+
+src_install() {
+ export STRIP_MASK="*/bin/*"
+ findlib_src_install
+}