summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-02-24 17:42:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-02-24 17:42:23 +0000
commitccc90de047201e0833b534d09e54091684ca75f6 (patch)
tree006e1e388724044bd3016798c6a4c933f5fb9d72 /dev-ml
parentBump for #355865, thanks to Jason Wallace (diff)
downloadgentoo-2-ccc90de047201e0833b534d09e54091684ca75f6.tar.gz
gentoo-2-ccc90de047201e0833b534d09e54091684ca75f6.tar.bz2
gentoo-2-ccc90de047201e0833b534d09e54091684ca75f6.zip
version bump
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/lwt/ChangeLog10
-rw-r--r--dev-ml/lwt/files/lwt-2.2.1-args.patch15
-rw-r--r--dev-ml/lwt/lwt-2.2.1.ebuild52
3 files changed, 75 insertions, 2 deletions
diff --git a/dev-ml/lwt/ChangeLog b/dev-ml/lwt/ChangeLog
index a115eea07b8a..51a4b1599038 100644
--- a/dev-ml/lwt/ChangeLog
+++ b/dev-ml/lwt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/lwt
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/lwt/ChangeLog,v 1.10 2010/12/25 18:00:18 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lwt/ChangeLog,v 1.11 2011/02/24 17:42:23 aballier Exp $
+
+*lwt-2.2.1 (24 Feb 2011)
+
+ 24 Feb 2011; Alexis Ballier <aballier@gentoo.org> +lwt-2.2.1.ebuild,
+ +files/lwt-2.2.1-args.patch:
+ version bump
*lwt-2.2.0 (25 Dec 2010)
diff --git a/dev-ml/lwt/files/lwt-2.2.1-args.patch b/dev-ml/lwt/files/lwt-2.2.1-args.patch
new file mode 100644
index 000000000000..25aeab8dd0a4
--- /dev/null
+++ b/dev-ml/lwt/files/lwt-2.2.1-args.patch
@@ -0,0 +1,15 @@
+Index: lwt-2.2.1/discover.ml
+===================================================================
+--- lwt-2.2.1.orig/discover.ml
++++ lwt-2.2.1/discover.ml
+@@ -109,9 +109,9 @@ let compile args stub_file =
+ Sys.command
+ "%s -custom %s %s %s 2> %s"
+ !ocamlc
+- args
+ (Filename.quote stub_file)
+ (Filename.quote !caml_file)
++ args
+ (Filename.quote !log_file)
+ = 0
+
diff --git a/dev-ml/lwt/lwt-2.2.1.ebuild b/dev-ml/lwt/lwt-2.2.1.ebuild
new file mode 100644
index 000000000000..5191439580dc
--- /dev/null
+++ b/dev-ml/lwt/lwt-2.2.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/lwt/lwt-2.2.1.ebuild,v 1.1 2011/02/24 17:42:23 aballier Exp $
+
+EAPI=2
+
+inherit findlib eutils multilib base
+
+MY_P=${P/_/+}
+DESCRIPTION="Cooperative light-weight thread library for OCaml"
+SRC_URI="http://ocsigen.org/download/${MY_P}.tar.gz"
+HOMEPAGE="http://ocsigen.org/lwt"
+
+IUSE="gtk +ocamlopt +react +ssl"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ react? ( dev-ml/react )
+ dev-libs/libev
+ ssl? ( >=dev-ml/ocaml-ssl-0.4.0 )
+ gtk? ( dev-ml/lablgtk dev-libs/glib:2 )"
+
+RDEPEND="${DEPEND}
+ !<www-servers/ocsigen-1.1"
+
+SLOT="0"
+LICENSE="LGPL-2.1 LGPL-2.1-linking-exception"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}/${P}-args.patch" )
+
+oasis_use_enable() {
+ echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
+}
+
+src_configure() {
+ ./configure --prefix usr \
+ --libdir /usr/$(get_libdir) \
+ --docdir /usr/share/doc/${PF}/html \
+ --destdir "${D}" \
+ $(use_enable gtk glib) \
+ $(use_enable react) \
+ $(use_enable ssl) \
+ $(oasis_use_enable ocamlopt is_native) \
+ || die
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES* README || die
+}