summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-07-13 18:27:13 +0000
committerAlexis Ballier <aballier@gentoo.org>2015-07-13 18:27:13 +0000
commitbab55dedf500f8b8feade1910b4c300eec944438 (patch)
tree86d2c9f85c92dca42780e5b6cb6a657f9b05350d /dev-ml
parentversion bump (diff)
downloadgentoo-2-bab55dedf500f8b8feade1910b4c300eec944438.tar.gz
gentoo-2-bab55dedf500f8b8feade1910b4c300eec944438.tar.bz2
gentoo-2-bab55dedf500f8b8feade1910b4c300eec944438.zip
version bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/async/ChangeLog7
-rw-r--r--dev-ml/async/async-112.35.00.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/dev-ml/async/ChangeLog b/dev-ml/async/ChangeLog
index b8435b110dd1..929b6243d908 100644
--- a/dev-ml/async/ChangeLog
+++ b/dev-ml/async/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/async
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/ChangeLog,v 1.18 2015/03/18 17:28:15 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/ChangeLog,v 1.19 2015/07/13 18:27:13 aballier Exp $
+
+*async-112.35.00 (13 Jul 2015)
+
+ 13 Jul 2015; Alexis Ballier <aballier@gentoo.org> +async-112.35.00.ebuild:
+ version bump
*async-112.24.00 (18 Mar 2015)
diff --git a/dev-ml/async/async-112.35.00.ebuild b/dev-ml/async/async-112.35.00.ebuild
new file mode 100644
index 000000000000..d76390acf486
--- /dev/null
+++ b/dev-ml/async/async-112.35.00.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/async/async-112.35.00.ebuild,v 1.1 2015/07/13 18:27:13 aballier Exp $
+
+EAPI="5"
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Jane Street Capital's asynchronous execution library"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-4.00.0:=
+ >=dev-ml/async_kernel-${PV}:=
+ >=dev-ml/async_unix-${PV}:=
+ >=dev-ml/async_extra-${PV}:=
+ dev-ml/camlp4:=
+ "
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.0.2 dev-ml/core_bench dev-ml/pa_ounit )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ oasis_src_install
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}