summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-09-15 14:31:18 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-09-15 14:31:18 +0000
commit9f9ca035a0a2d9ae82e68c26326da988beb069d8 (patch)
treec0f8da9e361ec92795dc392b7cdf6f04386f8e77 /dev-ml
parentAdd Ubuntu wallpapers. (diff)
downloadgentoo-2-9f9ca035a0a2d9ae82e68c26326da988beb069d8.tar.gz
gentoo-2-9f9ca035a0a2d9ae82e68c26326da988beb069d8.tar.bz2
gentoo-2-9f9ca035a0a2d9ae82e68c26326da988beb069d8.zip
initial import, ebuild by Jacques-Pascal Deplaix, bug #425094
(Portage version: 2.2.0_alpha128/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlpam/ChangeLog10
-rw-r--r--dev-ml/ocamlpam/files/ocamlpam-1.1-makefile.patch17
-rw-r--r--dev-ml/ocamlpam/metadata.xml5
-rw-r--r--dev-ml/ocamlpam/ocamlpam-1.1.ebuild37
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-ml/ocamlpam/ChangeLog b/dev-ml/ocamlpam/ChangeLog
new file mode 100644
index 000000000000..6d8f6adeed20
--- /dev/null
+++ b/dev-ml/ocamlpam/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/ocamlpam
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlpam/ChangeLog,v 1.1 2012/09/15 14:31:18 aballier Exp $
+
+*ocamlpam-1.1 (15 Sep 2012)
+
+ 15 Sep 2012; Alexis Ballier <aballier@gentoo.org> +ocamlpam-1.1.ebuild,
+ +files/ocamlpam-1.1-makefile.patch, +metadata.xml:
+ initial import, ebuild by Jacques-Pascal Deplaix, bug #425094
+
diff --git a/dev-ml/ocamlpam/files/ocamlpam-1.1-makefile.patch b/dev-ml/ocamlpam/files/ocamlpam-1.1-makefile.patch
new file mode 100644
index 000000000000..c9450b7f30dc
--- /dev/null
+++ b/dev-ml/ocamlpam/files/ocamlpam-1.1-makefile.patch
@@ -0,0 +1,17 @@
+--- a/Makefile 2012-09-14 22:46:11.508415083 +0200
++++ b/Makefile 2012-09-14 22:46:34.526338371 +0200
+@@ -35,10 +35,13 @@
+
+ install:
+ install -d $(DESTDIR)/pam
+- install -m 644 -t $(DESTDIR)/pam META *.mli *.cmi *.cmx *.cma *.cmxa *.a
++ install -m 644 -t $(DESTDIR)/pam META *.mli *.cmi *.cma *.a
+ install -d $(DESTDIR)/stublibs
+ install -m 644 -t $(DESTDIR)/stublibs dll$(BASENAME).so
+
++install-opt:
++ install -m 644 -t $(DESTDIR)/pam *.cmx *.cmxa
++
+ dist: clean
+ mkdir -p $(DISTNAME)
+ -cp * $(DISTNAME)
diff --git a/dev-ml/ocamlpam/metadata.xml b/dev-ml/ocamlpam/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/ocamlpam/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/ocamlpam/ocamlpam-1.1.ebuild b/dev-ml/ocamlpam/ocamlpam-1.1.ebuild
new file mode 100644
index 000000000000..f665571f8620
--- /dev/null
+++ b/dev-ml/ocamlpam/ocamlpam-1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlpam/ocamlpam-1.1.ebuild,v 1.1 2012/09/15 14:31:18 aballier Exp $
+
+EAPI=4
+
+inherit findlib eutils
+
+DESCRIPTION="OCamlPAM - an OCaml library for PAM"
+HOMEPAGE="http://sharvil.nanavati.net/projects/ocamlpam/"
+SRC_URI="http://sharvil.nanavati.net/projects/${PN}/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.12[ocamlopt?]
+ sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ emake META
+ emake byte
+ use ocamlopt && emake opt
+}
+
+src_install() {
+ findlib_src_preinst
+ emake DESTDIR="${OCAMLFIND_DESTDIR}" install
+ use ocamlopt && emake DESTDIR="${OCAMLFIND_DESTDIR}" install-opt
+ dodoc CHANGES README
+}