summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-04-09 11:05:48 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-04-09 11:05:48 +0000
commit8d0b74b6a04f80ab1cfa8c5e4436d598aa554a44 (patch)
tree98d7d40bff29179335cf1487f7f439c8c26055c0 /dev-ml
parentVersion bump (diff)
downloadgentoo-2-8d0b74b6a04f80ab1cfa8c5e4436d598aa554a44.tar.gz
gentoo-2-8d0b74b6a04f80ab1cfa8c5e4436d598aa554a44.tar.bz2
gentoo-2-8d0b74b6a04f80ab1cfa8c5e4436d598aa554a44.zip
version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pcre-ocaml/ChangeLog10
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-6.1.0.ebuild44
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-ml/pcre-ocaml/ChangeLog b/dev-ml/pcre-ocaml/ChangeLog
index ff06a8ec2d67..41923a7dc620 100644
--- a/dev-ml/pcre-ocaml/ChangeLog
+++ b/dev-ml/pcre-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/pcre-ocaml
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.30 2009/12/07 08:06:55 aballier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.31 2010/04/09 11:05:48 aballier Exp $
+
+*pcre-ocaml-6.1.0 (09 Apr 2010)
+
+ 09 Apr 2010; Alexis Ballier <aballier@gentoo.org>
+ +pcre-ocaml-6.1.0.ebuild:
+ version bump
07 Dec 2009; Alexis Ballier <aballier@gentoo.org>
-pcre-ocaml-5.15.0.ebuild:
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-6.1.0.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-6.1.0.ebuild
new file mode 100644
index 000000000000..70a90c1d6b2a
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-6.1.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/pcre-ocaml-6.1.0.ebuild,v 1.1 2010/04/09 11:05:48 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://www.ocaml.info/ocaml_sources/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ >=dev-libs/libpcre-4.5"
+DEPEND="${RDEPEND}"
+SLOT="0"
+IUSE="examples +ocamlopt"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-6.0.1-linkopts.patch"
+}
+
+src_compile() {
+ cd "${S}/lib"
+ emake byte-code-library || die "Failed to build byte code library"
+ if use ocamlopt; then
+ emake native-code-library || die "Failed to build native code library"
+ fi
+}
+
+src_install () {
+ export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_install
+
+ # install documentation
+ dodoc README.txt Changelog
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}