summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-02-24 10:40:17 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-02-24 10:40:17 +0000
commit26405d45ebce7010e5795961479c469eed846ae9 (patch)
treeebb34e0986527c7926fa9688bfb40a1e9bf982b2 /dev-ml
parentversion bump: straighten dependencies, introduce test USE flag to block dev-u... (diff)
downloadgentoo-2-26405d45ebce7010e5795961479c469eed846ae9.tar.gz
gentoo-2-26405d45ebce7010e5795961479c469eed846ae9.tar.bz2
gentoo-2-26405d45ebce7010e5795961479c469eed846ae9.zip
version bump
(Portage version: 2.2_rc63/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/postgresql-ocaml/ChangeLog10
-rw-r--r--dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.4.ebuild42
2 files changed, 50 insertions, 2 deletions
diff --git a/dev-ml/postgresql-ocaml/ChangeLog b/dev-ml/postgresql-ocaml/ChangeLog
index 6fe427168a7f..6c475ec43268 100644
--- a/dev-ml/postgresql-ocaml/ChangeLog
+++ b/dev-ml/postgresql-ocaml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/postgresql-ocaml
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.13 2009/10/13 07:03:58 aballier Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/ChangeLog,v 1.14 2010/02/24 10:40:17 aballier Exp $
+
+*postgresql-ocaml-1.12.4 (24 Feb 2010)
+
+ 24 Feb 2010; Alexis Ballier <aballier@gentoo.org>
+ +postgresql-ocaml-1.12.4.ebuild:
+ version bump
*postgresql-ocaml-1.12.3 (13 Oct 2009)
diff --git a/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.4.ebuild b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.4.ebuild
new file mode 100644
index 000000000000..bda1562aa0b9
--- /dev/null
+++ b/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/postgresql-ocaml/postgresql-ocaml-1.12.4.ebuild,v 1.1 2010/02/24 10:40:17 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+IUSE="examples +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to PostgreSQL databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#toc9"
+
+DEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
+ >=virtual/postgresql-base-7.3
+ >=virtual/postgresql-server-7.3"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_compile() {
+ cd "${S}/lib"
+ emake -j1 byte-code-library || die "failed to build byte code library"
+ if use ocamlopt; then
+ emake -j1 native-code-library || die "failed to built nativde code library"
+ fi
+}
+
+src_install () {
+ use ocamlopt || export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_preinst
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS Changelog README.txt
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}