summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2007-03-05 18:34:49 +0000
committerAlexis Ballier <aballier@gentoo.org>2007-03-05 18:34:49 +0000
commit0fdceb1fb598b85576c018ff9c9e7b121b07c724 (patch)
tree83974d282b2835cfa2d216c3a93f6afc1c3fd2b2 /dev-ml
parentAllow ebuilds to specify GEM_SRC. From Diego Pettenò <flameeyes@gmail.com> (diff)
downloadgentoo-2-0fdceb1fb598b85576c018ff9c9e7b121b07c724.tar.gz
gentoo-2-0fdceb1fb598b85576c018ff9c9e7b121b07c724.tar.bz2
gentoo-2-0fdceb1fb598b85576c018ff9c9e7b121b07c724.zip
Version bump, ~amd64
(Portage version: 2.1.2.1)
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-ssl/ChangeLog7
-rw-r--r--dev-ml/ocaml-ssl/files/digest-ocaml-ssl-0.4.13
-rw-r--r--dev-ml/ocaml-ssl/ocaml-ssl-0.4.1.ebuild34
3 files changed, 43 insertions, 1 deletions
diff --git a/dev-ml/ocaml-ssl/ChangeLog b/dev-ml/ocaml-ssl/ChangeLog
index 89b40593a62d..7c6979f500b1 100644
--- a/dev-ml/ocaml-ssl/ChangeLog
+++ b/dev-ml/ocaml-ssl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocaml-ssl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-ssl/ChangeLog,v 1.1 2007/02/06 20:56:28 nattfodd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-ssl/ChangeLog,v 1.2 2007/03/05 18:34:49 aballier Exp $
+
+*ocaml-ssl-0.4.1 (05 Mar 2007)
+
+ 05 Mar 2007; Alexis Ballier <aballier@gentoo.org> +ocaml-ssl-0.4.1.ebuild:
+ Version bump, ~amd64
*ocaml-ssl-0.4.0 (06 Feb 2007)
diff --git a/dev-ml/ocaml-ssl/files/digest-ocaml-ssl-0.4.1 b/dev-ml/ocaml-ssl/files/digest-ocaml-ssl-0.4.1
new file mode 100644
index 000000000000..79db376d48c5
--- /dev/null
+++ b/dev-ml/ocaml-ssl/files/digest-ocaml-ssl-0.4.1
@@ -0,0 +1,3 @@
+MD5 780c969a97e55c95d12b9a8e59688978 ocaml-ssl-0.4.1.tar.gz 109012
+RMD160 675e71c5ad79b7493c8435c39ce0cbcd8325a710 ocaml-ssl-0.4.1.tar.gz 109012
+SHA256 bc1da3b6052ca92c2bc2d76b45ca33bb678246ca7453875d9a580f8e62d013f0 ocaml-ssl-0.4.1.tar.gz 109012
diff --git a/dev-ml/ocaml-ssl/ocaml-ssl-0.4.1.ebuild b/dev-ml/ocaml-ssl/ocaml-ssl-0.4.1.ebuild
new file mode 100644
index 000000000000..118655a4ebfc
--- /dev/null
+++ b/dev-ml/ocaml-ssl/ocaml-ssl-0.4.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-ssl/ocaml-ssl-0.4.1.ebuild,v 1.1 2007/03/05 18:34:49 aballier Exp $
+
+inherit findlib eutils
+
+IUSE="doc"
+
+DESCRIPTION="OCaml bindings for OpenSSL."
+SRC_URI="mirror://sourceforge/savonet/${P}.tar.gz"
+HOMEPAGE="http://savonet.sourcforge.net/wiki/OCamlLibs"
+
+DEPEND="dev-libs/openssl"
+
+RDEPEND="$DEPEND"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ findlib_src_preinst
+ emake install || die
+
+ if use doc; then
+ dohtml -r doc/html/*
+ fi
+ dodoc CHANGES README
+}