summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2004-08-18 12:17:33 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2004-08-18 12:17:33 +0000
commitb6c9412c01551114d5c2f5f18a7f8d50dbcf46dd (patch)
treede73563dbc59c0d23301b1061bdd3bfeb4dad509 /dev-ml/ounit
parentImport of camlzip, bug #50621 (Manifest recommit) (diff)
downloadgentoo-2-b6c9412c01551114d5c2f5f18a7f8d50dbcf46dd.tar.gz
gentoo-2-b6c9412c01551114d5c2f5f18a7f8d50dbcf46dd.tar.bz2
gentoo-2-b6c9412c01551114d5c2f5f18a7f8d50dbcf46dd.zip
Initial import, see bug #51255.
Diffstat (limited to 'dev-ml/ounit')
-rw-r--r--dev-ml/ounit/ChangeLog11
-rw-r--r--dev-ml/ounit/Manifest3
-rw-r--r--dev-ml/ounit/files/digest-ounit-1.0.01
-rw-r--r--dev-ml/ounit/metadata.xml5
-rw-r--r--dev-ml/ounit/ounit-1.0.0.ebuild30
5 files changed, 50 insertions, 0 deletions
diff --git a/dev-ml/ounit/ChangeLog b/dev-ml/ounit/ChangeLog
new file mode 100644
index 000000000000..4e6953f8e8db
--- /dev/null
+++ b/dev-ml/ounit/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-ml/ounit
+# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ChangeLog,v 1.1 2004/08/18 12:17:33 mattam Exp $
+
+*ounit-1.0.0 (18 Aug 2004)
+
+ 18 Aug 2004; Matthieu Sozeau <mattam@gentoo.org> metadata.xml,
+ ounit-1.0.0.ebuild:
+ OUnit is a unit test framework for ocaml, thanks to Bardur Arantsson
+ <gentoo@scientician.net> for the submission (bug #51255).
+
diff --git a/dev-ml/ounit/Manifest b/dev-ml/ounit/Manifest
new file mode 100644
index 000000000000..edefc170447f
--- /dev/null
+++ b/dev-ml/ounit/Manifest
@@ -0,0 +1,3 @@
+MD5 8b350f19c06fcabf1053b0421b7c3f5a metadata.xml 155
+MD5 50906f4125e6fcdf1cb7892846c07433 ounit-1.0.0.ebuild 772
+MD5 02270b9f85472c60819e083e602cb39a files/digest-ounit-1.0.0 61
diff --git a/dev-ml/ounit/files/digest-ounit-1.0.0 b/dev-ml/ounit/files/digest-ounit-1.0.0
new file mode 100644
index 000000000000..42b975541d57
--- /dev/null
+++ b/dev-ml/ounit/files/digest-ounit-1.0.0
@@ -0,0 +1 @@
+MD5 392114f4648f9c5a300c763abef31647 ounit-1.0.0.tar.gz 9193
diff --git a/dev-ml/ounit/metadata.xml b/dev-ml/ounit/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/ounit/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/ounit/ounit-1.0.0.ebuild b/dev-ml/ounit/ounit-1.0.0.ebuild
new file mode 100644
index 000000000000..d29a36ca5e12
--- /dev/null
+++ b/dev-ml/ounit/ounit-1.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ounit/ounit-1.0.0.ebuild,v 1.1 2004/08/18 12:17:33 mattam Exp $
+
+DESCRIPTION="Unit testing framework for OCaml"
+HOMEPAGE="http://home.wanadoo.nl/maas/ocaml/"
+SRC_URI="http://home.wanadoo.nl/maas/ocaml/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+DEPEND="dev-lang/ocaml
+ dev-ml/findlib"
+
+src_compile() {
+ emake all allopt || die "emake failed"
+}
+
+src_install() {
+ # which directory does the lib go into?
+ destdir=`ocamlfind printconf destdir`
+ # install
+ mkdir -p ${D}${destdir} || die
+ make \
+ OCAMLFIND_DESTDIR=${D}${destdir} \
+ OCAMLFIND_LDCONF=dummy install || die
+ # typo
+ mv LICENCE LICENSE
+ # install documentation
+ dodoc README LICENSE changelog
+}