summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-02-04 12:59:30 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-02-04 12:59:30 +0000
commit2070482deb08cb9da0d180d3a9cb120d636b4023 (patch)
treea79e0011f29e66dc3299c8c14857599c2ba51d8f /dev-ml/odns
parentMask www-client/chromium dev channel release. (diff)
downloadgentoo-2-2070482deb08cb9da0d180d3a9cb120d636b4023.tar.gz
gentoo-2-2070482deb08cb9da0d180d3a9cb120d636b4023.tar.bz2
gentoo-2-2070482deb08cb9da0d180d3a9cb120d636b4023.zip
initial import, ebuild by me
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/odns')
-rw-r--r--dev-ml/odns/ChangeLog10
-rw-r--r--dev-ml/odns/metadata.xml5
-rw-r--r--dev-ml/odns/odns-0.2.ebuild25
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/odns/ChangeLog b/dev-ml/odns/ChangeLog
new file mode 100644
index 000000000000..acb83735f23c
--- /dev/null
+++ b/dev-ml/odns/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/odns
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/odns/ChangeLog,v 1.1 2011/02/04 12:59:30 aballier Exp $
+
+*odns-0.2 (04 Feb 2011)
+
+ 04 Feb 2011; Alexis Ballier <aballier@gentoo.org> +odns-0.2.ebuild,
+ +metadata.xml:
+ initial import, ebuild by me
+
diff --git a/dev-ml/odns/metadata.xml b/dev-ml/odns/metadata.xml
new file mode 100644
index 000000000000..2193d772e351
--- /dev/null
+++ b/dev-ml/odns/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ml</herd>
+</pkgmetadata>
diff --git a/dev-ml/odns/odns-0.2.ebuild b/dev-ml/odns/odns-0.2.ebuild
new file mode 100644
index 000000000000..9b5712d77214
--- /dev/null
+++ b/dev-ml/odns/odns-0.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/odns/odns-0.2.ebuild,v 1.1 2011/02/04 12:59:30 aballier Exp $
+
+EAPI=3
+
+inherit findlib
+
+DESCRIPTION="OCaml library to query DNS servers"
+HOMEPAGE="http://odns.tuxfamily.org/"
+SRC_URI="http://download.tuxfamily.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt]"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ findlib_src_preinst
+ PREFIX="${D}/usr" emake install || die
+ dodoc AUTHORS README || die
+}