summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-08-02 12:56:55 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-08-02 12:56:55 +0000
commit82ca22deb7108c97639570a8dacc16d3db239a1c (patch)
tree5c4f769f36d39b2c056413e515bb67397253660a /dev-ml/ocamlsdl
parentInitial commit of basic printing software for the makerbot replicator 3d prin... (diff)
downloadgentoo-2-82ca22deb7108c97639570a8dacc16d3db239a1c.tar.gz
gentoo-2-82ca22deb7108c97639570a8dacc16d3db239a1c.tar.bz2
gentoo-2-82ca22deb7108c97639570a8dacc16d3db239a1c.zip
version bump
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/ocamlsdl')
-rw-r--r--dev-ml/ocamlsdl/ChangeLog7
-rw-r--r--dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-ml/ocamlsdl/ChangeLog b/dev-ml/ocamlsdl/ChangeLog
index ef262670d16e..66d4c2a198da 100644
--- a/dev-ml/ocamlsdl/ChangeLog
+++ b/dev-ml/ocamlsdl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocamlsdl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlsdl/ChangeLog,v 1.17 2012/06/22 12:42:30 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlsdl/ChangeLog,v 1.18 2012/08/02 12:56:55 aballier Exp $
+
+*ocamlsdl-0.9.1 (02 Aug 2012)
+
+ 02 Aug 2012; Alexis Ballier <aballier@gentoo.org> +ocamlsdl-0.9.1.ebuild:
+ version bump
*ocamlsdl-0.9.0 (22 Jun 2012)
diff --git a/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild b/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild
new file mode 100644
index 000000000000..4545d1d96c18
--- /dev/null
+++ b/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlsdl/ocamlsdl-0.9.1.ebuild,v 1.1 2012/08/02 12:56:55 aballier Exp $
+
+inherit findlib
+
+DESCRIPTION="OCaml SDL Bindings"
+
+HOMEPAGE="http://ocamlsdl.sourceforge.net"
+SRC_URI="mirror://sourceforge/ocamlsdl/${P}.tar.gz"
+LICENSE="LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc opengl truetype" #noimage nomixer
+
+DEPEND=">=dev-lang/ocaml-3.04
+>=media-libs/libsdl-1.2
+opengl? ( >=dev-ml/lablgl-0.98 )
+>=media-libs/sdl-mixer-1.2
+>=media-libs/sdl-image-1.2
+truetype? ( >=media-libs/sdl-ttf-2.0 )"
+
+src_compile() {
+ myconf=""
+ if use opengl; then
+ destdir=`ocamlfind printconf destdir`
+ lablgldir=`find ${destdir} -name "lablgl" -or -name "lablGL"`
+ if [ -z "${lablgldir}" ]; then
+ destdir=`ocamlc -where`
+ lablgldir=`find ${destdir} -name "lablgl" -or -name "lablGL"`
+ fi
+
+ if [ ! -z "${lablgldir}" ]; then
+ myconf="--with-lablgldir=${lablgldir}"
+ fi
+ fi
+
+ #use noimage && myconf="${myconf} --without-sdl-image"
+ #use nomixer && myconf="${myconf} --without-sdl-mixer"
+
+ econf $myconf \
+ `use_enable truetype sdl-ttf` \
+ || die
+ emake all || die
+}
+
+src_install() {
+ findlib_src_install
+
+ dodoc AUTHORS NEWS README || die
+ doinfo doc/*.info* || die
+
+ if use doc; then
+ dohtml doc/html/* || die
+ fi
+}