summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-11-07 16:51:40 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-11-07 16:51:40 +0000
commit4db33b9fd688ce184392bd63946ca339c4a803c4 (patch)
tree160c9daf82f1517d299c29f40f70ec67ee250618 /dev-ml/ocamlnet
parentVersion bump. (diff)
downloadgentoo-2-4db33b9fd688ce184392bd63946ca339c4a803c4.tar.gz
gentoo-2-4db33b9fd688ce184392bd63946ca339c4a803c4.tar.bz2
gentoo-2-4db33b9fd688ce184392bd63946ca339c4a803c4.zip
version bump
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/ocamlnet')
-rw-r--r--dev-ml/ocamlnet/ChangeLog7
-rw-r--r--dev-ml/ocamlnet/ocamlnet-3.0.3.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/dev-ml/ocamlnet/ChangeLog b/dev-ml/ocamlnet/ChangeLog
index 98be5a5d73c0..1ec049fd927b 100644
--- a/dev-ml/ocamlnet/ChangeLog
+++ b/dev-ml/ocamlnet/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/ocamlnet
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.40 2010/03/09 23:17:07 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ChangeLog,v 1.41 2010/11/07 16:51:40 aballier Exp $
+
+*ocamlnet-3.0.3 (07 Nov 2010)
+
+ 07 Nov 2010; Alexis Ballier <aballier@gentoo.org> +ocamlnet-3.0.3.ebuild:
+ version bump
*ocamlnet-3.0_beta2 (09 Mar 2010)
diff --git a/dev-ml/ocamlnet/ocamlnet-3.0.3.ebuild b/dev-ml/ocamlnet/ocamlnet-3.0.3.ebuild
new file mode 100644
index 000000000000..af6dec39079b
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-3.0.3.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-3.0.3.ebuild,v 1.1 2010/11/07 16:51:40 aballier Exp $
+
+EAPI="2"
+
+inherit eutils findlib
+
+MY_P=${P/_beta/test}
+DESCRIPTION="Modules for OCaml application-level Internet protocols"
+HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="as-is GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="gtk ssl tk httpd +ocamlopt zip"
+RESTRICT="installsources"
+
+# the auth-dh compile flag has been disabled as well, since it depends on
+# ocaml-cryptgps, which is not available.
+
+DEPEND=">=dev-ml/findlib-1.0
+ >=dev-ml/pcre-ocaml-5
+ >=dev-lang/ocaml-3.10.2[tk?,ocamlopt?]
+ gtk? ( >=dev-ml/lablgtk-2 )
+ ssl? ( >=dev-ml/ocaml-ssl-0.4 )
+ zip? ( dev-ml/camlzip )
+ "
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+ocamlnet_use_with() {
+ if use $1; then
+ echo "-with-$2"
+ else
+ echo "-without-$2"
+ fi
+}
+
+ocamlnet_use_enable() {
+ if use $1; then
+ echo "-enable-$2"
+ else
+ echo "-disable-$2"
+ fi
+}
+
+src_configure() {
+ ./configure \
+ -bindir /usr/bin \
+ -datadir /usr/share/${PN} \
+ $(ocamlnet_use_enable gtk gtk2) \
+ $(ocamlnet_use_enable ssl ssl) \
+ $(ocamlnet_use_enable tk tcl) \
+ $(ocamlnet_use_enable zip zip) \
+ $(ocamlnet_use_with httpd nethttpd) \
+ || die "Error : econf failed!"
+}
+
+src_compile() {
+ emake -j1 all || die "make failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "make failed"
+ fi
+}
+
+src_install() {
+ export STRIP_MASK="*/bin/*"
+ findlib_src_install
+}