summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthieu Sozeau <mattam@gentoo.org>2005-02-17 23:30:15 +0000
committerMatthieu Sozeau <mattam@gentoo.org>2005-02-17 23:30:15 +0000
commit2eb30aa0ca4b25ae6d0949cf8e7a8ea94bdb6302 (patch)
tree1c2e3bffb560ef746f8443e4dbb7d494ed953d74 /dev-ml/ocamlnet/ocamlnet-0.98.ebuild
parentAdded to ~ppc. (diff)
downloadgentoo-2-2eb30aa0ca4b25ae6d0949cf8e7a8ea94bdb6302.tar.gz
gentoo-2-2eb30aa0ca4b25ae6d0949cf8e7a8ea94bdb6302.tar.bz2
gentoo-2-2eb30aa0ca4b25ae6d0949cf8e7a8ea94bdb6302.zip
Version bump.
Diffstat (limited to 'dev-ml/ocamlnet/ocamlnet-0.98.ebuild')
-rw-r--r--dev-ml/ocamlnet/ocamlnet-0.98.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/ocamlnet/ocamlnet-0.98.ebuild b/dev-ml/ocamlnet/ocamlnet-0.98.ebuild
new file mode 100644
index 000000000000..1d24415ac58e
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-0.98.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlnet/ocamlnet-0.98.ebuild,v 1.1 2005/02/17 23:30:15 mattam Exp $
+
+inherit findlib
+
+DESCRIPTION="Modules for O'Caml application-level Internet protocols"
+HOMEPAGE="http://ocamlnet.sourceforge.net"
+SRC_URI="mirror://sourceforge/ocamlnet/${P}.tar.gz"
+LICENSE="as-is"
+
+IUSE=""
+KEYWORDS="~x86 ~ppc"
+DEPEND=">=dev-ml/pcre-ocaml-4.31.0"
+
+S="${WORKDIR}/${P}/src"
+
+src_compile() {
+ ./configure || die
+ make all opt || die
+}
+
+src_install() {
+ findlib_src_install NET_DB_DIR=${D}${OCAML_SITELIB}/netstring
+
+ cd ${WORKDIR}/${P}
+ dodoc README
+ dohtml doc/intro/html/*
+}