summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-10-28 08:13:27 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-10-28 08:13:27 +0000
commit844ecbf88eecaa16e4fe01a9850dac1382657d8b (patch)
treebf48188f8f0e46d6d3e3e8831f94aaedd08fb265 /dev-ml/ocamlgraph
parentkeyword ~arm (diff)
downloadgentoo-2-844ecbf88eecaa16e4fe01a9850dac1382657d8b.tar.gz
gentoo-2-844ecbf88eecaa16e4fe01a9850dac1382657d8b.tar.bz2
gentoo-2-844ecbf88eecaa16e4fe01a9850dac1382657d8b.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/ocamlgraph')
-rw-r--r--dev-ml/ocamlgraph/ChangeLog10
-rw-r--r--dev-ml/ocamlgraph/files/ocamlgraph-1.8.5-installfindlib.patch38
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild62
3 files changed, 108 insertions, 2 deletions
diff --git a/dev-ml/ocamlgraph/ChangeLog b/dev-ml/ocamlgraph/ChangeLog
index 4987e1bb1271..ba19e2b4aa48 100644
--- a/dev-ml/ocamlgraph/ChangeLog
+++ b/dev-ml/ocamlgraph/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocamlgraph
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgraph/ChangeLog,v 1.13 2013/08/19 13:46:39 aballier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgraph/ChangeLog,v 1.14 2014/10/28 08:13:27 aballier Exp $
+
+*ocamlgraph-1.8.5 (28 Oct 2014)
+
+ 28 Oct 2014; Alexis Ballier <aballier@gentoo.org> +ocamlgraph-1.8.5.ebuild,
+ +files/ocamlgraph-1.8.5-installfindlib.patch:
+ version bump
19 Aug 2013; Alexis Ballier <aballier@gentoo.org> ocamlgraph-0.99b.ebuild:
eapi5, define subslot and add := dep on ocaml
diff --git a/dev-ml/ocamlgraph/files/ocamlgraph-1.8.5-installfindlib.patch b/dev-ml/ocamlgraph/files/ocamlgraph-1.8.5-installfindlib.patch
new file mode 100644
index 000000000000..30eb937069d0
--- /dev/null
+++ b/dev-ml/ocamlgraph/files/ocamlgraph-1.8.5-installfindlib.patch
@@ -0,0 +1,38 @@
+Index: ocamlgraph-1.8.5/Makefile.in
+===================================================================
+--- ocamlgraph-1.8.5.orig/Makefile.in
++++ ocamlgraph-1.8.5/Makefile.in
+@@ -417,21 +417,25 @@ ifeq (@LABLGNOMECANVAS@,yes)
+ cp -f $(VIEWER_DIR)/*.mli $(DGRAPH_DIR)/*.mli $(INSTALL_LIBDIR)
+ endif
+
++ifneq ($(WANT_OCAMLOPT),no)
++INSTALL_OPT=graph$(LIBEXT) graph.cmx $(CMXA)
++INSTALL_GTK_OPT=$(VIEWER_CMXLIB) $(VIEWER_CMXLIB:.cmx=.o) $(DGRAPH_CMXLIB) $(DGRAPH_CMXLIB:.cmx=.o) graph$(OBJEXT)
++endif
++
+ install-findlib: META
+ ifdef OCAMLFIND
+-ifeq (@LABLGNOMECANVAS@,yes)
++ifeq ($(WANT_GTK),yes)
+ $(OCAMLFIND) install ocamlgraph META \
+ $(SRCDIR)/*.mli $(VIEWER_DIR)/*.mli $(DGRAPH_DIR)/*.mli \
+- graph$(OBJEXT) graph$(LIBEXT) graph.cmx graph.cmo graph.cmi \
+- $(CMA) $(CMXA) \
+- $(VIEWER_CMXLIB) $(VIEWER_CMOLIB) $(VIEWER_CMILIB) \
+- $(VIEWER_CMXLIB:.cmx=.o) \
+- $(DGRAPH_CMXLIB) $(DGRAPH_CMOLIB) $(DGRAPH_CMILIB) \
+- $(DGRAPH_CMXLIB:.cmx=.o)
++ $(INSTALL_OPT) graph.cmo graph.cmi \
++ $(CMA) \
++ $(INSTALL_GTK_OPT) \
++ $(VIEWER_CMOLIB) $(VIEWER_CMILIB) \
++ $(DGRAPH_CMOLIB) $(DGRAPH_CMILIB)
+ else
+ $(OCAMLFIND) install ocamlgraph META \
+ $(SRCDIR)/*.mli $(VIEWER_DIR)/*.mli $(DGRAPH_DIR)/*.mli \
+- graph$(LIBEXT) graph.cmx graph.cmo graph.cmi $(CMA) $(CMXA)
++ $(INSTALL_OPT) graph.cmo graph.cmi $(CMA)
+ endif
+ endif
+
diff --git a/dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild b/dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild
new file mode 100644
index 000000000000..f6def1163626
--- /dev/null
+++ b/dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocamlgraph/ocamlgraph-1.8.5.ebuild,v 1.1 2014/10/28 08:13:27 aballier Exp $
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="O'Caml Graph library"
+HOMEPAGE="http://ocamlgraph.lri.fr/index.en.html"
+SRC_URI="http://ocamlgraph.lri.fr/download/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+RDEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ gtk? ( dev-ml/lablgtk:=[gnomecanvas,ocamlopt?] )"
+DEPEND="${RDEPEND}
+ doc? ( dev-tex/hevea dev-ml/ocamlweb )"
+IUSE="doc examples gtk +ocamlopt"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-installfindlib.patch"
+}
+
+src_compile() {
+ emake byte
+ use ocamlopt && emake opt
+
+ if use doc; then
+ emake doc
+ fi
+
+ if use gtk; then
+ emake OCAMLBEST=$(usex ocamlopt opt byte) viewer dgraph editor
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ use ocamlopt || export WANT_OCAMLOPT=no
+ use gtk && export WANT_GTK=yes
+ emake install-findlib
+
+ if use gtk ; then
+ local ext=byte
+ use ocamlopt && ext=opt
+ newbin dgraph/dgraph.${ext} ${PN}-dgraph
+ newbin editor/editor.${ext} ${PN}-editor
+ newbin view_graph/viewgraph.${ext} ${PN}-viewgraph
+ fi
+
+ dodoc README CREDITS FAQ CHANGES
+ if use doc; then
+ dohtml doc/*
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}