summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-12-15 23:56:41 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-12-15 23:56:41 +0000
commitc7f5999b1aae382452d374e55e6304762ccc63d3 (patch)
treefbf0fb3fa234c84503fcc210a9119fd5c1918729 /dev-ml/findlib
parentadding xemacs-21.4.10-r1.ebuild (diff)
downloadgentoo-2-c7f5999b1aae382452d374e55e6304762ccc63d3.tar.gz
gentoo-2-c7f5999b1aae382452d374e55e6304762ccc63d3.tar.bz2
gentoo-2-c7f5999b1aae382452d374e55e6304762ccc63d3.zip
new package - OCaml tool to find/use non-standard packages.
Diffstat (limited to 'dev-ml/findlib')
-rw-r--r--dev-ml/findlib/ChangeLog10
-rw-r--r--dev-ml/findlib/files/digest-findlib-0.81
-rw-r--r--dev-ml/findlib/findlib-0.8.ebuild34
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/findlib/ChangeLog b/dev-ml/findlib/ChangeLog
new file mode 100644
index 000000000000..143d52e1ce89
--- /dev/null
+++ b/dev-ml/findlib/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-ml/findlib
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/ChangeLog,v 1.1 2002/12/15 23:56:41 george Exp $
+
+*findlib-0.8.ebuild (15 äÅË 2002)
+
+ 15 Dec 2002; George Shapovalov <george@gentoo.org> ChangeLog, findlib-0.8.ebuild, files/digest-findlib-0.8 :
+ initial release
+ OCaml tool to find/use non-standard packages.
+ ebuild submitted by Matthieu Sozeau <mattam@netcourrier.com>
diff --git a/dev-ml/findlib/files/digest-findlib-0.8 b/dev-ml/findlib/files/digest-findlib-0.8
new file mode 100644
index 000000000000..b7732f7bd4f1
--- /dev/null
+++ b/dev-ml/findlib/files/digest-findlib-0.8
@@ -0,0 +1 @@
+MD5 6fd9506464198c8f543b0f5ec8d44d55 findlib-0.8.tar.gz 158006
diff --git a/dev-ml/findlib/findlib-0.8.ebuild b/dev-ml/findlib/findlib-0.8.ebuild
new file mode 100644
index 000000000000..ce0db39556d7
--- /dev/null
+++ b/dev-ml/findlib/findlib-0.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/findlib/findlib-0.8.ebuild,v 1.1 2002/12/15 23:56:41 george Exp $
+
+IUSE=""
+
+DESCRIPTION="OCaml tool to find/use non-standard packages."
+HOMEPAGE="http://www.ocaml-programming.de/programming/download-caml.html"
+SRC_URI="http://www.ocaml-programming.de/packages/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="dev-lang/ocaml"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ ./configure -bindir /usr/bin -mandir /usr/share/man \
+ -sitelib /usr/lib/ocaml/site-packages/ \
+ -config /usr/lib/ocaml/site-packages/findlib/findlib.conf || die "configure failed"
+
+ make all || die
+ make opt || die # optimized code
+}
+
+src_install() {
+ make PREFIX=${D} install || die
+
+ cd ${S}/doc
+ dodoc QUICKSTART README
+ dohtml html/*
+}