summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-10-24 07:39:26 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-10-24 07:39:26 +0000
commit766799166ffd78014ccd6eb2201218c363c7fd2b (patch)
treedaa4c9c01f2054c9b38d356e4bc1084861d7789d /dev-ml/cppo
parentremove old (diff)
downloadgentoo-2-766799166ffd78014ccd6eb2201218c363c7fd2b.tar.gz
gentoo-2-766799166ffd78014ccd6eb2201218c363c7fd2b.tar.bz2
gentoo-2-766799166ffd78014ccd6eb2201218c363c7fd2b.zip
version bump
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/cppo')
-rw-r--r--dev-ml/cppo/ChangeLog9
-rw-r--r--dev-ml/cppo/cppo-1.0.1.ebuild31
2 files changed, 38 insertions, 2 deletions
diff --git a/dev-ml/cppo/ChangeLog b/dev-ml/cppo/ChangeLog
index 367687348cd8..da9cae602de9 100644
--- a/dev-ml/cppo/ChangeLog
+++ b/dev-ml/cppo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/cppo
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/cppo/ChangeLog,v 1.1 2013/07/23 18:05:39 aballier Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/cppo/ChangeLog,v 1.2 2014/10/24 07:39:26 aballier Exp $
+
+*cppo-1.0.1 (24 Oct 2014)
+
+ 24 Oct 2014; Alexis Ballier <aballier@gentoo.org> +cppo-1.0.1.ebuild:
+ version bump
*cppo-0.9.3 (23 Jul 2013)
diff --git a/dev-ml/cppo/cppo-1.0.1.ebuild b/dev-ml/cppo/cppo-1.0.1.ebuild
new file mode 100644
index 000000000000..ec942b562354
--- /dev/null
+++ b/dev-ml/cppo/cppo-1.0.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/cppo/cppo-1.0.1.ebuild,v 1.1 2014/10/24 07:39:26 aballier Exp $
+
+EAPI="5"
+
+inherit findlib
+
+DESCRIPTION="An equivalent of the C preprocessor for OCaml programs"
+HOMEPAGE="http://mjambon.com/cppo.html"
+SRC_URI="http://mjambon.com/releases/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.12:="
+DEPEND="${RDEPEND}"
+
+src_install() {
+ findlib_src_preinst
+ mkdir -p "${ED}"/usr/bin
+ emake PREFIX="${ED}"/usr install
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}