summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-05-19 06:12:51 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-05-19 06:12:51 +0000
commit2cbbb8acbe566a47d8f31469f02a157eacd5a688 (patch)
tree445551f20e20f7c57a61c70d592dd51e13fd7f24 /dev-ml/camlp5
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-2cbbb8acbe566a47d8f31469f02a157eacd5a688.tar.gz
gentoo-2-2cbbb8acbe566a47d8f31469f02a157eacd5a688.tar.bz2
gentoo-2-2cbbb8acbe566a47d8f31469f02a157eacd5a688.zip
version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/camlp5')
-rw-r--r--dev-ml/camlp5/ChangeLog7
-rw-r--r--dev-ml/camlp5/camlp5-5.14.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-ml/camlp5/ChangeLog b/dev-ml/camlp5/ChangeLog
index e262878d530c..46d8ab53627b 100644
--- a/dev-ml/camlp5/ChangeLog
+++ b/dev-ml/camlp5/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/camlp5
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.41 2010/04/09 11:24:50 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/ChangeLog,v 1.42 2010/05/19 06:12:51 aballier Exp $
+
+*camlp5-5.14 (19 May 2010)
+
+ 19 May 2010; Alexis Ballier <aballier@gentoo.org> +camlp5-5.14.ebuild:
+ version bump
*camlp5-5.13 (09 Apr 2010)
diff --git a/dev-ml/camlp5/camlp5-5.14.ebuild b/dev-ml/camlp5/camlp5-5.14.ebuild
new file mode 100644
index 000000000000..e0203ea8a105
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-5.14.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlp5/camlp5-5.14.ebuild,v 1.1 2010/05/19 06:12:51 aballier Exp $
+
+EAPI="2"
+
+inherit multilib findlib eutils
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="http://pauillac.inria.fr/~ddr/camlp5/"
+SRC_URI="http://pauillac.inria.fr/~ddr/camlp5/distrib/src/${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc +ocamlopt"
+
+DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ ./configure \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile(){
+ emake -j1 || die "emake failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "Compiling native code programs failed"
+ emake -j1 opt.opt || die "Compiling native code programs failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META || die "failed to install META file for findlib support"
+
+ use doc && dohtml -r doc/*
+
+ dodoc CHANGES DEVEL ICHANGES README UPGRADING MODE
+}