summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-04-10 12:22:14 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-04-10 12:22:14 +0000
commit6a5e848747f2e02edbb0511fc8ab71b5a07ad18d (patch)
treef1b74fb05be0a9a4ded7a8021f11acb064f31027 /dev-ml/camlimages
parentVersion bump (diff)
downloadgentoo-2-6a5e848747f2e02edbb0511fc8ab71b5a07ad18d.tar.gz
gentoo-2-6a5e848747f2e02edbb0511fc8ab71b5a07ad18d.tar.bz2
gentoo-2-6a5e848747f2e02edbb0511fc8ab71b5a07ad18d.zip
version bump
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/camlimages')
-rw-r--r--dev-ml/camlimages/ChangeLog10
-rw-r--r--dev-ml/camlimages/camlimages-4.0.1.ebuild74
-rw-r--r--dev-ml/camlimages/files/camlimages-4.0.1-libpng15.patch67
3 files changed, 149 insertions, 2 deletions
diff --git a/dev-ml/camlimages/ChangeLog b/dev-ml/camlimages/ChangeLog
index e665b418de1d..c0a0e556bd15 100644
--- a/dev-ml/camlimages/ChangeLog
+++ b/dev-ml/camlimages/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/camlimages
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlimages/ChangeLog,v 1.30 2011/02/28 18:10:41 ssuominen Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlimages/ChangeLog,v 1.31 2012/04/10 12:22:14 aballier Exp $
+
+*camlimages-4.0.1 (10 Apr 2012)
+
+ 10 Apr 2012; Alexis Ballier <aballier@gentoo.org> +camlimages-4.0.1.ebuild,
+ +files/camlimages-4.0.1-libpng15.patch:
+ version bump
28 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> camlimages-3.0.2.ebuild:
Use virtual/jpeg.
diff --git a/dev-ml/camlimages/camlimages-4.0.1.ebuild b/dev-ml/camlimages/camlimages-4.0.1.ebuild
new file mode 100644
index 000000000000..414aad32fe7a
--- /dev/null
+++ b/dev-ml/camlimages/camlimages-4.0.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/camlimages/camlimages-4.0.1.ebuild,v 1.1 2012/04/10 12:22:14 aballier Exp $
+
+EAPI=4
+
+inherit eutils vcs-snapshot findlib multilib
+
+DESCRIPTION="An image manipulation library for ocaml"
+HOMEPAGE="http://gallium.inria.fr/camlimages/"
+SRC_URI="http://bitbucket.org/camlspotter/camlimages/get/v4.0.1.tar.bz2 -> ${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc gif gs gtk jpeg png tiff truetype X xpm zlib"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[X?,ocamlopt]
+ gif? ( media-libs/giflib )
+ gtk? ( dev-ml/lablgtk )
+ gs? ( app-text/ghostscript-gpl )
+ jpeg? ( virtual/jpeg )
+ tiff? ( media-libs/tiff )
+ png? ( >=media-libs/libpng-1.4 )
+ truetype? ( >=media-libs/freetype-2 )
+ xpm? ( x11-libs/libXpm )
+ X? ( x11-apps/rgb )
+ zlib? ( sys-libs/zlib )
+ "
+DEPEND="${DEPEND}
+ doc? ( dev-python/sphinx[latex] )
+ dev-util/omake
+ dev-ml/findlib"
+
+REQUIRED_USE="png? ( zlib )"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-libpng15.patch"
+}
+
+camlimages_disable_have() {
+ if ! use $1 ; then
+ sed -i -e "s/^[[:space:]]*HAVE_$2.*\$/ HAVE_$2 = false/" OMakefile || die
+ sed -i -e "s/^[[:space:]]*SUPPORT_$2.*\$/\0\n SUPPORT_$2 = false/" OMakefile || die
+ fi
+}
+
+src_configure() {
+ camlimages_disable_have gif GIF
+ camlimages_disable_have zlib Z
+ camlimages_disable_have png PNG
+ camlimages_disable_have jpeg JPEG
+ camlimages_disable_have tiff TIFF
+ camlimages_disable_have xpm XPM
+ camlimages_disable_have gs PS
+ camlimages_disable_have gtk LABLGTK2
+ camlimages_disable_have X GRAPHICS
+ camlimages_disable_have X RGB_TXT
+ camlimages_disable_have truetype FREETYPE
+}
+
+src_compile() {
+ omake --force-dotomake || die
+ if use doc ; then
+ sphinx-build doc/sphinx sphinxdoc || die
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ omake --force-dotomake DESTDIR="${D}" install || die
+ dodoc README
+ use doc && dohtml -r sphinxdoc/*
+}
diff --git a/dev-ml/camlimages/files/camlimages-4.0.1-libpng15.patch b/dev-ml/camlimages/files/camlimages-4.0.1-libpng15.patch
new file mode 100644
index 000000000000..460b3c11edf1
--- /dev/null
+++ b/dev-ml/camlimages/files/camlimages-4.0.1-libpng15.patch
@@ -0,0 +1,67 @@
+# HG changeset patch
+# User Jun Furuse <jun.furuse@gmail.com>
+# Date 1329456902 -28800
+# Node ID 4ecc49e79369d413af732c4feeab7128e2f6f11a
+# Parent 9b5cbcd07ae5a88561fbaa4eec3938af5e8b7574
+png_ptr->jmpbuf => png_jmpbuf(png_ptr)
+
+diff -r 9b5cbcd07ae5 -r 4ecc49e79369 src/pngread.c
+--- a/src/pngread.c Tue Jan 31 22:40:50 2012 +0900
++++ b/src/pngread.c Fri Feb 17 13:35:02 2012 +0800
+@@ -69,7 +69,7 @@
+ }
+
+ /* error handling */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+ fclose(fp);
+@@ -134,7 +134,7 @@
+ png_set_rows(png_ptr, info_ptr, row_pointers);
+
+ /* Later, we can return something */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+ fclose(fp);
+@@ -243,7 +243,7 @@
+ }
+
+ /* error handling */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+ fclose(fp);
+@@ -302,7 +302,7 @@
+ png_set_rows(png_ptr, info_ptr, row_pointers);
+
+ /* Later, we can return something */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_read_struct(&png_ptr, &info_ptr, (png_infopp)NULL);
+ fclose(fp);
+diff -r 9b5cbcd07ae5 -r 4ecc49e79369 src/pngwrite.c
+--- a/src/pngwrite.c Tue Jan 31 22:40:50 2012 +0900
++++ b/src/pngwrite.c Fri Feb 17 13:35:02 2012 +0800
+@@ -62,7 +62,7 @@
+ }
+
+ /* error handling */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+ fclose(fp);
+@@ -171,7 +171,7 @@
+ }
+
+ /* error handling */
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ /* Free all of the memory associated with the png_ptr and info_ptr */
+ png_destroy_write_struct(&png_ptr, &info_ptr);
+ fclose(fp);