summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-06-06 11:34:22 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-06-06 11:34:22 +0000
commit799c15548bd42bd9f24ae46bb6112080556ffe1e (patch)
tree9ec9695b9e5e3e18c64978e2a7218e1973afb780 /dev-lua
parentFix perl dependency - bug #341981. EAPI bump. Remove old. (diff)
downloadgentoo-2-799c15548bd42bd9f24ae46bb6112080556ffe1e.tar.gz
gentoo-2-799c15548bd42bd9f24ae46bb6112080556ffe1e.tar.bz2
gentoo-2-799c15548bd42bd9f24ae46bb6112080556ffe1e.zip
Version bump luaexpat to 1.2.0.
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luaexpat/ChangeLog10
-rw-r--r--dev-lua/luaexpat/files/luaexpat-1.2.0-makefile.patch19
-rw-r--r--dev-lua/luaexpat/luaexpat-1.2.0.ebuild46
3 files changed, 73 insertions, 2 deletions
diff --git a/dev-lua/luaexpat/ChangeLog b/dev-lua/luaexpat/ChangeLog
index 2a5d3c02c489..cdd2661241d0 100644
--- a/dev-lua/luaexpat/ChangeLog
+++ b/dev-lua/luaexpat/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lua/luaexpat
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/luaexpat/ChangeLog,v 1.2 2010/11/05 20:51:36 rafaelmartins Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luaexpat/ChangeLog,v 1.3 2011/06/06 11:34:21 djc Exp $
+
+*luaexpat-1.2.0 (06 Jun 2011)
+
+ 06 Jun 2011; Dirkjan Ochtman <djc@gentoo.org> +luaexpat-1.2.0.ebuild,
+ +files/luaexpat-1.2.0-makefile.patch:
+ Version bump to 1.2.0.
05 Nov 2010; Rafael G. Martins <rafaelmartins@gentoo.org>
+files/luaexpat-1.1-makefile.patch:
diff --git a/dev-lua/luaexpat/files/luaexpat-1.2.0-makefile.patch b/dev-lua/luaexpat/files/luaexpat-1.2.0-makefile.patch
new file mode 100644
index 000000000000..b503a4e032d9
--- /dev/null
+++ b/dev-lua/luaexpat/files/luaexpat-1.2.0-makefile.patch
@@ -0,0 +1,19 @@
+--- makefile.old 2006-06-08 20:41:48.000000000 +0000
++++ makefile 2009-10-26 14:19:08.000000000 +0000
+@@ -18,11 +18,11 @@
+ $(CC) -c $(CFLAGS) -o $@ $(COMPAT_DIR)/compat-5.1.c
+
+ install:
+- mkdir -p $(LUA_LIBDIR)
+- cp src/$(LIBNAME) $(LUA_LIBDIR)
+- cd $(LUA_LIBDIR); ln -f -s $(LIBNAME) $T.so
+- mkdir -p $(LUA_DIR)/$T
+- cp src/$T/lom.lua $(LUA_DIR)/$T
++ mkdir -p $(DESTDIR)$(LUA_LIBDIR)
++ cp src/$(LIBNAME) $(DESTDIR)$(LUA_LIBDIR)
++ cd $(DESTDIR)$(LUA_LIBDIR); ln -f -s $(LIBNAME) $T.so
++ mkdir -p $(DESTDIR)$(LUA_DIR)/$T
++ cp src/$T/lom.lua $(DESTDIR)$(LUA_DIR)/$T
+
+ clean:
+ rm -f src/$(LIBNAME) $(OBJS)
diff --git a/dev-lua/luaexpat/luaexpat-1.2.0.ebuild b/dev-lua/luaexpat/luaexpat-1.2.0.ebuild
new file mode 100644
index 000000000000..6759d45ed83b
--- /dev/null
+++ b/dev-lua/luaexpat/luaexpat-1.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luaexpat/luaexpat-1.2.0.ebuild,v 1.1 2011/06/06 11:34:21 djc Exp $
+
+EAPI=2
+
+inherit multilib toolchain-funcs flag-o-matic eutils
+
+DESCRIPTION="LuaExpat is a SAX XML parser based on the Expat library."
+HOMEPAGE="http://www.keplerproject.org/luaexpat/"
+SRC_URI="http://matthewwild.co.uk/projects/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/lua-5.1[deprecated]
+ dev-libs/expat"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ sed -i -e "s#^LUA_LIBDIR=.*#LUA_LIBDIR=$(pkg-config --variable INSTALL_CMOD lua)#" "${S}/config"
+ sed -i -e "s#^LUA_DIR=.*#LUA_DIR=$(pkg-config --variable INSTALL_LMOD lua)#" "${S}/config"
+ sed -i -e "s#^LUA_INC=.*#LUA_INC=$(pkg-config --variable INSTALL_INC lua)#" "${S}/config"
+ sed -i -e "s#^EXPAT_INC=.*#EXPAT_INC=/usr/include#" "${S}/config"
+ sed -i -e "s#^LUA_VERSION_NUM=.*#LUA_VERSION_NUM=501#" "${S}/config"
+ epatch "${FILESDIR}/${P}-makefile.patch"
+}
+
+src_compile() {
+ append-flags -fPIC
+ emake \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ LD="$(tc-getCC) -shared" \
+ || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install failed"
+ dodoc README || die
+ dohtml -r doc/* || die
+}