summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-06-30 20:56:18 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-06-30 20:56:18 +0000
commit0be055c2f894d80396100adbcc287c9c9bc84458 (patch)
treed342b989b95cd1685782f6fc01e614a4168301d2 /dev-lua/luvit
parentSync 1.0.1 with 1.0. (diff)
downloadgentoo-2-0be055c2f894d80396100adbcc287c9c9bc84458.tar.gz
gentoo-2-0be055c2f894d80396100adbcc287c9c9bc84458.tar.bz2
gentoo-2-0be055c2f894d80396100adbcc287c9c9bc84458.zip
update live-ebuild
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-lua/luvit')
-rw-r--r--dev-lua/luvit/ChangeLog5
-rw-r--r--dev-lua/luvit/luvit-9999.ebuild27
2 files changed, 21 insertions, 11 deletions
diff --git a/dev-lua/luvit/ChangeLog b/dev-lua/luvit/ChangeLog
index bb10b9f12670..49860d195746 100644
--- a/dev-lua/luvit/ChangeLog
+++ b/dev-lua/luvit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lua/luvit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/luvit/ChangeLog,v 1.3 2013/06/30 20:44:13 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luvit/ChangeLog,v 1.4 2013/06/30 20:56:18 hasufell Exp $
+
+ 30 Jun 2013; Julian Ospald <hasufell@gentoo.org> luvit-9999.ebuild:
+ update live-ebuild
*luvit-0.6.1-r1 (30 Jun 2013)
diff --git a/dev-lua/luvit/luvit-9999.ebuild b/dev-lua/luvit/luvit-9999.ebuild
index bdf17b4099fc..d202e50d3430 100644
--- a/dev-lua/luvit/luvit-9999.ebuild
+++ b/dev-lua/luvit/luvit-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lua/luvit/luvit-9999.ebuild,v 1.2 2013/03/05 21:09:17 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lua/luvit/luvit-9999.ebuild,v 1.3 2013/06/30 20:56:18 hasufell Exp $
EAPI=5
@@ -14,11 +14,11 @@ EGIT_REPO_URI="git://github.com/luvit/luvit.git"
KEYWORDS=""
SLOT="0"
-IUSE="examples +system-libs"
+IUSE="bundled-libs examples"
# luvit Apache-2.0
# luajit MIT
# yajl BSD
-LICENSE="Apache-2.0 MIT !system-libs? ( BSD )"
+LICENSE="Apache-2.0 !bundled-libs? ( BSD MIT )"
# fails in portage environment
# succeeds if run manually
@@ -27,7 +27,8 @@ RESTRICT="test"
RDEPEND="
dev-libs/openssl:0
sys-libs/zlib
- system-libs? (
+ !bundled-libs? (
+ dev-lang/luajit:2[lua52compat]
>=dev-libs/yajl-2.0.4
)"
DEPEND="${RDEPEND}
@@ -36,11 +37,17 @@ DEPEND="${RDEPEND}
EGIT_HAS_SUBMODULES=1
src_prepare() {
- if use system-libs ; then
- MY_YAJL_VERSION=$(pkg-config --modversion yajl)
- else
+ rm -r deps/{openssl,zlib} || die
+
+ if use bundled-libs ; then
MY_YAJL_VERSION=$(git --git-dir deps/yajl/.git describe --tags)
+ MY_LUAJIT_VERSION=$(git --git-dir deps/luajit/.git describe --tags)
+ else
+ rm -r deps/{luajit,yajl} || die
+ MY_YAJL_VERSION=$($(tc-getPKG_CONFIG) --modversion yajl)
+ MY_LUAJIT_VERSION=$($(tc-getPKG_CONFIG) --modversion luajit)
fi
+
MY_HTTP_VERSION=$(git --git-dir deps/http-parser/.git describe --tags)
MY_UV_VERSION=$(git --git-dir deps/uv/.git describe --all --long | cut -f 3 -d -)
@@ -69,10 +76,10 @@ src_compile() {
DEBUG=0
WERROR=0
USE_SYSTEM_SSL=1
- # bundled luajit is compiled with special flags
- USE_SYSTEM_LUAJIT=0
USE_SYSTEM_ZLIB=1
- USE_SYSTEM_YAJL=$(usex system-libs "1" "0")
+ # bundled luajit is compiled with special flags
+ USE_SYSTEM_LUAJIT=$(usex bundled-libs "0" "1")
+ USE_SYSTEM_YAJL=$(usex bundled-libs "0" "1")
PREFIX=/usr
LIBDIR="${D}"/usr/$(get_libdir)/${PN}
DESTDIR="${D}"