summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-10-27 20:03:33 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-10-27 20:03:33 +0000
commit73ee5b467b8fbb70a047db85a82b205fe46e8323 (patch)
treeaf0b623611cd4bd4bfe87772a5435eba0877306a /dev-lisp
parentVersion bump to move wine into the normal prefix of things (/usr). The winex... (diff)
downloadgentoo-2-73ee5b467b8fbb70a047db85a82b205fe46e8323.tar.gz
gentoo-2-73ee5b467b8fbb70a047db85a82b205fe46e8323.tar.bz2
gentoo-2-73ee5b467b8fbb70a047db85a82b205fe46e8323.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/ecls-cvs/ChangeLog5
-rw-r--r--dev-lisp/ecls-cvs/ecls-cvs-1.ebuild17
2 files changed, 14 insertions, 8 deletions
diff --git a/dev-lisp/ecls-cvs/ChangeLog b/dev-lisp/ecls-cvs/ChangeLog
index e4f09358d092..6f226c6a8b4c 100644
--- a/dev-lisp/ecls-cvs/ChangeLog
+++ b/dev-lisp/ecls-cvs/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-lisp/ecls-cvs
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls-cvs/ChangeLog,v 1.2 2004/06/24 23:58:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls-cvs/ChangeLog,v 1.3 2004/10/27 20:03:33 mkennedy Exp $
+
+ 27 Oct 2004; Matthew Kenendy <mkennedy@gentoo.org> ecls-cvs-1.ebuild:
+ Added -k option to make for extra dubious durability.
*ecls-cvs-1 (06 Oct 2003)
diff --git a/dev-lisp/ecls-cvs/ecls-cvs-1.ebuild b/dev-lisp/ecls-cvs/ecls-cvs-1.ebuild
index 237398e7e570..9067206ce715 100644
--- a/dev-lisp/ecls-cvs/ecls-cvs-1.ebuild
+++ b/dev-lisp/ecls-cvs/ecls-cvs-1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls-cvs/ecls-cvs-1.ebuild,v 1.2 2004/06/24 23:58:42 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/ecls-cvs/ecls-cvs-1.ebuild,v 1.3 2004/10/27 20:03:33 mkennedy Exp $
ECVS_SERVER="cvs.sourceforge.net:/cvsroot/ecls"
ECVS_MODULE="ecls"
@@ -11,7 +11,7 @@ inherit cvs
IUSE="X"
S=${WORKDIR}/${ECVS_MODULE}
-DESCRIPTION="ECL stands for Embeddable Common-Lisp. The ECL project is an effort to modernize Giusseppe Attardi's ECL environment to produce an implementation of the Common-Lisp language which complies to the ANSI X3J13 definition of the language."
+DESCRIPTION="ECL is an embeddable Common Lisp implementation."
SRC_URI=""
HOMEPAGE="http://ecls.sourceforge.net/"
RESTRICT="$RESTRICT nostrip"
@@ -20,24 +20,27 @@ LICENSE="BSD LGPL-2"
KEYWORDS="~x86"
DEPEND="X? ( virtual/x11 )
- =dev-libs/gmp-4*"
+ =dev-libs/gmp-4*
+ dev-libs/boehm-gc
+ app-text/texi2html"
src_compile() {
use X && myconf="--with-x" || myconf="--without-x"
econf --enable-local-gmp \
- --disable-local-boehm \
+ --enable-local-boehm \
--with-tcp \
--with-ffi \
--with-clos-streams \
+ --with-cmu-format \
${myconf} || die
- make || die
+ make -k || true
}
src_install () {
- make bindir=${D}/usr/bin \
+ make -k bindir=${D}/usr/bin \
infodir=${D}/usr/share/info \
mandir=${D}/usr/share/man \
- libdir=${D}/usr/lib/ecl install || die
+ libdir=${D}/usr/lib/ecl install || true
dohtml doc/*.html
dodoc ANNOUNCEMENT Copyright LGPL
}