summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-28 12:36:11 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-28 12:36:11 +0000
commit2ddc5a3e9dbe7a74d35b5d6d9bd87a14867f4785 (patch)
treeea963cea41db52bb237dbc7e3e7f1ffcd9462001 /dev-lisp/gcl
parentarm KEYWORDS (diff)
downloadgentoo-2-2ddc5a3e9dbe7a74d35b5d6d9bd87a14867f4785.tar.gz
gentoo-2-2ddc5a3e9dbe7a74d35b5d6d9bd87a14867f4785.tar.bz2
gentoo-2-2ddc5a3e9dbe7a74d35b5d6d9bd87a14867f4785.zip
needs to inherit flag-o-matic
Diffstat (limited to 'dev-lisp/gcl')
-rw-r--r--dev-lisp/gcl/gcl-2.5.3.ebuild25
1 files changed, 10 insertions, 15 deletions
diff --git a/dev-lisp/gcl/gcl-2.5.3.ebuild b/dev-lisp/gcl/gcl-2.5.3.ebuild
index 40a0a1b7f213..3dc51b0e2076 100644
--- a/dev-lisp/gcl/gcl-2.5.3.ebuild
+++ b/dev-lisp/gcl/gcl-2.5.3.ebuild
@@ -1,37 +1,33 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gcl/gcl-2.5.3.ebuild,v 1.5 2004/05/12 11:11:10 pappy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gcl/gcl-2.5.3.ebuild,v 1.6 2004/05/28 12:36:11 vapier Exp $
-inherit elisp-common
+inherit elisp-common flag-o-matic
-IUSE="emacs"
-
-S=${WORKDIR}/${P}
DESCRIPTION="GNU Common Lisp"
-SRC_URI="ftp://ftp.gnu.org/gnu/gcl/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/gcl/gcl.html"
-# uncomment and add to profiles when GCL is integrated into the common lisp controller
-# PROVIDE="virtual/commonlisp"
+SRC_URI="ftp://ftp.gnu.org/gnu/gcl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="emacs"
DEPEND=">=app-text/texi2html-1.64
>=dev-libs/gmp-4.1
virtual/tetex"
RDEPEND="${DEPEND}
emacs? ( virtual/emacs )"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
+# uncomment and add to profiles when GCL is integrated into the common lisp controller
+# PROVIDE="virtual/commonlisp"
src_unpack() {
-
unpack ${A}
sed -e "s/gcl-doc/${PF}/g" ${S}/info/makefile > ${T}/makefile
mv ${T}/makefile ${S}/info/makefile
}
src_compile() {
-
# hardened gcc may automatically use PIE building,
# which does not work for this package so far
filter-flags "-fPIC"
@@ -46,7 +42,6 @@ src_compile() {
}
src_install() {
-
make DESTDIR=${D} install || die
rm -rf ${D}/usr/lib/${P}/info