summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2008-07-03 17:14:16 +0000
committerMarijn Schouten <hkbst@gentoo.org>2008-07-03 17:14:16 +0000
commit562a3bfd0e8d3d96ca5c33f6fe6759c15501262a (patch)
tree0f6587871024c15ce04797a04999651decd4a2ac /dev-lisp/clisp
parentadd clisp:pari (diff)
downloadgentoo-2-562a3bfd0e8d3d96ca5c33f6fe6759c15501262a.tar.gz
gentoo-2-562a3bfd0e8d3d96ca5c33f6fe6759c15501262a.tar.bz2
gentoo-2-562a3bfd0e8d3d96ca5c33f6fe6759c15501262a.zip
bump
(Portage version: 2.2_rc1/cvs/Linux 2.6.23-gentoo-r8 x86_64)
Diffstat (limited to 'dev-lisp/clisp')
-rw-r--r--dev-lisp/clisp/ChangeLog28
-rw-r--r--dev-lisp/clisp/clisp-2.46.ebuild117
2 files changed, 144 insertions, 1 deletions
diff --git a/dev-lisp/clisp/ChangeLog b/dev-lisp/clisp/ChangeLog
index 4d732815497d..afefa773b0b4 100644
--- a/dev-lisp/clisp/ChangeLog
+++ b/dev-lisp/clisp/ChangeLog
@@ -1,6 +1,32 @@
# ChangeLog for dev-lisp/clisp
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.79 2008/05/21 15:59:59 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/ChangeLog,v 1.80 2008/07/03 17:14:16 hkbst Exp $
+
+*clisp-2.46 (03 Jul 2008)
+
+ 03 Jul 2008; Marijn Schouten <hkBst@gentoo.org> +clisp-2.46.ebuild:
+ bump:
+ User visible changes
+ --------------------
+ * CLISP built natively on 64-bit platforms (i.e., with 64-bit pointers)
+ now has :WORD-SIZE=64 in *FEATURES*.
+ See <http://clisp.cons.org/impnotes/features.html> for details.
+ * Module syscalls now offers OS:ERRNO and OS:STRERROR (for the sake of
+ FFI modules).
+ See <http://clisp.cons.org/impnotes/syscalls.html#errno> for details.
+ * Modules MIT-CLX and NEW-CLX export a new macro XLIB:WITH-OPEN-DISPLAY.
+ * Module netica has been upgraded to the Netica C API version 3.25 (from 2.15).
+ See <http://clisp.cons.org/impnotes/netica.html> for details.
+ * Module libsvm has been upgraded to the upstream version 2.86.
+ See <http://clisp.cons.org/impnotes/libsvm.html> for details.
+ * Bug fixes:
+ + Work around the absence of tgamma() on solaris. [ 1966375 ]
+ + Avoid a rare segfault on SIGHUP. [ 1956715 ]
+ + Improve module portability to systems with non-GNU make. [ 1970141 ]
+ + Fix GRAY:STREAM-READ-SEQUENCE and GRAY:STREAM-WRITE-SEQUENCE. [ 1975798 ]
+ + Fix the remaining bugs in special bindings in evaluated code on
+ TYPECODES (64-bit) platforms.
+ + Fix SOCKET:SOCKET-CONNECT with timeout to a dead port. [ 2007052 ]
21 May 2008; Tiziano Müller <dev-zero@gentoo.org> clisp-2.43-r1.ebuild,
clisp-2.44.1.ebuild, clisp-2.44.1-r1.ebuild:
diff --git a/dev-lisp/clisp/clisp-2.46.ebuild b/dev-lisp/clisp/clisp-2.46.ebuild
new file mode 100644
index 000000000000..80937fbacfc7
--- /dev/null
+++ b/dev-lisp/clisp/clisp-2.46.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/clisp/clisp-2.46.ebuild,v 1.1 2008/07/03 17:14:16 hkbst Exp $
+
+inherit flag-o-matic eutils toolchain-funcs multilib
+
+DESCRIPTION="A portable, bytecode-compiled implementation of Common Lisp"
+HOMEPAGE="http://clisp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/clisp/${P}.tar.bz2"
+LICENSE="GPL-2"
+
+# EAPI="1"
+SLOT="2"
+KEYWORDS="~amd64 ~ppc -sparc ~x86"
+IUSE="hyperspec X new-clx fastcgi gdbm gtk pari pcre postgres readline svm zlib"
+
+RDEPEND="virtual/libiconv
+ >=dev-libs/libsigsegv-2.4
+ >=dev-libs/ffcall-1.10
+ fastcgi? ( dev-libs/fcgi )
+ gdbm? ( sys-libs/gdbm )
+ gtk? ( >=x11-libs/gtk+-2.10 >=gnome-base/libglade-2.6 )
+ pari? ( >=sci-mathematics/pari-2.3.0 )
+ postgres? ( >=dev-db/postgresql-8.0 )
+ readline? ( sys-libs/readline )
+ pcre? ( dev-libs/libpcre )
+ svm? ( sci-libs/libsvm )
+ zlib? ( sys-libs/zlib )
+ X? ( new-clx? ( x11-libs/libXpm ) )
+ hyperspec? ( dev-lisp/hyperspec )"
+# berkdb? ( sys-libs/db:4.5 )
+
+DEPEND="${RDEPEND} X? ( new-clx? ( x11-misc/imake x11-proto/xextproto ) )"
+
+PDEPEND="dev-lisp/gentoo-init"
+
+PROVIDE="virtual/commonlisp"
+
+enable_modules() {
+ [[ $# = 0 ]] && die "${FUNCNAME[0]} must receive at least one argument"
+ for m in "$@" ; do
+ einfo "enabling module $m"
+ myconf="${myconf} --with-module=${m}"
+ done
+}
+
+BUILDDIR="builddir"
+
+# modules not enabled:
+# * berkdb: must figure out a way to make the configure script pick up the
+# currect version of the library and headers
+# * dirkey: fails to compile, requiring windows.h, possibly wrong #ifdefs
+# * matlab, netica: not in portage
+# * oracle: can't install oracle-instantclient
+
+src_compile() {
+ # built-in features
+ local myconf="--with-ffcall --with-dynamic-modules"
+ use readline || myconf="${myconf} --with-noreadline"
+
+ # default modules
+ enable_modules wildcard rawsock i18n
+ # optional modules
+ use elibc_glibc && enable_modules bindings/glibc
+ if use X; then
+ if use new-clx; then
+ enable_modules clx/new-clx
+ else
+ enable_modules clx/mit-clx
+ fi
+ fi
+ if use postgres; then
+ enable_modules postgresql
+ CPPFLAGS="-I $(pg_config --includedir)"
+ fi
+# if use berkdb; then
+# enable_modules berkley-db
+# CPPFLAGS="${CPPFLAGS} -I /usr/include/db4.5"
+# fi
+ use fastcgi && enable_modules fastcgi
+ use gdbm && enable_modules gdbm
+ use gtk && enable_modules gtk2
+ use pari && enable_modules pari
+ use pcre && enable_modules pcre
+ use svm && enable_modules libsvm
+ use zlib && enable_modules zlib
+
+ if use hyperspec; then
+ CLHSROOT="file:///usr/share/doc/hyperspec/HyperSpec/"
+ else
+ CLHSROOT="http://www.lispworks.com/reference/HyperSpec/"
+ fi
+
+ # configure chokes on --infodir option
+ ./configure --prefix=/usr --libdir=/usr/$(get_libdir) \
+ ${myconf} --hyperspec=${CLHSROOT} ${BUILDDIR} || die "./configure failed"
+ cd ${BUILDDIR}
+ sed -i 's,"vi","nano",g' config.lisp
+ IMPNOTES="file://${ROOT%/}/usr/share/doc/${PN}-${PVR}/html/impnotes.html"
+ sed -i "s,http://clisp.cons.org/impnotes/,${IMPNOTES},g" config.lisp
+ # parallel build fails
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ pushd ${BUILDDIR}
+ make DESTDIR="${D}" prefix=/usr install-bin || die
+ doman clisp.1
+ dodoc SUMMARY README* NEWS MAGIC.add ANNOUNCE clisp.dvi clisp.html
+ chmod a+x "${D}"/usr/$(get_libdir)/clisp-${PV/_*/}/clisp-link
+ # stripping them removes common symbols (defined but unitialised variables)
+ # which are then needed to build modules...
+ export STRIP_MASK="*/usr/$(get_libdir)/clisp-${PV}/*/*"
+ popd
+ dohtml doc/impnotes.{css,html} ${BUILDDIR}/clisp.html doc/clisp.png
+ dodoc ${BUILDDIR}/clisp.ps doc/{editors,CLOS-guide,LISP-tutorial}.txt
+}