summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2006-05-11 06:09:39 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2006-05-11 06:09:39 +0000
commitb8d61441d811d6daee58290bc884a7b3ba4e0187 (patch)
tree4d1b4bbf2689964418edb20ad169e1277327c1bc /dev-lisp/cl-ironclad/cl-ironclad-0.13.ebuild
parentmark ~ppc (Bug #130382) (diff)
downloadgentoo-2-b8d61441d811d6daee58290bc884a7b3ba4e0187.tar.gz
gentoo-2-b8d61441d811d6daee58290bc884a7b3ba4e0187.tar.bz2
gentoo-2-b8d61441d811d6daee58290bc884a7b3ba4e0187.zip
New upstream version.
(Portage version: 2.1_pre10-r5)
Diffstat (limited to 'dev-lisp/cl-ironclad/cl-ironclad-0.13.ebuild')
-rw-r--r--dev-lisp/cl-ironclad/cl-ironclad-0.13.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-lisp/cl-ironclad/cl-ironclad-0.13.ebuild b/dev-lisp/cl-ironclad/cl-ironclad-0.13.ebuild
new file mode 100644
index 000000000000..15e4d42f501d
--- /dev/null
+++ b/dev-lisp/cl-ironclad/cl-ironclad-0.13.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-ironclad/cl-ironclad-0.13.ebuild,v 1.1 2006/05/11 06:09:39 mkennedy Exp $
+
+inherit common-lisp
+
+DESCRIPTION="Ironclad is a Common Lisp library similar to OpenSSL, GNU TLS or Crypto++"
+HOMEPAGE="http://www.cliki.net/Ironclad"
+SRC_URI="http://www.cs.rice.edu/~froydnj/lisp/ironclad_${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND=""
+
+CLPACKAGE=ironclad
+
+S=${WORKDIR}/ironclad_${PV}
+
+src_install() {
+ common-lisp-install *.{lisp,asd}
+ common-lisp-system-symlink
+ insinto $CLSOURCEROOT/ironclad/test-vectors
+ doins test-vectors/*.lisp
+ dodoc README TODO NEWS LICENSE
+}