summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-08-25 04:36:51 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-08-25 04:36:51 +0000
commit8bc424680884135d88d75ebe7f14aab37b1c03a1 (patch)
tree218525cf93bccd8076d2e86578482c824021577b /dev-lisp/cl-clx/cl-clx-0.7.1.ebuild
parentMarking 2.10.1-r1 stable (x86) (diff)
downloadgentoo-2-8bc424680884135d88d75ebe7f14aab37b1c03a1.tar.gz
gentoo-2-8bc424680884135d88d75ebe7f14aab37b1c03a1.tar.bz2
gentoo-2-8bc424680884135d88d75ebe7f14aab37b1c03a1.zip
Remove old ebuilds; New upstream version.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-lisp/cl-clx/cl-clx-0.7.1.ebuild')
-rw-r--r--dev-lisp/cl-clx/cl-clx-0.7.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-lisp/cl-clx/cl-clx-0.7.1.ebuild b/dev-lisp/cl-clx/cl-clx-0.7.1.ebuild
new file mode 100644
index 000000000000..b694b0186085
--- /dev/null
+++ b/dev-lisp/cl-clx/cl-clx-0.7.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-clx/cl-clx-0.7.1.ebuild,v 1.1 2005/08/25 04:36:51 mkennedy Exp $
+
+inherit common-lisp eutils
+
+DESCRIPTION="Portable CLX"
+HOMEPAGE="http://ftp.linux.org.uk/pub/lisp/sbcl/ http://www.cliki.net/CLX"
+SRC_URI="http://ftp.linux.org.uk/pub/lisp/sbcl/clx_${PV}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+IUSE=""
+
+DEPEND="dev-lisp/common-lisp-controller"
+
+CLPACKAGE=clx
+
+S=${WORKDIR}/clx_${PV}
+
+src_install() {
+ for i in . demo test debug; do
+ insinto /usr/share/common-lisp/source/clx/${i}
+ doins ${S}/${i}/*.lisp
+ done
+ insinto /usr/share/common-lisp/source/clx
+ doins clx.asd NEWS CHANGES README README-R5 \
+ excl* sock*
+ insinto /usr/share/common-lisp/source/manual
+ doins manual/clx.texinfo
+ common-lisp-system-symlink
+ dodoc CHANGES NEWS README*
+}