summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2003-10-15 20:52:05 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2003-10-15 20:52:05 +0000
commit4fab3efbcc3496cf1a4b9de6f213fac5663da845 (patch)
tree2bc24fe3af9129a281a012f509ff25a498febb0c /dev-lisp/cl-binary-types
parent*** empty log message *** (diff)
downloadgentoo-2-4fab3efbcc3496cf1a4b9de6f213fac5663da845.tar.gz
gentoo-2-4fab3efbcc3496cf1a4b9de6f213fac5663da845.tar.bz2
gentoo-2-4fab3efbcc3496cf1a4b9de6f213fac5663da845.zip
*** empty log message ***
Diffstat (limited to 'dev-lisp/cl-binary-types')
-rw-r--r--dev-lisp/cl-binary-types/ChangeLog6
-rw-r--r--dev-lisp/cl-binary-types/Manifest4
-rw-r--r--dev-lisp/cl-binary-types/cl-binary-types-0.84.1.ebuild44
-rw-r--r--dev-lisp/cl-binary-types/files/0.84.1-gentoo.patch11
-rw-r--r--dev-lisp/cl-binary-types/files/digest-cl-binary-types-0.84.12
-rw-r--r--dev-lisp/cl-binary-types/metadata.xml5
6 files changed, 68 insertions, 4 deletions
diff --git a/dev-lisp/cl-binary-types/ChangeLog b/dev-lisp/cl-binary-types/ChangeLog
index 5c7f9bfad57b..0f5ff7e3d623 100644
--- a/dev-lisp/cl-binary-types/ChangeLog
+++ b/dev-lisp/cl-binary-types/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-lisp/cl-binary-types
# Copyright 2000-2003 Gentoo Technologies, Inc. and Matthew Kennedy <mkennedy@gentoo.org>; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-binary-types/ChangeLog,v 1.2 2003/10/15 20:47:28 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-binary-types/ChangeLog,v 1.3 2003/10/15 20:52:03 mkennedy Exp $
+
+ 15 Oct 2003; Matthew Kennedy <mkennedy@gentoo.org>
+ files/0.84.1-gentoo.patch:
+ add clisp fix to patch
*cl-binary-types-0.84.1 (15 Oct 2003)
diff --git a/dev-lisp/cl-binary-types/Manifest b/dev-lisp/cl-binary-types/Manifest
index 24f052a5a601..e8436ef85a50 100644
--- a/dev-lisp/cl-binary-types/Manifest
+++ b/dev-lisp/cl-binary-types/Manifest
@@ -1,8 +1,8 @@
MD5 9b65b0341efc8f4b29498aad23315229 metadata.xml 164
MD5 31e2cce11f8d21774f69db67d2ec0cad cl-binary-types-0.84.1.ebuild 1425
MD5 589bdddadbd8664fb4e0b0421a8bb69b cl-binary-types-0.84.ebuild 1025
-MD5 28d5cff8ab7cbab659bc7b334287e85a ChangeLog 566
+MD5 1de1f935a08937529644c7b82a6f83ba ChangeLog 674
MD5 fdbadabdd46b39bfdcefad8254042838 files/digest-cl-binary-types-0.84 68
MD5 8b540ba90685d04211514b6fba04ddc6 files/digest-cl-binary-types-0.84.1 153
MD5 bf152b8888126284672b5bb0cbd63304 files/binary-types.asd 1312
-MD5 0c9226822dcfe619f4e9fb55522044c6 files/0.84.1-gentoo.patch 663
+MD5 11bcea71f54bf124cf10323ca6660c1e files/0.84.1-gentoo.patch 1049
diff --git a/dev-lisp/cl-binary-types/cl-binary-types-0.84.1.ebuild b/dev-lisp/cl-binary-types/cl-binary-types-0.84.1.ebuild
new file mode 100644
index 000000000000..4081836d67d7
--- /dev/null
+++ b/dev-lisp/cl-binary-types/cl-binary-types-0.84.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/cl-binary-types/cl-binary-types-0.84.1.ebuild,v 1.1 2003/10/15 20:47:28 mkennedy Exp $
+
+inherit common-lisp
+
+DEB_PV=1
+
+DESCRIPTION="Binary-types is a Library for accessing binary files with fixed bit-length code-words. Binary-types provides macros that are used to declare the mapping between Common Lisp objects and some binary (i.e. octet-based) representation."
+HOMEPAGE="http://www.cliki.net/Binary-types
+ http://www.cs.uit.no/~frodef/sw/binary-types/"
+SRC_URI="http://ftp.debian.org/debian/pool/main/c/cl-binary-types/cl-binary-types_${PV}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/c/cl-binary-types/cl-binary-types_${PV}-${DEB_PV}.diff.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-lisp/common-lisp-controller
+ virtual/commonlisp"
+
+CLPACKAGE=binary-types
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ epatch cl-binary-types_${PV}-${DEB_PV}.diff
+ epatch ${FILESDIR}/${PV}-gentoo.patch
+}
+
+src_install() {
+ common-lisp-install ${FILESDIR}/binary-types.asd *.lisp
+ common-lisp-system-symlink
+ dodoc README-bitfield COPYING ChangeLog type-hierarchy.ps README example.lisp
+ do-debian-credits
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
diff --git a/dev-lisp/cl-binary-types/files/0.84.1-gentoo.patch b/dev-lisp/cl-binary-types/files/0.84.1-gentoo.patch
index e1a92cddae88..da20f49ed079 100644
--- a/dev-lisp/cl-binary-types/files/0.84.1-gentoo.patch
+++ b/dev-lisp/cl-binary-types/files/0.84.1-gentoo.patch
@@ -1,6 +1,15 @@
diff -u cl-binary-types-0.84.1.orig/binary-types.lisp cl-binary-types-0.84.1/binary-types.lisp
--- cl-binary-types-0.84.1.orig/binary-types.lisp 2002-10-25 06:20:52.000000000 -0500
-+++ cl-binary-types-0.84.1/binary-types.lisp 2003-10-15 15:38:27.770957296 -0500
++++ cl-binary-types-0.84.1/binary-types.lisp 2003-10-15 15:47:45.949101320 -0500
+@@ -1,7 +1,7 @@
+ ;;;;------------------------------------------------------------------
+ ;;;;
+ ;;;; Copyright (C) 200120001999,
+-;;;; Department of Computer Science, University of Tromsø, Norway
++;;;; Department of Computer Science, University of Tromso, Norway
+ ;;;;
+ ;;;; Filename: binary-types.lisp
+ ;;;; Description: Reading and writing of binary data in streams.
@@ -433,7 +433,7 @@
(unless (typep type 'binary-record)
(setf type (find-binary-type type)))
diff --git a/dev-lisp/cl-binary-types/files/digest-cl-binary-types-0.84.1 b/dev-lisp/cl-binary-types/files/digest-cl-binary-types-0.84.1
new file mode 100644
index 000000000000..9ea2fb3fef2d
--- /dev/null
+++ b/dev-lisp/cl-binary-types/files/digest-cl-binary-types-0.84.1
@@ -0,0 +1,2 @@
+MD5 f8c7d587976b043c2777aa80fbc5cc68 cl-binary-types_0.84.1.orig.tar.gz 18536
+MD5 177c24987328d5b1e3b1ced0cbcf28b6 cl-binary-types_0.84.1-1.diff.gz 2847
diff --git a/dev-lisp/cl-binary-types/metadata.xml b/dev-lisp/cl-binary-types/metadata.xml
new file mode 100644
index 000000000000..f418045b09c8
--- /dev/null
+++ b/dev-lisp/cl-binary-types/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>common-lisp</herd>
+</pkgmetadata>