summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-07-09 20:44:36 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-07-09 20:44:36 +0000
commitea3330bfa1ddb6cd0aab1ec5905b80765f950f51 (patch)
tree3c69722d91e4882b1c2a4b1805072c5573a0e11a /dev-libs
parentAdd CCPL-Attribution-ShareAlike-3.0 (diff)
downloadgentoo-2-ea3330bfa1ddb6cd0aab1ec5905b80765f950f51.tar.gz
gentoo-2-ea3330bfa1ddb6cd0aab1ec5905b80765f950f51.tar.bz2
gentoo-2-ea3330bfa1ddb6cd0aab1ec5905b80765f950f51.zip
Version bump.
Add correct licence. Fix SONAME and NEEDED. (Portage version: 2.1.3_rc5)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/dmalloc/ChangeLog11
-rw-r--r--dev-libs/dmalloc/dmalloc-5.5.2.ebuild50
-rw-r--r--dev-libs/dmalloc/files/digest-dmalloc-5.5.23
-rw-r--r--dev-libs/dmalloc/files/dmalloc-5.5.2-SONAME.patch13
-rw-r--r--dev-libs/dmalloc/files/dmalloc-5.5.2-respect-DESTDIR.diff100
5 files changed, 176 insertions, 1 deletions
diff --git a/dev-libs/dmalloc/ChangeLog b/dev-libs/dmalloc/ChangeLog
index 9d737b1b1141..627a06c64fae 100644
--- a/dev-libs/dmalloc/ChangeLog
+++ b/dev-libs/dmalloc/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/dmalloc
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/dmalloc/ChangeLog,v 1.29 2007/03/19 00:57:50 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dmalloc/ChangeLog,v 1.30 2007/07/09 20:44:36 drizzt Exp $
+
+*dmalloc-5.5.2 (09 Jul 2007)
+
+ 09 Jul 2007; Timothy Redaelli <drizzt@gentoo.org>
+ +files/dmalloc-5.5.2-SONAME.patch,
+ +files/dmalloc-5.5.2-respect-DESTDIR.diff, +dmalloc-5.5.2.ebuild:
+ Version bump.
+ Add correct licence.
+ Fix SONAME and NEEDED.
19 Mar 2007; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove ka0ttic from metadata.xml due to retirement.
diff --git a/dev-libs/dmalloc/dmalloc-5.5.2.ebuild b/dev-libs/dmalloc/dmalloc-5.5.2.ebuild
new file mode 100644
index 000000000000..0000f73055c1
--- /dev/null
+++ b/dev-libs/dmalloc/dmalloc-5.5.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/dmalloc/dmalloc-5.5.2.ebuild,v 1.1 2007/07/09 20:44:36 drizzt Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="A Debug Malloc Library"
+HOMEPAGE="http://dmalloc.com/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-5.3.0-fpic.patch
+ epatch "${FILESDIR}"/${P}-SONAME.patch
+ epatch "${FILESDIR}"/${P}-respect-DESTDIR.diff
+ epatch "${FILESDIR}"/${PN}-5.4.2-sandbox.patch
+
+ eautoreconf
+}
+
+src_compile() {
+ econf --enable-threads --enable-shlib || die "configure failed"
+ emake || die "emake failed"
+ cd docs && makeinfo dmalloc.texi
+}
+
+src_test() {
+ einfo "Running tests"
+ make heavy || die "make check tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ newdoc ChangeLog.1 ChangeLog
+ dodoc INSTALL NEWS README docs/NOTES docs/TODO
+ insinto /usr/share/doc/${PF}
+ doins docs/dmalloc.pdf
+ dohtml RELEASE.html docs/dmalloc.html
+ doinfo docs/dmalloc.info
+}
diff --git a/dev-libs/dmalloc/files/digest-dmalloc-5.5.2 b/dev-libs/dmalloc/files/digest-dmalloc-5.5.2
new file mode 100644
index 000000000000..979781dc57ea
--- /dev/null
+++ b/dev-libs/dmalloc/files/digest-dmalloc-5.5.2
@@ -0,0 +1,3 @@
+MD5 f92e5606c23a8092f3d5694e8d1c932e dmalloc-5.5.2.tgz 666608
+RMD160 2cfe4daa453337e0fae0656bdbdaad1214d6243d dmalloc-5.5.2.tgz 666608
+SHA256 d3be5c6eec24950cb3bd67dbfbcdf036f1278fae5fd78655ef8cdf9e911e428a dmalloc-5.5.2.tgz 666608
diff --git a/dev-libs/dmalloc/files/dmalloc-5.5.2-SONAME.patch b/dev-libs/dmalloc/files/dmalloc-5.5.2-SONAME.patch
new file mode 100644
index 000000000000..6e0dde1887d4
--- /dev/null
+++ b/dev-libs/dmalloc/files/dmalloc-5.5.2-SONAME.patch
@@ -0,0 +1,13 @@
+--- dmalloc-5.5.2.orig/configure.ac 2007-07-09 22:02:57.000000000 +0200
++++ dmalloc-5.5.2/configure.ac 2007-07-09 22:18:42.000000000 +0200
+@@ -160,8 +160,8 @@
+ ac_cv_shared_link_args='ld -shared --whole-archive -soname $@ -o $@.t'
+ elif (ld -shared -o conftest.so.t -all -soname conftest.so.t -none -lc -all conftest.a) 2>&5; then
+ ac_cv_shared_link_args='ld -shared -o $@.t -all -soname $@ -none -lc -all'
+- elif (ld -G -o conftest.so.t conftest.a) 2>&5; then
+- ac_cv_shared_link_args='ld -G -o $@.t'
++ elif (ld -G -soname $@ -o conftest.so.t conftest.a) 2>&5; then
++ ac_cv_shared_link_args='ld -G -soname $@ -o $@.t'
+ else
+ # oh well, toss an error
+ ac_cv_shared_link_args='# Could not configure shlib linking'
diff --git a/dev-libs/dmalloc/files/dmalloc-5.5.2-respect-DESTDIR.diff b/dev-libs/dmalloc/files/dmalloc-5.5.2-respect-DESTDIR.diff
new file mode 100644
index 000000000000..53571bc97b3d
--- /dev/null
+++ b/dev-libs/dmalloc/files/dmalloc-5.5.2-respect-DESTDIR.diff
@@ -0,0 +1,100 @@
+Common subdirectories: dmalloc-5.5.2.orig/contrib and dmalloc-5.5.2/contrib
+Common subdirectories: dmalloc-5.5.2.orig/docs and dmalloc-5.5.2/docs
+diff -u dmalloc-5.5.2.orig/Makefile.in dmalloc-5.5.2/Makefile.in
+--- dmalloc-5.5.2.orig/Makefile.in 2007-07-09 22:02:58.000000000 +0200
++++ dmalloc-5.5.2/Makefile.in 2007-07-09 22:06:18.000000000 +0200
+@@ -174,66 +174,66 @@
+ # rm -f configure
+
+ installdirs :
+- $(srcdir)/mkinstalldirs $(includedir) $(libdir) $(bindir)
++ $(srcdir)/mkinstalldirs $(DESTDIR)$(includedir) $(DESTDIR)$(libdir) $(DESTDIR)$(bindir)
+
+ installincs : $(HFLS)
+- $(srcdir)/mkinstalldirs $(includedir)
+- $(INSTALL_DATA) $(HFLS) $(includedir)
++ $(srcdir)/mkinstalldirs $(DESTDIR)$(includedir)
++ $(INSTALL_DATA) $(HFLS) $(DESTDIR)$(includedir)
+
+ installthsl : $(LIB_TH_SL)
+- $(srcdir)/mkinstalldirs $(libdir)
+- $(INSTALL_PROGRAM) $(LIB_TH_SL) $(libdir)
++ $(srcdir)/mkinstalldirs $(DESTDIR)$(libdir)
++ $(INSTALL_PROGRAM) $(LIB_TH_SL) $(DESTDIR)$(libdir)
+
+ installth : $(INSTALL_THREADS)
+- $(srcdir)/mkinstalldirs $(libdir)
+- $(INSTALL_PROGRAM) $(LIB_TH) $(libdir)
++ $(srcdir)/mkinstalldirs $(DESTDIR)$(libdir)
++ $(INSTALL_PROGRAM) $(LIB_TH) $(DESTDIR)$(libdir)
+ @CXX_OFF@ @echo "Enter 'make installthcxx' to install the threaded C++ library"
+ @SL_OFF@ @echo "Enter 'make installthsl' to install the threaded shared-library"
+
+ installthcxxsl : $(LIB_TH_CXX_SL)
+- $(srcdir)/mkinstalldirs $(shlibdir)
+- $(INSTALL_PROGRAM) $(LIB_TH_CXX_SL) $(shlibdir)
++ $(srcdir)/mkinstalldirs $(DESTDIR)$(shlibdir)
++ $(INSTALL_PROGRAM) $(LIB_TH_CXX_SL) $(DESTDIR)$(shlibdir)
+
+ installthcxx : $(INSTALL_TH_CXX)
+- $(srcdir)/mkinstalldirs $(libdir)
+- $(INSTALL_PROGRAM) $(LIB_TH_CXX) $(libdir)
++ $(srcdir)/mkinstalldirs $(DESTDIR)$(libdir)
++ $(INSTALL_PROGRAM) $(LIB_TH_CXX) $(DESTDIR)$(libdir)
+ @SL_OFF@ @echo "Enter 'make installthcxxsl' to install the threaded C++ shared-library"
+
+ installcxxsl : $(LIB_CXX_SL)
+- $(srcdir)/mkinstalldirs $(libdir)
+- $(INSTALL_PROGRAM) $(LIB_CXX_SL) $(libdir)
++ $(srcdir)/mkinstalldirs $(DESTDIR)$(libdir)
++ $(INSTALL_PROGRAM) $(LIB_CXX_SL) $(DESTDIR)$(libdir)
+
+ installcxx : $(INSTALL_CXX)
+- $(srcdir)/mkinstalldirs $(libdir)
+- $(INSTALL_PROGRAM) $(LIB_CXX) $(libdir)
++ $(srcdir)/mkinstalldirs $(DESTDIR)$(libdir)
++ $(INSTALL_PROGRAM) $(LIB_CXX) $(DESTDIR)$(libdir)
+ @TH_OFF@ @echo "Enter 'make installthcxx' to install the threaded C++ library"
+ @SL_OFF@ @echo "Enter 'make installcxxsl' to install the C++ shared-library"
+
+ installsl : $(LIB_SL)
+- $(srcdir)/mkinstalldirs $(shlibdir)
+- $(INSTALL_PROGRAM) $(LIB_SL) $(shlibdir)
++ $(srcdir)/mkinstalldirs $(DESTDIR)$(shlibdir)
++ $(INSTALL_PROGRAM) $(LIB_SL) $(DESTDIR)$(shlibdir)
+ @CXX_OFF@ @echo "Enter 'make installcxxsl' to install the C++ shared-library"
+ @TH_OFF@ @echo "Enter 'make installthsl' to install thread shared-library"
+
+ installlib : $(INSTALL_LIB)
+- $(srcdir)/mkinstalldirs $(libdir)
+- $(INSTALL_PROGRAM) $(LIBRARY) $(libdir)
+- @RANLIB@ $(libdir)/$(LIBRARY)
+-@SL_OFF@ @echo "Enter 'make installsl' to install $(LIB_SL) in $(shlibdir)"
++ $(srcdir)/mkinstalldirs $(DESTDIR)$(libdir)
++ $(INSTALL_PROGRAM) $(LIBRARY) $(DESTDIR)$(libdir)
++ @RANLIB@ $(DESTDIR)$(libdir)/$(LIBRARY)
++@SL_OFF@ @echo "Enter 'make installsl' to install $(LIB_SL) in $(DESTDIR)$(shlibdir)"
+ @CXX_OFF@ @echo "Enter 'make installcxx' to install the C++ library"
+ @TH_OFF@ @echo "Enter 'make installth' to install thread library"
+
+ installdocs : $(srcdir)/docs/$(HTMLFILE) $(srcdir)/docs/$(TEXIFILE) \
+ $(srcdir)/docs/$(PDFFILE)
+- $(srcdir)/mkinstalldirs $(docdir)
+- $(INSTALL_DATA) $(srcdir)/docs/$(HTMLFILE) $(docdir)
+- $(INSTALL_DATA) $(srcdir)/docs/$(TEXIFILE) $(docdir)
+- $(INSTALL_DATA) $(srcdir)/docs/$(PDFFILE) $(docdir)
++ $(srcdir)/mkinstalldirs $(DESTDIR)$(docdir)
++ $(INSTALL_DATA) $(srcdir)/docs/$(HTMLFILE) $(DESTDIR)$(docdir)
++ $(INSTALL_DATA) $(srcdir)/docs/$(TEXIFILE) $(DESTDIR)$(docdir)
++ $(INSTALL_DATA) $(srcdir)/docs/$(PDFFILE) $(DESTDIR)$(docdir)
+
+ install : installincs installlib $(UTIL)
+- $(srcdir)/mkinstalldirs $(bindir)
+- $(INSTALL_PROGRAM) $(UTIL) $(bindir)
+- @echo "Enter 'make installdocs' to install $(DOCFILES) in $(docdir)"
++ $(srcdir)/mkinstalldirs $(DESTDIR)$(bindir)
++ $(INSTALL_PROGRAM) $(UTIL) $(DESTDIR)$(bindir)
++ @echo "Enter 'make installdocs' to install $(DOCFILES) in $(DESTDIR)$(docdir)"
+
+ dmalloc.h.2 : $(srcdir)/configure
+ $(SHELL) $(srcdir)/configure