summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-15 23:31:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-04-15 23:31:43 +0000
commite437123d4754a8dc874a2136cd541770e60cca29 (patch)
tree78b50dccb191256032781da62712bf5da6b1cd15 /dev-libs
parentImport Gentoo Prefix changes, convert to EAPI3, add keywords. bug 315513 (diff)
downloadgentoo-2-e437123d4754a8dc874a2136cd541770e60cca29.tar.gz
gentoo-2-e437123d4754a8dc874a2136cd541770e60cca29.tar.bz2
gentoo-2-e437123d4754a8dc874a2136cd541770e60cca29.zip
Set QA_DT_NEEDED (bug #215729). Install libicutest (bug #310297).
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/icu/ChangeLog8
-rw-r--r--dev-libs/icu/files/icu-4.4-install_libicutest.patch42
-rw-r--r--dev-libs/icu/icu-4.4-r1.ebuild75
3 files changed, 124 insertions, 1 deletions
diff --git a/dev-libs/icu/ChangeLog b/dev-libs/icu/ChangeLog
index 443bc3cb7b82..93b682b8f503 100644
--- a/dev-libs/icu/ChangeLog
+++ b/dev-libs/icu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/icu
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.105 2010/03/19 12:01:01 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/ChangeLog,v 1.106 2010/04/15 23:31:43 arfrever Exp $
+
+*icu-4.4-r1 (15 Apr 2010)
+
+ 15 Apr 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +icu-4.4-r1.ebuild, +files/icu-4.4-install_libicutest.patch:
+ Set QA_DT_NEEDED (bug #215729). Install libicutest (bug #310297).
*icu-4.4 (19 Mar 2010)
diff --git a/dev-libs/icu/files/icu-4.4-install_libicutest.patch b/dev-libs/icu/files/icu-4.4-install_libicutest.patch
new file mode 100644
index 000000000000..e38b49ca26fd
--- /dev/null
+++ b/dev-libs/icu/files/icu-4.4-install_libicutest.patch
@@ -0,0 +1,42 @@
+https://bugs.icu-project.org/trac/ticket/7567
+https://bugs.icu-project.org/trac/changeset/27878
+
+--- tools/ctestfw/Makefile.in
++++ tools/ctestfw/Makefile.in
+@@ -1,6 +1,6 @@
+ #******************************************************************************
+ #
+-# Copyright (C) 1999-2009, International Business Machines
++# Copyright (C) 1999-2010, International Business Machines
+ # Corporation and others. All Rights Reserved.
+ #
+ #******************************************************************************
+@@ -79,6 +79,28 @@
+ install-local: install-library
+
+ install-library: all-local
++ $(MKINSTALLDIRS) $(DESTDIR)$(libdir)
++ifneq ($(ENABLE_STATIC),)
++ $(INSTALL-L) $(TARGET) $(DESTDIR)$(libdir)
++endif
++ifneq ($(ENABLE_SHARED),)
++ $(INSTALL-L) $(FINAL_SO_TARGET) $(DESTDIR)$(libdir)
++ifneq ($(FINAL_SO_TARGET),$(SO_TARGET))
++ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(SO_TARGET))
++ifneq ($(FINAL_SO_TARGET),$(MIDDLE_SO_TARGET))
++ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_SO_TARGET)) && ln -s $(notdir $(FINAL_SO_TARGET)) $(notdir $(MIDDLE_SO_TARGET))
++endif
++endif
++ifneq ($(IMPORT_LIB_EXT),)
++ $(INSTALL-L) $(FINAL_IMPORT_LIB) $(DESTDIR)$(libdir)
++ifneq ($(IMPORT_LIB),$(FINAL_IMPORT_LIB))
++ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(IMPORT_LIB)) && ln -s $(notdir $(FINAL_IMPORT_LIB)) $(notdir $(IMPORT_LIB))
++endif
++ifneq ($(MIDDLE_IMPORT_LIB),$(FINAL_IMPORT_LIB))
++ cd $(DESTDIR)$(libdir) && $(RM) $(notdir $(MIDDLE_IMPORT_LIB)) && ln -s $(notdir $(FINAL_IMPORT_LIB)) $(notdir $(MIDDLE_IMPORT_LIB))
++endif
++endif
++endif
+
+ dist-local:
+
diff --git a/dev-libs/icu/icu-4.4-r1.ebuild b/dev-libs/icu/icu-4.4-r1.ebuild
new file mode 100644
index 000000000000..9806fcf5e71c
--- /dev/null
+++ b/dev-libs/icu/icu-4.4-r1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/icu/icu-4.4-r1.ebuild,v 1.1 2010/04/15 23:31:43 arfrever Exp $
+
+EAPI="3"
+
+inherit eutils flag-o-matic versionator
+
+MAJOR_MINOR_VERSION="$(get_version_component_range 1-2)"
+
+DESCRIPTION="International Components for Unicode"
+HOMEPAGE="http://www.icu-project.org/"
+
+BASE_URI="http://download.icu-project.org/files/icu4c/${PV}"
+DOCS_BASE_URI="http://download.icu-project.org/files/icu4c/${MAJOR_MINOR_VERSION}"
+SRC_ARCHIVE="icu4c-${PV//./_}-src.tgz"
+DOCS_ARCHIVE="icu4c-${MAJOR_MINOR_VERSION//./_}-docs.zip"
+
+SRC_URI="${BASE_URI}/${SRC_ARCHIVE}
+ doc? ( ${DOCS_BASE_URI}/${DOCS_ARCHIVE} )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples"
+
+DEPEND="doc? ( app-arch/unzip )"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}/source"
+
+QA_DT_NEEDED="/usr/lib.*/libicudata.so.${MAJOR_MINOR_VERSION/./}.0"
+
+src_unpack() {
+ unpack "${SRC_ARCHIVE}"
+ if use doc; then
+ mkdir docs
+ pushd docs > /dev/null
+ unpack "${DOCS_ARCHIVE}"
+ popd > /dev/null
+ fi
+}
+
+src_prepare() {
+ # Do not hardcode used CFLAGS, LDFLAGS etc. into icu-config
+ # Bug 202059
+ # https://bugs.icu-project.org/trac/ticket/6102
+ for x in ARFLAGS CFLAGS CPPFLAGS CXXFLAGS FFLAGS LDFLAGS; do
+ sed -i -e "/^${x} =.*/s:@${x}@::" "config/Makefile.inc.in" || die "sed failed"
+ done
+
+ epatch "${FILESDIR}/${P}-install_libicutest.patch"
+}
+
+src_configure() {
+ econf \
+ --enable-static \
+ $(use_enable debug) \
+ $(use_enable examples samples)
+}
+
+src_test() {
+ emake check || die "emake check failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dohtml ../readme.html
+ dodoc ../unicode-license.txt
+ if use doc; then
+ insinto /usr/share/doc/${PF}/html/api
+ doins -r "${WORKDIR}/docs/"*
+ fi
+}