summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2015-08-03 08:29:48 +0000
committerSergey Popov <pinkbyte@gentoo.org>2015-08-03 08:29:48 +0000
commitcb0eed244ff4c39aca576ed7cf858d2b9db63878 (patch)
tree926c3ef4f9cbef5ba086eac55a28ba53c79ae4b5 /dev-libs
parentRemove older stable versions. (diff)
downloadgentoo-2-cb0eed244ff4c39aca576ed7cf858d2b9db63878.tar.gz
gentoo-2-cb0eed244ff4c39aca576ed7cf858d2b9db63878.tar.bz2
gentoo-2-cb0eed244ff4c39aca576ed7cf858d2b9db63878.zip
Version bump, wrt bug #454710. EAPI 5, add epatch_user, do not install crap files with examples, drop unneeded nonfatal calls wrt bug #551164. Drop old version
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x60C0742D1F357D42)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/quantlib/ChangeLog10
-rw-r--r--dev-libs/quantlib/quantlib-1.6.ebuild (renamed from dev-libs/quantlib/quantlib-1.2.ebuild)59
2 files changed, 46 insertions, 23 deletions
diff --git a/dev-libs/quantlib/ChangeLog b/dev-libs/quantlib/ChangeLog
index 3e29df19f17c..68f8b2f1aeb6 100644
--- a/dev-libs/quantlib/ChangeLog
+++ b/dev-libs/quantlib/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-libs/quantlib
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/quantlib/ChangeLog,v 1.38 2015/06/09 14:49:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/quantlib/ChangeLog,v 1.39 2015/08/03 08:29:48 pinkbyte Exp $
+
+*quantlib-1.6 (03 Aug 2015)
+
+ 03 Aug 2015; Sergey Popov <pinkbyte@gentoo.org> -quantlib-1.2.ebuild,
+ +quantlib-1.6.ebuild:
+ Version bump, wrt bug #454710. EAPI 5, add epatch_user, do not install crap
+ files with examples, drop unneeded nonfatal calls wrt bug #551164. Drop old
+ version
09 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Updating remote-id in metadata.xml
diff --git a/dev-libs/quantlib/quantlib-1.2.ebuild b/dev-libs/quantlib/quantlib-1.6.ebuild
index b2f902436878..9dc9f8c6dfc7 100644
--- a/dev-libs/quantlib/quantlib-1.2.ebuild
+++ b/dev-libs/quantlib/quantlib-1.6.ebuild
@@ -1,11 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/quantlib/quantlib-1.2.ebuild,v 1.2 2012/03/17 08:54:35 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/quantlib/quantlib-1.6.ebuild,v 1.1 2015/08/03 08:29:48 pinkbyte Exp $
-EAPI=4
-inherit elisp-common
+EAPI=5
-MY_P=QuantLib-${PV}
+inherit elisp-common eutils toolchain-funcs
+
+MY_P="QuantLib-${PV}"
DESCRIPTION="A comprehensive software framework for quantitative finance"
HOMEPAGE="http://quantlib.org/"
@@ -14,18 +15,28 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc emacs examples static-libs"
+IUSE="debug doc emacs examples openmp static-libs"
-RDEPEND="dev-libs/boost"
+RDEPEND="dev-libs/boost:="
DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
+ doc? ( app-doc/doxygen[dot] )
emacs? ( virtual/emacs )"
DOCS="*.txt"
-SITEFILE=50${PN}-gentoo.el
+S="${WORKDIR}/${MY_P}"
+
+SITEFILE="50${PN}-gentoo.el"
+
+pkg_setup() {
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+}
-S=${WORKDIR}/${MY_P}
+src_prepare() {
+ epatch_user
+}
src_configure() {
# NOTE: Too fragile for single .pdf or .ps document
@@ -39,39 +50,43 @@ src_configure() {
# NOTE: --enable-examples will only change noinst_PROGRAMS to bin_PROGRAMS
econf \
+ $(use_enable debug error-functions) \
+ $(use_enable debug error-lines) \
+ $(use_enable debug tracing) \
+ $(use_enable openmp) \
$(use_enable static-libs static) \
--enable-examples \
- --with-lispdir="${SITELISP}"/${PN}
+ --with-lispdir="${SITELISP}/${PN}"
}
src_compile() {
- emake
+ default
if use doc; then
pushd Docs >/dev/null
- nonfatal emake docs-html
+ emake docs-html
popd >/dev/null
fi
}
src_install(){
default
-
- rm -f "${ED}"/usr/lib*/*.la
+ prune_libtool_files
if use doc; then
- find Docs \( -name '.time-stamp*' -o -name '*.doxy' -o -name 'Makefile*' \) -delete
- insinto /usr/share/doc/${PF}
- nonfatal doins -r Docs
+ find Docs \( -name '.time-stamp*' -o -name '*.doxy' -o -name 'Makefile*' \) -delete || die
+ insinto "/usr/share/doc/${PF}"
+ doins -r Docs
fi
if use examples; then
- find Examples \( -name '*vc*proj*' -o -name '*.dev' -o -name 'Makefile*' -o -name '.libs' -o -name '*.o' \) -delete
- insinto /usr/share/doc/${PF}
- nonfatal doins -r Examples
+ find Examples -name '.libs' -exec rm -rf {} + || die
+ find Examples \( -name '*vc*proj*' -o -name '*.dev' -o -name 'Makefile*' -o -name '*.o' \) -delete || die
+ insinto "/usr/share/doc/${PF}"
+ doins -r Examples
fi
- use emacs && elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
}
pkg_postinst() {