summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2008-11-06 08:10:02 +0000
committerDaniel Black <dragonheart@gentoo.org>2008-11-06 08:10:02 +0000
commitc3ecfa6f2d5b18910d31eec15a3c0b34ff2b2115 (patch)
tree0e3568679c2e21e68e3adde7de6394aa9198277c /dev-libs
parents390 love (diff)
downloadgentoo-2-c3ecfa6f2d5b18910d31eec15a3c0b34ff2b2115.tar.gz
gentoo-2-c3ecfa6f2d5b18910d31eec15a3c0b34ff2b2115.tar.bz2
gentoo-2-c3ecfa6f2d5b18910d31eec15a3c0b34ff2b2115.zip
hash calculation fix as per upstream http://marc.info/?l=gcrypt-devel&m=122591162816263&w=2
(Portage version: 2.2_rc12/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libgcrypt/ChangeLog11
-rw-r--r--dev-libs/libgcrypt/files/libgcrypt-1.4.0-HMAC-SHA-384-512.patch20
-rw-r--r--dev-libs/libgcrypt/files/libgcrypt-1.4.3-HMAC-SHA-384-512.patch21
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.4.0-r1.ebuild4
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.4.3-r1.ebuild (renamed from dev-libs/libgcrypt/libgcrypt-1.4.3.ebuild)4
5 files changed, 57 insertions, 3 deletions
diff --git a/dev-libs/libgcrypt/ChangeLog b/dev-libs/libgcrypt/ChangeLog
index 4b8b29c90c42..a0763efbf1f6 100644
--- a/dev-libs/libgcrypt/ChangeLog
+++ b/dev-libs/libgcrypt/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/libgcrypt
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/ChangeLog,v 1.115 2008/11/03 17:07:51 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/ChangeLog,v 1.116 2008/11/06 08:10:02 dragonheart Exp $
+
+*libgcrypt-1.4.3-r1 (06 Nov 2008)
+
+ 06 Nov 2008; Daniel Black <dragonheart@gentoo.org>
+ +files/libgcrypt-1.4.0-HMAC-SHA-384-512.patch,
+ +files/libgcrypt-1.4.3-HMAC-SHA-384-512.patch, libgcrypt-1.4.0-r1.ebuild,
+ -libgcrypt-1.4.3.ebuild, +libgcrypt-1.4.3-r1.ebuild:
+ hash calculation fix as per upstream
+ http://marc.info/?l=gcrypt-devel&m=122591162816263&w=2
*libgcrypt-1.4.3 (03 Nov 2008)
diff --git a/dev-libs/libgcrypt/files/libgcrypt-1.4.0-HMAC-SHA-384-512.patch b/dev-libs/libgcrypt/files/libgcrypt-1.4.0-HMAC-SHA-384-512.patch
new file mode 100644
index 000000000000..6841fce90a27
--- /dev/null
+++ b/dev-libs/libgcrypt/files/libgcrypt-1.4.0-HMAC-SHA-384-512.patch
@@ -0,0 +1,20 @@
+--- cipher/md.c.orig 2007-08-14 02:46:51.000000000 +1000
++++ cipher/md.c 2008-11-06 19:05:37.000000000 +1100
+@@ -791,7 +791,7 @@
+ if ( !algo )
+ return GPG_ERR_DIGEST_ALGO; /* i.e. no algo enabled */
+
+- if ( keylen > 64 )
++ if ( keylen > hd->ctx->macpads_Bsize )
+ {
+ helpkey = gcry_malloc_secure ( md_digest_length( algo ) );
+ if ( !helpkey )
+@@ -799,7 +799,7 @@
+ gcry_md_hash_buffer ( algo, helpkey, key, keylen );
+ key = helpkey;
+ keylen = md_digest_length( algo );
+- assert ( keylen <= 64 );
++ assert ( keylen <= hd->ctx->macpads_Bsize );
+ }
+
+ memset ( hd->ctx->macpads, 0, 2*(hd->ctx->macpads_Bsize) );
diff --git a/dev-libs/libgcrypt/files/libgcrypt-1.4.3-HMAC-SHA-384-512.patch b/dev-libs/libgcrypt/files/libgcrypt-1.4.3-HMAC-SHA-384-512.patch
new file mode 100644
index 000000000000..e9146b9085a0
--- /dev/null
+++ b/dev-libs/libgcrypt/files/libgcrypt-1.4.3-HMAC-SHA-384-512.patch
@@ -0,0 +1,21 @@
+--- orig/libgcrypt-1.4.3/cipher/md.c 2008-09-12 15:43:52.000000000 +0200
++++ libgcrypt-1.4.3/cipher/md.c 2008-11-05 19:52:32.000000000 +0100
+@@ -834,7 +834,7 @@ prepare_macpads( gcry_md_hd_t hd, const
+ if ( !algo )
+ return GPG_ERR_DIGEST_ALGO; /* i.e. no algo enabled */
+
+- if ( keylen > 64 )
++ if ( keylen > hd->ctx->macpads_Bsize )
+ {
+ helpkey = gcry_malloc_secure ( md_digest_length( algo ) );
+ if ( !helpkey )
+@@ -842,7 +842,7 @@ prepare_macpads( gcry_md_hd_t hd, const
+ gcry_md_hash_buffer ( algo, helpkey, key, keylen );
+ key = helpkey;
+ keylen = md_digest_length( algo );
+- gcry_assert ( keylen <= 64 );
++ gcry_assert ( keylen <= hd->ctx->macpads_Bsize );
+ }
+
+ memset ( hd->ctx->macpads, 0, 2*(hd->ctx->macpads_Bsize) );
+
diff --git a/dev-libs/libgcrypt/libgcrypt-1.4.0-r1.ebuild b/dev-libs/libgcrypt/libgcrypt-1.4.0-r1.ebuild
index 53c70db7511f..d862b462614f 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.4.0-r1.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.4.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.4.0-r1.ebuild,v 1.10 2008/01/31 15:00:42 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.4.0-r1.ebuild,v 1.11 2008/11/06 08:10:02 dragonheart Exp $
inherit eutils autotools
@@ -22,6 +22,8 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
+ # http://marc.info/?l=gcrypt-devel&m=122591162816263&w=2
+ epatch "${FILESDIR}"/${P}-HMAC-SHA-384-512.patch
if use idea; then
if use bindist; then
diff --git a/dev-libs/libgcrypt/libgcrypt-1.4.3.ebuild b/dev-libs/libgcrypt/libgcrypt-1.4.3-r1.ebuild
index 44180d131f1c..4535fc9a79a0 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.4.3.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.4.3.ebuild,v 1.1 2008/11/03 17:07:51 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.4.3-r1.ebuild,v 1.1 2008/11/06 08:10:02 dragonheart Exp $
inherit autotools eutils
@@ -21,6 +21,8 @@ DEPEND="${RDEPEND}"
src_unpack() {
unpack ${A}
cd "${S}"
+ # http://marc.info/?l=gcrypt-devel&m=122591162816263&w=2
+ epatch "${FILESDIR}"/${P}-HMAC-SHA-384-512.patch
if use idea; then
if use bindist; then