summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-02-20 20:32:25 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-02-20 20:32:25 +0000
commitb74fe02f6d9ab6a9f2a877b328c7e60be927c191 (patch)
tree407c53c85230239e6d647966331613241f0cb18a /dev-libs
parentx11-wm/dwm: remove old (diff)
downloadgentoo-2-b74fe02f6d9ab6a9f2a877b328c7e60be927c191.tar.gz
gentoo-2-b74fe02f6d9ab6a9f2a877b328c7e60be927c191.tar.bz2
gentoo-2-b74fe02f6d9ab6a9f2a877b328c7e60be927c191.zip
Removed ${ROOT} where not appropriate (bug #167271). Added src_test for 1.33.1-r1.
(Portage version: 2.1.2-r7)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost/ChangeLog7
-rw-r--r--dev-libs/boost/boost-1.33.1-r1.ebuild50
-rw-r--r--dev-libs/boost/boost-1.34_pre20061214.ebuild10
3 files changed, 59 insertions, 8 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 895eaa835cf4..b259cf14417a 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.107 2007/02/18 11:15:23 eroyf Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.108 2007/02/20 20:32:25 dev-zero Exp $
+
+ 20 Feb 2007; Tiziano Müller <dev-zero@gentoo.org> boost-1.33.1-r1.ebuild,
+ boost-1.34_pre20061214.ebuild:
+ Removed ${ROOT} where not appropriate (bug #167271). Added src_test for
+ 1.33.1-r1.
18 Feb 2007; Alexander H. Færøy <eroyf@gentoo.org>
boost-1.33.1-r1.ebuild:
diff --git a/dev-libs/boost/boost-1.33.1-r1.ebuild b/dev-libs/boost/boost-1.33.1-r1.ebuild
index 52fb158d43b9..7000bb6cbc9b 100644
--- a/dev-libs/boost/boost-1.33.1-r1.ebuild
+++ b/dev-libs/boost/boost-1.33.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.33.1-r1.ebuild,v 1.14 2007/02/18 11:15:23 eroyf Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.33.1-r1.ebuild,v 1.15 2007/02/20 20:32:25 dev-zero Exp $
inherit eutils distutils multilib python versionator
@@ -82,7 +82,7 @@ pkg_setup() {
fi
if use icu ; then
- ADDITIONAL_OPTIONS="-sHAVE_ICU=1 -sICU_PATH=${ROOT}/usr"
+ ADDITIONAL_OPTIONS="-sHAVE_ICU=1 -sICU_PATH=/usr"
fi
}
@@ -219,4 +219,50 @@ src_install () {
cd "${S}"/tools/build/jam_src/bin.*/
dobin bjam || die "bjam install failed"
fi
+
+ if has test ${FEATURES} ; then
+ cd "${S}/status"
+ elog "Tests enabled, installing the output to:"
+ elog " ${ROOT}usr/share/doc/${PF}/status"
+ elog "The results are in"
+ elog " ${ROOT}usr/share/doc/${PF}/status/cs-$(uname).html"
+ docinto status
+ sed -i -e 's|../boost.png|boost.png|' *.html
+ dohtml *.{html,gif} ../boost.png
+ dodoc regress.log
+ fi
+}
+
+src_test() {
+ ewarn "This test might take a couple of hours even on a recent machine"
+ ewarn "and you need 2 GB free space in your temp directory."
+ ebeep
+
+ elog "It is possible to provide a regression_comment file"
+ elog "which might be useful it you intend to send the generated"
+ elog "regression results table to the boost-developers."
+ elog "Just export a variable BOOST_COMMENT_PATH before starting"
+ elog "the merge containing the full path to such a file."
+ elog "If you don't know what's this all about, just ignore it."
+
+ if [ -n ${BOOST_COMMENT_PATH} ] ; then
+ elog "Creating default comment file..."
+ cat > comment.html <<- __EOF__
+ <p>Tests are run on Gentoo Linux.</p>
+ __EOF__
+ BOOST_COMMENT_PATH="$(pwd)/comment.html"
+ fi
+
+
+ cd "${S}/tools/regression"
+ sed -i \
+ -e "s|\(boost_root\)=.*|\1=\"${S}\"|" \
+ -e "s|\(toolset\)=.*|\1=\"${BOOST_TOOLSET}\"|" \
+ -e "s|\(test_tools\)=.*|\1=\"${BOOST_TOOLSET}\"|" \
+ -e "s|\(comment_path\)=.*|\1=\"${BOOST_COMMENT_PATH}\"|" \
+ run_tests.sh || die "sed failed"
+ . run_tests.sh || die "tests failed"
+
+ elog "You have to check the test output yourself"
+ elog "to see whether all tests succeeded."
}
diff --git a/dev-libs/boost/boost-1.34_pre20061214.ebuild b/dev-libs/boost/boost-1.34_pre20061214.ebuild
index 4deea05625ca..3f20e9bc9aee 100644
--- a/dev-libs/boost/boost-1.34_pre20061214.ebuild
+++ b/dev-libs/boost/boost-1.34_pre20061214.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.34_pre20061214.ebuild,v 1.3 2007/02/10 12:38:14 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.34_pre20061214.ebuild,v 1.4 2007/02/20 20:32:25 dev-zero Exp $
inherit distutils flag-o-matic multilib toolchain-funcs versionator
@@ -47,7 +47,7 @@ generate_options() {
OPTIONS="${OPTIONS} optimization=none"
OPTIONS="${OPTIONS} threading=single,multi"
- use icu && OPTIONS="${OPTIONS} -sHAVE_ICU=1 -sICU_PATH=\"${ROOT}/usr\""
+ use icu && OPTIONS="${OPTIONS} -sHAVE_ICU=1 -sICU_PATH=/usr"
}
@@ -73,7 +73,7 @@ generate_userconfig() {
import toolset : using ;
import toolset : flags ;
using ${compiler} : ${compilerVersion} : ${compilerExecutable} : <cxxflags>"${CXXFLAGS}" <linkflags>"${LDFLAGS}" ;
-using python : ${PYVER} : ${ROOT}usr : ${ROOT}usr/include/python${PYVER} : ${ROOT}usr/lib/python${PYVER} ;
+using python : ${PYVER} : /usr : /usr/include/python${PYVER} : /usr/lib/python${PYVER} ;
__EOF__
}
@@ -86,7 +86,7 @@ src_compile() {
generate_options
export BOOST_ROOT=${S}
- export BOOST_BUILD_PATH=${ROOT}/usr/share/boost-build
+ export BOOST_BUILD_PATH=/usr/share/boost-build
# Note: The line "debug-symbols=on" only adds '-g' to compiler and linker invocation
# and prevents boost-build from stripping the libraries/binaries
@@ -123,7 +123,7 @@ src_install () {
generate_options
export BOOST_ROOT=${S}
- export BOOST_BUILD_PATH=${ROOT}/usr/share/boost-build
+ export BOOST_BUILD_PATH=/usr/share/boost-build
for linkoption in ${LINK_OPTIONS} ; do
bjam \