summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2014-06-16 21:54:20 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2014-06-16 21:54:20 +0000
commit939db9936c938fedf78f80b301f1cef5c696e55d (patch)
tree3430b05e590110cd843b3844fbb5461a4804be02 /dev-libs
parentRemove unnecessary dep on emul-linux-x86/multilib openssl. Disable building p... (diff)
downloadgentoo-2-939db9936c938fedf78f80b301f1cef5c696e55d.tar.gz
gentoo-2-939db9936c938fedf78f80b301f1cef5c696e55d.tar.bz2
gentoo-2-939db9936c938fedf78f80b301f1cef5c696e55d.zip
version bump, bug #507046, imported from sage-on-gentoo, thanks to François Bissey
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB2EFA1D4)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/ntl/ChangeLog8
-rw-r--r--dev-libs/ntl/ntl-6.1.0.ebuild75
2 files changed, 82 insertions, 1 deletions
diff --git a/dev-libs/ntl/ChangeLog b/dev-libs/ntl/ChangeLog
index d71700058438..a40cd0732f18 100644
--- a/dev-libs/ntl/ChangeLog
+++ b/dev-libs/ntl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/ntl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ntl/ChangeLog,v 1.23 2014/03/10 18:29:06 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ntl/ChangeLog,v 1.24 2014/06/16 21:54:20 jauhien Exp $
+
+*ntl-6.1.0 (16 Jun 2014)
+
+ 16 Jun 2014; Jauhien Piatlicki <jauhien@gentoo.org> +ntl-6.1.0.ebuild:
+ version bump, bug #507046, imported from sage-on-gentoo, thanks to François
+ Bissey
*ntl-6.0.0 (10 Mar 2014)
diff --git a/dev-libs/ntl/ntl-6.1.0.ebuild b/dev-libs/ntl/ntl-6.1.0.ebuild
new file mode 100644
index 000000000000..7ce6658a0d39
--- /dev/null
+++ b/dev-libs/ntl/ntl-6.1.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ntl/ntl-6.1.0.ebuild,v 1.1 2014/06/16 21:54:20 jauhien Exp $
+
+EAPI=5
+inherit toolchain-funcs eutils multilib flag-o-matic
+
+DESCRIPTION="High-performance and portable Number Theory C++ library"
+HOMEPAGE="http://shoup.net/ntl/"
+SRC_URI="http://www.shoup.net/ntl/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-macos"
+IUSE="doc static-libs test"
+
+RDEPEND=">=dev-libs/gmp-4.3
+ >=dev-libs/gf2x-0.9"
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+S="${WORKDIR}/${P}/src"
+
+src_prepare() {
+ # fix parallel make
+ sed -i -e "s/make/make ${MAKEOPTS}/g" WizardAux || die
+ cd ..
+ # enable compatibility with singular
+ epatch "$FILESDIR/${PN}-6.0.0-singular.patch"
+ # implement a call back framework (submitted upstream)
+ epatch "$FILESDIR/${PN}-6.0.0-sage-tools.patch"
+ # sanitize the makefile and allow the building of shared library
+ epatch "$FILESDIR/${PN}-5.5.2-shared-r1.patch"
+ replace-flags -O[3-9] -O2
+}
+
+src_configure() {
+ perl DoConfig \
+ PREFIX="${EPREFIX}"/usr \
+ CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" \
+ AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" \
+ NTL_STD_CXX=on NTL_GMP_LIP=on NTL_GF2X_LIB=on \
+ || die "DoConfig failed"
+}
+
+src_compile() {
+ # split the targets to allow parallel make to run properly
+ emake setup1 setup2 || die "emake setup failed"
+ emake setup3 || die "emake setup failed"
+ sh Wizard on || die "Tuning wizard failed"
+ if use static-libs || use test; then
+ emake ntl.a || die "emake static failed"
+ fi
+ local trg=so
+ [[ ${CHOST} == *-darwin* ]] && trg=dylib
+ emake shared${trg} || die "emake shared failed"
+}
+
+src_install() {
+ if use static-libs; then
+ newlib.a ntl.a libntl.a || die "installation of static library failed"
+ fi
+ dolib.so lib*$(get_libname) || die "installation of shared library failed"
+
+ cd ..
+ insinto /usr/include
+ doins -r include/NTL || die "installation of the headers failed"
+
+ dodoc README
+ if use doc ; then
+ dodoc doc/*.txt || die
+ dohtml doc/* || die
+ fi
+}