summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-01 22:09:17 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-12-01 22:09:17 +0000
commit8e35ff551b736473a3386e5dea94280a586797ad (patch)
tree7db4942e7a486006688cf4fa9c39ec861230eedf /dev-libs
parentVersion bump. (diff)
downloadgentoo-2-8e35ff551b736473a3386e5dea94280a586797ad.tar.gz
gentoo-2-8e35ff551b736473a3386e5dea94280a586797ad.tar.bz2
gentoo-2-8e35ff551b736473a3386e5dea94280a586797ad.zip
Patch the build system so that it can build with modern automake, allowing for this to be built with libtool-2.4. Also fix quoting of $FILESDIR and properly set RDEPEND/DEPEND.
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libstroke/ChangeLog10
-rw-r--r--dev-libs/libstroke/files/libstroke-0.5.1-autotools.patch29
-rw-r--r--dev-libs/libstroke/libstroke-0.5.1.ebuild13
3 files changed, 44 insertions, 8 deletions
diff --git a/dev-libs/libstroke/ChangeLog b/dev-libs/libstroke/ChangeLog
index b44385d483eb..f07c567e4979 100644
--- a/dev-libs/libstroke/ChangeLog
+++ b/dev-libs/libstroke/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libstroke
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libstroke/ChangeLog,v 1.24 2007/09/19 09:24:33 calchan Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libstroke/ChangeLog,v 1.25 2010/12/01 22:09:17 flameeyes Exp $
+
+ 01 Dec 2010; Diego E. Pettenò <flameeyes@gentoo.org> libstroke-0.5.1.ebuild,
+ +files/libstroke-0.5.1-autotools.patch:
+ Patch the build system so that it can build with modern automake, allowing
+ for this to be built with libtool-2.4. Also fix quoting of $FILESDIR and
+ properly set RDEPEND/DEPEND.
19 Sep 2007; Denis Dupeyron <calchan@gentoo.org> metadata.xml,
libstroke-0.5.1.ebuild:
diff --git a/dev-libs/libstroke/files/libstroke-0.5.1-autotools.patch b/dev-libs/libstroke/files/libstroke-0.5.1-autotools.patch
new file mode 100644
index 000000000000..2bd67677a89c
--- /dev/null
+++ b/dev-libs/libstroke/files/libstroke-0.5.1-autotools.patch
@@ -0,0 +1,29 @@
+Index: libstroke-0.5.1/libgstroke/Makefile.am
+===================================================================
+--- libstroke-0.5.1.orig/libgstroke/Makefile.am
++++ libstroke-0.5.1/libgstroke/Makefile.am
+@@ -5,8 +5,6 @@
+ # level Makefile.
+ AUTOMAKE_OPTIONS = foreign
+
+-EXTRA_DIST =
+-
+ #SEL_BIB = libgstroke.la
+
+ lib_LTLIBRARIES = libgstroke.la
+Index: libstroke-0.5.1/libstroke/Makefile.am
+===================================================================
+--- libstroke-0.5.1.orig/libstroke/Makefile.am
++++ libstroke-0.5.1/libstroke/Makefile.am
+@@ -5,11 +5,6 @@
+ # level Makefile.
+ AUTOMAKE_OPTIONS = foreign
+
+-EXTRA_DIST =
+-
+-#tclpath::
+- #echo ${ENABLE_TCL}
+-
+ #if ENABLE_TCL
+ #SEL_BIB = libstroke.la libstroke_tcl.la
+ #else
diff --git a/dev-libs/libstroke/libstroke-0.5.1.ebuild b/dev-libs/libstroke/libstroke-0.5.1.ebuild
index 0e2a7543d13c..d583c2ddc24c 100644
--- a/dev-libs/libstroke/libstroke-0.5.1.ebuild
+++ b/dev-libs/libstroke/libstroke-0.5.1.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libstroke/libstroke-0.5.1.ebuild,v 1.22 2007/09/19 09:24:33 calchan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libstroke/libstroke-0.5.1.ebuild,v 1.23 2010/12/01 22:09:17 flameeyes Exp $
-WANT_AUTOMAKE=1.4
inherit eutils autotools
DESCRIPTION="A Stroke and Gesture recognition Library"
@@ -14,14 +13,16 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE=""
+RDEPEND="x11-libs/libX11"
DEPEND="x11-proto/xproto
- x11-libs/libX11"
+ ${RDEPEND}"
src_unpack() {
unpack "${A}"
cd "${S}"
- epatch ${FILESDIR}/${P}-m4_syntax.patch
- epatch ${FILESDIR}/${P}-no_gtk1.patch
+ epatch "${FILESDIR}"/${P}-m4_syntax.patch
+ epatch "${FILESDIR}"/${P}-no_gtk1.patch
+ epatch "${FILESDIR}"/${P}-autotools.patch
eautoreconf || die 'eautoreconf failed'
}