summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2006-02-09 09:22:30 +0000
committerMartin Schlemmer <azarah@gentoo.org>2006-02-09 09:22:30 +0000
commit717523f8b4bfd6121d953371212d2a5dfa1b8155 (patch)
tree4e773a528f644d18daa124d2fde0f8840d506c2a /dev-libs
parentStable for x86. See bug #122136 (diff)
downloadgentoo-2-717523f8b4bfd6121d953371212d2a5dfa1b8155.tar.gz
gentoo-2-717523f8b4bfd6121d953371212d2a5dfa1b8155.tar.bz2
gentoo-2-717523f8b4bfd6121d953371212d2a5dfa1b8155.zip
Fix build logic for different KBUILD_OUT, bug #122173. Dash build still
fails with it set though, so need to wait for upstream to fix it. (Portage version: 2.1_pre4-r1)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/klibc/ChangeLog6
-rw-r--r--dev-libs/klibc/klibc-1.2.1-r1.ebuild25
2 files changed, 21 insertions, 10 deletions
diff --git a/dev-libs/klibc/ChangeLog b/dev-libs/klibc/ChangeLog
index 3faf21b16d93..6dd0f1331bdb 100644
--- a/dev-libs/klibc/ChangeLog
+++ b/dev-libs/klibc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/klibc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/ChangeLog,v 1.20 2006/02/07 08:33:22 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/ChangeLog,v 1.21 2006/02/09 09:22:30 azarah Exp $
+
+ 09 Feb 2006; Martin Schlemmer <azarah@gentoo.org> klibc-1.2.1-r1.ebuild:
+ Fix build logic for different KBUILD_OUT, bug #122173. Dash build still
+ fails with it set though, so need to wait for upstream to fix it.
*klibc-1.2.1-r1 (07 Feb 2006)
diff --git a/dev-libs/klibc/klibc-1.2.1-r1.ebuild b/dev-libs/klibc/klibc-1.2.1-r1.ebuild
index 1d270a381eec..6d0ff74ff48f 100644
--- a/dev-libs/klibc/klibc-1.2.1-r1.ebuild
+++ b/dev-libs/klibc/klibc-1.2.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/klibc-1.2.1-r1.ebuild,v 1.1 2006/02/07 08:33:22 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/klibc/klibc-1.2.1-r1.ebuild,v 1.2 2006/02/09 09:22:30 azarah Exp $
-inherit eutils linux-mod
+inherit eutils linux-info
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
@@ -87,9 +87,6 @@ src_unpack() {
# Add our linux source tree symlink
ln -snf ${KV_DIR} linux
- # set the build directory
- echo "KRNLOBJ = ${KV_OUT_DIR}" >> MCONFIG
-
# We do not want all the nice prelink warnings
# NOTE: for amd64, we might change below to '/usr/$(get_libdir)/klibc',
# but I do not do it right now, as the build system do not support
@@ -112,30 +109,40 @@ src_unpack() {
}
src_compile() {
+ local myargs
+
+ [[ ${KV_DIR} != "${KV_OUT_DIR}" ]] && \
+ myargs="KLIBCKERNELOBJ='${KV_OUT_DIR}/' KBUILD_SRC='1'"
+
if is_cross ; then
einfo "ARCH = \"$(guess_arch)\""
einfo "CROSS = \"${CTARGET}-\""
emake ARCH=$(guess_arch) \
- CROSS="${CTARGET}-" || die "Compile failed!"
+ CROSS="${CTARGET}-" \
+ ${myargs} || die "Compile failed!"
else
env -u ARCH \
- emake || die "Compile failed!"
+ emake ${myargs} || die "Compile failed!"
fi
}
src_install() {
- local klibc_prefix
+ local myargs klibc_prefix
+
+ [[ ${KV_DIR} != "${KV_OUT_DIR}" ]] && \
+ myargs="KLIBCKERNELOBJ='${KV_OUT_DIR}/' KBUILD_SRC='1'"
if is_cross ; then
make INSTALLROOT=${D} \
ARCH=$(guess_arch) \
CROSS="${CTARGET}-" \
+ ${myargs} \
install || die "Install failed!"
klibc_prefix=$("${S}/klcc/${CTARGET}-klcc" -print-klibc-bindir)
else
env -u ARCH \
- make INSTALLROOT=${D} install || die "Install failed!"
+ make INSTALLROOT=${D} ${myargs} install || die "Install failed!"
klibc_prefix=$("${S}/klcc/klcc" -print-klibc-bindir)
fi