summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-13 23:57:31 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-13 23:57:31 +0000
commit65826b20ecd54274d08667b9272d7580d17356bb (patch)
tree3603169d4e4bff2da65ec85afe7d0f10c01b02fc /dev-libs
parentadd m68k KEYWORDS and epunt_cxx (diff)
downloadgentoo-2-65826b20ecd54274d08667b9272d7580d17356bb.tar.gz
gentoo-2-65826b20ecd54274d08667b9272d7580d17356bb.tar.bz2
gentoo-2-65826b20ecd54274d08667b9272d7580d17356bb.zip
epunt_cxx love
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libgcrypt/libgcrypt-1.2.1.ebuild13
-rw-r--r--dev-libs/libxslt/libxslt-1.1.12.ebuild5
-rw-r--r--dev-libs/libxslt/libxslt-1.1.13-r1.ebuild13
3 files changed, 19 insertions, 12 deletions
diff --git a/dev-libs/libgcrypt/libgcrypt-1.2.1.ebuild b/dev-libs/libgcrypt/libgcrypt-1.2.1.ebuild
index d419904b11cb..ea4624c16643 100644
--- a/dev-libs/libgcrypt/libgcrypt-1.2.1.ebuild
+++ b/dev-libs/libgcrypt/libgcrypt-1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.2.1.ebuild,v 1.11 2005/06/06 08:54:05 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libgcrypt/libgcrypt-1.2.1.ebuild,v 1.12 2005/06/13 23:54:17 vapier Exp $
inherit eutils
@@ -17,17 +17,22 @@ DEPEND="dev-libs/libgpg-error"
RDEPEND="nls? ( sys-devel/gettext )
dev-libs/libgpg-error"
+src_unpack() {
+ unpack ${A}
+ epunt_cxx
+}
+
src_compile() {
econf $(use_enable nls) --disable-dependency-tracking || die
emake || die
}
src_install() {
- make DESTDIR=${D} install || die
- dodoc AUTHORS BUGS ChangeLog COPYING* NEWS README* THANKS TODO VERSION
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README* THANKS TODO VERSION
# backwards compat symlinks
- if use ppc-macos; then
+ if use ppc-macos ; then
dosym libgcrypt.11.dylib /usr/lib/libgcrypt.7.dylib
else
dosym libgcrypt.so.11 /usr/lib/libgcrypt.so.7
diff --git a/dev-libs/libxslt/libxslt-1.1.12.ebuild b/dev-libs/libxslt/libxslt-1.1.12.ebuild
index a032601f70d6..493f617d985d 100644
--- a/dev-libs/libxslt/libxslt-1.1.12.ebuild
+++ b/dev-libs/libxslt/libxslt-1.1.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.12.ebuild,v 1.8 2005/04/09 07:40:01 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.12.ebuild,v 1.9 2005/06/13 23:57:31 vapier Exp $
inherit libtool gnome.org eutils python
@@ -22,6 +22,7 @@ src_unpack() {
# we still require the 1.1.8 patch for the .m4 file, to add
# the CXXFLAGS defines <obz@gentoo.org>
epatch "${FILESDIR}"/libxslt.m4-${PN}-1.1.8.patch
+ epunt_cxx
elibtoolize
}
@@ -34,6 +35,6 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install
+ make DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog README NEWS TODO
}
diff --git a/dev-libs/libxslt/libxslt-1.1.13-r1.ebuild b/dev-libs/libxslt/libxslt-1.1.13-r1.ebuild
index eb7676f6e4e4..3fdcda064d54 100644
--- a/dev-libs/libxslt/libxslt-1.1.13-r1.ebuild
+++ b/dev-libs/libxslt/libxslt-1.1.13-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.13-r1.ebuild,v 1.3 2005/03/26 15:43:06 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libxslt/libxslt-1.1.13-r1.ebuild,v 1.4 2005/06/13 23:57:31 vapier Exp $
inherit libtool gnome.org eutils python
@@ -18,17 +18,18 @@ DEPEND=">=dev-libs/libxml2-2.6.17
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
# we still require the 1.1.8 patch for the .m4 file, to add
# the CXXFLAGS defines <obz@gentoo.org>
- epatch ${FILESDIR}/libxslt.m4-${PN}-1.1.8.patch
+ epatch "${FILESDIR}"/libxslt.m4-${PN}-1.1.8.patch
# patch for xslt missing dictionary, see:
# http://bugs.gentoo.org/show_bug.cgi?id=86327 and
# http://bugzilla.gnome.org/show_bug.cgi?id=170533
# <obz@gentoo.org>
- epatch ${FILESDIR}/${P}-xslt.patch
+ epatch "${FILESDIR}"/${P}-xslt.patch
+ epunt_cxx
elibtoolize
}
@@ -41,7 +42,7 @@ src_compile() {
# Patching the Makefiles to respect get_libdir
# Fixes BUG #86756, please keep this.
# Danny van Dyk <kugelfang@gentoo.org> 2005/03/26
- for x in $(find ${S} -name "Makefile") ; do
+ for x in $(find "${S}" -name "Makefile") ; do
sed \
-e "s|^\(PYTHON_SITE_PACKAGES\ =\ \/usr\/\).*\(\/python.*\)|\1$(get_libdir)\2|g" \
-i ${x} \
@@ -52,6 +53,6 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} install
+ make DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog README NEWS TODO
}