summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPieter van den Abeele <pvdabeel@gentoo.org>2004-09-25 11:35:40 +0000
committerPieter van den Abeele <pvdabeel@gentoo.org>2004-09-25 11:35:40 +0000
commit650698ed4d644c571011b85cd0bc37a379906e12 (patch)
tree1df1af72780c37b859cd9c269933335665ff9960 /dev-libs
parentcleaned out old ebuild (Manifest recommit) (diff)
downloadgentoo-2-650698ed4d644c571011b85cd0bc37a379906e12.tar.gz
gentoo-2-650698ed4d644c571011b85cd0bc37a379906e12.tar.bz2
gentoo-2-650698ed4d644c571011b85cd0bc37a379906e12.zip
Ported to PPC
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/hdf/hdf-4.2.0-r3.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-libs/hdf/hdf-4.2.0-r3.ebuild b/dev-libs/hdf/hdf-4.2.0-r3.ebuild
index f7ce6356b609..f7a910615051 100644
--- a/dev-libs/hdf/hdf-4.2.0-r3.ebuild
+++ b/dev-libs/hdf/hdf-4.2.0-r3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/hdf/hdf-4.2.0-r3.ebuild,v 1.3 2004/06/24 23:12:11 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/hdf/hdf-4.2.0-r3.ebuild,v 1.4 2004/09/25 11:35:40 pvdabeel Exp $
+
+inherit flag-o-matic
# substitute second dot by "r"
MY_PV=${PV/./X}
@@ -14,7 +16,7 @@ SRC_URI="ftp://ftp.ncsa.uiuc.edu/HDF/pub/outgoing/hdf4/hdf${MY_PV}/hdf${MY_PV}.t
HOMEPAGE="http://hdf.ncsa.uiuc.edu/hdf4.html"
LICENSE="NCSA-HDF"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~x86 ~amd64 ppc"
SLOT="0"
IUSE="szip"
@@ -33,6 +35,7 @@ pkg_setup() {
src_compile() {
local myconf="--enable-production"
use szip && myconf="${myconf} --with-szlib=/usr"
+ use ppc && append-flags -DSUN
econf ${myconf} || die "configure failed"
make LDFLAGS="-lm" || die "make failed"
}