summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-10-05 17:26:53 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-10-05 17:26:53 +0000
commit5f13c4130505a6f48222ced98b7b7ab24f34c1ac (patch)
treea52af03b6ceb0e89fe4c52e6e909ba6d3733d63a /dev-libs
parentMask release candidate of libffi for testing. (diff)
downloadgentoo-2-5f13c4130505a6f48222ced98b7b7ab24f34c1ac.tar.gz
gentoo-2-5f13c4130505a6f48222ced98b7b7ab24f34c1ac.tar.bz2
gentoo-2-5f13c4130505a6f48222ced98b7b7ab24f34c1ac.zip
Version bump.
(Portage version: 2.2_rc43/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/libffi/ChangeLog8
-rw-r--r--dev-libs/libffi/libffi-3.0.9_rc1.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-libs/libffi/ChangeLog b/dev-libs/libffi/ChangeLog
index ab50d5525ae4..57fbc610df35 100644
--- a/dev-libs/libffi/ChangeLog
+++ b/dev-libs/libffi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libffi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/ChangeLog,v 1.78 2009/10/03 16:38:24 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/ChangeLog,v 1.79 2009/10/05 17:26:53 ssuominen Exp $
+
+*libffi-3.0.9_rc1 (05 Oct 2009)
+
+ 05 Oct 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +libffi-3.0.9_rc1.ebuild:
+ Version bump.
03 Oct 2009; Samuli Suominen <ssuominen@gentoo.org> libffi-3.0.8.ebuild:
Move dev-libs/libffi back to EAPI="0" because dev-lang/python is consuming
diff --git a/dev-libs/libffi/libffi-3.0.9_rc1.ebuild b/dev-libs/libffi/libffi-3.0.9_rc1.ebuild
new file mode 100644
index 000000000000..45f0ce9733b9
--- /dev/null
+++ b/dev-libs/libffi/libffi-3.0.9_rc1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libffi/libffi-3.0.9_rc1.ebuild,v 1.1 2009/10/05 17:26:53 ssuominen Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="a portable, high level programming interface to various calling conventions."
+HOMEPAGE="http://sourceware.org/libffi"
+SRC_URI="ftp://sources.redhat.com/pub/${PN}/${P/_}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug static-libs test"
+
+RDEPEND=""
+DEPEND="!<dev-libs/g-wrap-1.9.11
+ test? ( dev-util/dejagnu )"
+
+S=${WORKDIR}/${P/_}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.0.8-autoconf-2.64.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_enable debug)
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ChangeLog* README
+}
+
+pkg_postinst() {
+ ewarn "If you have sys-devel/gcc built with USE libffi, unset it immediately."
+}