summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-21 16:41:26 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-21 16:41:26 +0000
commit5c1b86fd1fb45ff4c956f072dedf5dfe5179d9a7 (patch)
treea132fa4e707bf3b8c1daf34eb2167ca7c70bd794 /dev-libs
parentfix iproute dep (diff)
downloadgentoo-2-5c1b86fd1fb45ff4c956f072dedf5dfe5179d9a7.tar.gz
gentoo-2-5c1b86fd1fb45ff4c956f072dedf5dfe5179d9a7.tar.bz2
gentoo-2-5c1b86fd1fb45ff4c956f072dedf5dfe5179d9a7.zip
add inherit eutils
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild6
-rw-r--r--dev-libs/gmp/gmp-4.1-r1.ebuild9
-rw-r--r--dev-libs/gmp/gmp-4.1.2.ebuild16
-rw-r--r--dev-libs/ibpp/ibpp-1.0.5.2-r1.ebuild16
-rw-r--r--dev-libs/libaio/libaio-0.3.15.ebuild8
-rw-r--r--dev-libs/libextractor/libextractor-0.2.2.ebuild21
6 files changed, 42 insertions, 34 deletions
diff --git a/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild b/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild
index 7c3b1c9cd1ef..4d5bf7629e6c 100644
--- a/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild
+++ b/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild,v 1.12 2004/04/16 02:33:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-3.1.0-r1.ebuild,v 1.13 2004/04/21 16:37:55 vapier Exp $
-inherit flag-o-matic
+inherit flag-o-matic eutils
DESCRIPTION="Beecrypt is a general-purpose cryptography library."
HOMEPAGE="http://sourceforge.net/projects/beecrypt"
@@ -45,5 +45,5 @@ src_install() {
make DESTDIR=${D} install || die "make install failed"
# Not needed
rm -f ${D}/usr/lib/python*/site-packages/_bc.*a
- dodoc BUGS README BENCHMARKS NEWS || die "dodoc failed"
+ dodoc BUGS README BENCHMARKS NEWS
}
diff --git a/dev-libs/gmp/gmp-4.1-r1.ebuild b/dev-libs/gmp/gmp-4.1-r1.ebuild
index 9ee6082a7504..9e0cf5002576 100644
--- a/dev-libs/gmp/gmp-4.1-r1.ebuild
+++ b/dev-libs/gmp/gmp-4.1-r1.ebuild
@@ -1,14 +1,17 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-4.1-r1.ebuild,v 1.18 2004/02/24 17:55:12 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-4.1-r1.ebuild,v 1.19 2004/04/21 16:38:20 vapier Exp $
+
+inherit eutils
DESCRIPTION="Library for arithmetic on arbitrary precision integers, rational numbers, and floating-point numbers"
HOMEPAGE="http://www.gnu.org/software/gmp/gmp.html"
SRC_URI="ftp://prep.ai.mit.edu/gnu/gmp/${P}.tar.gz"
-SLOT="0"
LICENSE="LGPL-2"
+SLOT="0"
KEYWORDS="x86 ppc sparc alpha"
+IUSE=""
DEPEND="~sys-devel/m4-1.4"
@@ -35,7 +38,7 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die
- dodoc AUTHORS ChangeLog COPYING* NEWS README
+ dodoc AUTHORS ChangeLog NEWS README
dodoc doc/configuration doc/isa_abi_headache
dohtml -r doc
}
diff --git a/dev-libs/gmp/gmp-4.1.2.ebuild b/dev-libs/gmp/gmp-4.1.2.ebuild
index e511a259ef2d..933e31c21e7d 100644
--- a/dev-libs/gmp/gmp-4.1.2.ebuild
+++ b/dev-libs/gmp/gmp-4.1.2.ebuild
@@ -1,16 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-4.1.2.ebuild,v 1.18 2004/04/03 09:31:23 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/gmp/gmp-4.1.2.ebuild,v 1.19 2004/04/21 16:39:16 vapier Exp $
inherit flag-o-matic libtool
-filter-flags -ffast-math
DESCRIPTION="Library for arithmetic on arbitrary precision integers, rational numbers, and floating-point numbers"
HOMEPAGE="http://www.gnu.org/software/gmp/gmp.html"
SRC_URI="mirror://gnu/gmp/${P}.tar.gz"
-SLOT="0"
+
LICENSE="LGPL-2"
-KEYWORDS="x86 ppc sparc alpha amd64 ia64 ~mips hppa"
+SLOT="0"
+KEYWORDS="x86 ppc sparc ~mips alpha hppa amd64 ia64"
+IUSE=""
+
DEPEND="~sys-devel/m4-1.4"
src_unpack() {
@@ -21,6 +23,8 @@ src_unpack() {
}
src_compile() {
+ filter-flags -ffast-math
+
elibtoolize
local myconf=""
@@ -39,7 +43,7 @@ src_compile() {
# It's pretty slow to run all the checks, and not really necessary
# on every build of this package. Just run the checks when
# debugging is enabled. (23 Feb 2003 agriffis)
- if [ `use debug` ] ; then
+ if use debug ; then
make check || die "make check failed"
fi
}
@@ -47,7 +51,7 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die "make install failed"
- dodoc AUTHORS ChangeLog COPYING* NEWS README
+ dodoc AUTHORS ChangeLog NEWS README
dodoc doc/configuration doc/isa_abi_headache
dohtml -r doc
}
diff --git a/dev-libs/ibpp/ibpp-1.0.5.2-r1.ebuild b/dev-libs/ibpp/ibpp-1.0.5.2-r1.ebuild
index eac58ad031e8..b03e562b5f71 100644
--- a/dev-libs/ibpp/ibpp-1.0.5.2-r1.ebuild
+++ b/dev-libs/ibpp/ibpp-1.0.5.2-r1.ebuild
@@ -1,14 +1,17 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/ibpp/ibpp-1.0.5.2-r1.ebuild,v 1.12 2004/03/14 12:21:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/ibpp/ibpp-1.0.5.2-r1.ebuild,v 1.13 2004/04/21 16:40:03 vapier Exp $
+
+inherit eutils
DESCRIPTION="IBPP, a C++ client API for firebird 1.0"
HOMEPAGE="http://www.ibpp.org/"
SRC_URI="mirror://sourceforge/ibpp/${P//./-}-src.zip"
-SLOT="0"
LICENSE="MPL-1.1"
+SLOT="0"
KEYWORDS="x86 -sparc"
+IUSE=""
DEPEND=">=sys-apps/portage-2.0.47-r10
>=dev-db/firebird-1.0"
@@ -25,11 +28,10 @@ src_compile() {
emake PLATFORM="linux" || die
}
-src_install () {
- dodir /usr/include
+src_install() {
insinto /usr/include
- doins ibpp.h
+ doins ibpp.h || die "doins failed"
cd release/linux
- dolib.so libibpp.so libibpp_core.so libibpp_helper.so
- dolib.a libibpp.a libibpp_core.a libibpp_helper.a
+ dolib.so libibpp.so libibpp_core.so libibpp_helper.so || die "dolib.so failed"
+ dolib.a libibpp.a libibpp_core.a libibpp_helper.a || die "dolib.a failed"
}
diff --git a/dev-libs/libaio/libaio-0.3.15.ebuild b/dev-libs/libaio/libaio-0.3.15.ebuild
index 580c6ffce243..fed1e7dd9077 100644
--- a/dev-libs/libaio/libaio-0.3.15.ebuild
+++ b/dev-libs/libaio/libaio-0.3.15.ebuild
@@ -1,11 +1,13 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libaio/libaio-0.3.15.ebuild,v 1.2 2004/03/14 12:28:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libaio/libaio-0.3.15.ebuild,v 1.3 2004/04/21 16:40:32 vapier Exp $
+
+inherit eutils
DESCRIPTION="Asynchronous input/output library maintained by RedHat, required by Oracle9i AMD64 edition"
+HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/andrea/libaio/"
#SRC_URI="mirror://gentoo/${P}.tar.bz2"
SRC_URI="http://www.kernel.org/pub/linux/kernel/people/andrea/libaio/${P}-2.5-2.tar.bz2"
-HOMEPAGE="http://www.kernel.org/pub/linux/kernel/people/andrea/libaio/"
LICENSE="LGPL-2"
SLOT="0"
@@ -14,7 +16,7 @@ IUSE="nls"
DEPEND=""
-S="${S}-2.5-2"
+S="${WORKDIR}/${P}-2.5-2"
src_compile() {
cd ${S}
diff --git a/dev-libs/libextractor/libextractor-0.2.2.ebuild b/dev-libs/libextractor/libextractor-0.2.2.ebuild
index a0249333218b..e82695a70778 100644
--- a/dev-libs/libextractor/libextractor-0.2.2.ebuild
+++ b/dev-libs/libextractor/libextractor-0.2.2.ebuild
@@ -1,16 +1,18 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libextractor/libextractor-0.2.2.ebuild,v 1.8 2004/03/25 03:19:59 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libextractor/libextractor-0.2.2.ebuild,v 1.9 2004/04/21 16:41:26 vapier Exp $
-inherit libtool
+inherit libtool eutils
-IUSE="oggvorbis static"
DESCRIPTION="A simple library for keyword extraction"
HOMEPAGE="http://www.ovmj.org/~samanta/libextractor"
SRC_URI="http://www.ovmj.org/~samanta/libextractor/download/${P}.tar.bz2"
-SLOT="0"
+
LICENSE="LGPL-2.1"
+SLOT="0"
KEYWORDS="x86 sparc"
+IUSE="oggvorbis static"
+
# does not work with rpm-4.2
DEPEND=">=sys-devel/libtool-1.4.1
<app-arch/rpm-4.2
@@ -19,22 +21,17 @@ DEPEND=">=sys-devel/libtool-1.4.1
src_unpack() {
unpack ${A}
# patch their half baked attempt at supporting ogg vorbis
- epatch ${FILESDIR}/${P}-vorbisfile.patch || die "patch failed"
+ epatch ${FILESDIR}/${P}-vorbisfile.patch
}
src_compile() {
elibtoolize
- local myconf
- myconf="--with-gnu-ld"
export CPPFLAGS="-I/usr/include/rpm"
- use static \
- && myconf="${myconf} --enable-static" \
- || myconf="${myconf} --disable-static"
- econf ${myconf}
+ econf `use_enable static` || die
make || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
}