summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2013-04-24 08:48:34 +0000
committerEray Aslan <eras@gentoo.org>2013-04-24 08:48:34 +0000
commit4fb5174b742c3d268d76c077accc53ba25929055 (patch)
treef99099ca68723602a52cd0366585ca08c3864b3b /dev-libs
parentAdd ~ppc, wrt bug #461346 (diff)
downloadgentoo-2-4fb5174b742c3d268d76c077accc53ba25929055.tar.gz
gentoo-2-4fb5174b742c3d268d76c077accc53ba25929055.tar.bz2
gentoo-2-4fb5174b742c3d268d76c077accc53ba25929055.zip
Do not use automake-1.13 until fixed - bug #466994
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 0x77F1F175586A3B1F)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/cyrus-sasl/ChangeLog6
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-2.1.25-r4.ebuild10
-rw-r--r--dev-libs/cyrus-sasl/cyrus-sasl-2.1.26-r1.ebuild13
3 files changed, 25 insertions, 4 deletions
diff --git a/dev-libs/cyrus-sasl/ChangeLog b/dev-libs/cyrus-sasl/ChangeLog
index 6e4a081d89ab..47a608125561 100644
--- a/dev-libs/cyrus-sasl/ChangeLog
+++ b/dev-libs/cyrus-sasl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/cyrus-sasl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.278 2013/03/11 11:57:14 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/ChangeLog,v 1.279 2013/04/24 08:48:34 eras Exp $
+
+ 24 Apr 2013; Eray Aslan <eras@gentoo.org> cyrus-sasl-2.1.25-r4.ebuild,
+ cyrus-sasl-2.1.26-r1.ebuild:
+ Do not use automake-1.13 until fixed - bug #466994
11 Mar 2013; Eray Aslan <eras@gentoo.org> -cyrus-sasl-2.1.25-r3.ebuild,
-cyrus-sasl-2.1.26.ebuild:
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.25-r4.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.25-r4.ebuild
index 67aa4eef6b2a..d3d479904b8e 100644
--- a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.25-r4.ebuild
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.25-r4.ebuild
@@ -1,8 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.25-r4.ebuild,v 1.14 2013/03/01 12:43:42 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.25-r4.ebuild,v 1.15 2013/04/24 08:48:34 eras Exp $
EAPI=4
+
+# should be fixed in automake-1.13.2(?). Please test and remove if appropriate.
+# See automake bug #13514
+WANT_AUTOMAKE="1.12"
+
inherit eutils flag-o-matic multilib autotools pam java-pkg-opt-2 db-use
SASLAUTHD_CONF_VER="2.1.21"
@@ -59,6 +64,9 @@ src_prepare() {
sed -i '/^sasldir =/s:=.*:= $(plugindir):' \
"${S}"/plugins/Makefile.{am,in} || die "sed failed"
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g' \
+ configure.in || die
+
AT_M4DIR="${S}/cmulocal ${S}/config" eautoreconf
}
diff --git a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.26-r1.ebuild b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.26-r1.ebuild
index 4efa4f99f9ef..b0905815cde1 100644
--- a/dev-libs/cyrus-sasl/cyrus-sasl-2.1.26-r1.ebuild
+++ b/dev-libs/cyrus-sasl/cyrus-sasl-2.1.26-r1.ebuild
@@ -1,8 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.26-r1.ebuild,v 1.2 2013/02/23 22:25:47 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cyrus-sasl/cyrus-sasl-2.1.26-r1.ebuild,v 1.3 2013/04/24 08:48:34 eras Exp $
EAPI=5
+
+# should be fixed in automake-1.13.2(?). Please test when released.
+# See automake bug #13514
+WANT_AUTOMAKE="1.12"
+
inherit eutils flag-o-matic multilib autotools pam java-pkg-opt-2 db-use
SASLAUTHD_CONF_VER="2.1.21"
@@ -50,12 +55,16 @@ src_prepare() {
# Get rid of the -R switch (runpath_switch for Sun)
# >=gcc-4.6 errors out with unknown option
- sed -i -e '/LIB_SQLITE.*-R/s/ -R[^"]*//' configure.in
+ sed -i -e '/LIB_SQLITE.*-R/s/ -R[^"]*//' \
+ configure.in || die
# Use plugindir for sasldir
sed -i '/^sasldir =/s:=.*:= $(plugindir):' \
"${S}"/plugins/Makefile.{am,in} || die "sed failed"
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:g' \
+ configure.in || die
+
eautoreconf
}