summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2008-12-08 21:24:47 +0000
committerHans de Graaff <graaff@gentoo.org>2008-12-08 21:24:47 +0000
commit3cb4600e97872f622d12372a35f230f336cac1ef (patch)
tree8b37f46ae6a5bc23785a070f15e9329ee8c25063 /dev-libs
parentVersion bump, found no changelog or security alert. (diff)
downloadgentoo-2-3cb4600e97872f622d12372a35f230f336cac1ef.tar.gz
gentoo-2-3cb4600e97872f622d12372a35f230f336cac1ef.tar.bz2
gentoo-2-3cb4600e97872f622d12372a35f230f336cac1ef.zip
Version bump to address #250232
(Portage version: 2.1.6/cvs/Linux 2.6.26-gentoo-r2 x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/fcgi/ChangeLog9
-rw-r--r--dev-libs/fcgi/fcgi-2.4.1_pre0311112127.ebuild55
2 files changed, 63 insertions, 1 deletions
diff --git a/dev-libs/fcgi/ChangeLog b/dev-libs/fcgi/ChangeLog
index 5e832ff89ed6..6545bced4bd9 100644
--- a/dev-libs/fcgi/ChangeLog
+++ b/dev-libs/fcgi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-libs/fcgi
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/fcgi/ChangeLog,v 1.37 2008/12/08 20:40:28 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/fcgi/ChangeLog,v 1.38 2008/12/08 21:24:47 graaff Exp $
+
+*fcgi-2.4.1_pre0311112127 (08 Dec 2008)
+
+ 08 Dec 2008; Hans de Graaff <graaff@gentoo.org>
+ +fcgi-2.4.1_pre0311112127.ebuild:
+ Version bump to latest snapshot to address bug raised in #250232.
+ Hardcode version number since it won't change anytime soon. Use emake.
08 Dec 2008; Hans de Graaff <graaff@gentoo.org> -fcgi-2.4.0.ebuild:
Remove old version
diff --git a/dev-libs/fcgi/fcgi-2.4.1_pre0311112127.ebuild b/dev-libs/fcgi/fcgi-2.4.1_pre0311112127.ebuild
new file mode 100644
index 000000000000..1aecbf633924
--- /dev/null
+++ b/dev-libs/fcgi/fcgi-2.4.1_pre0311112127.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/fcgi/fcgi-2.4.1_pre0311112127.ebuild,v 1.1 2008/12/08 21:24:47 graaff Exp $
+
+inherit eutils autotools multilib
+
+DESCRIPTION="FastCGI Developer's Kit"
+HOMEPAGE="http://www.fastcgi.com/"
+SRC_URI="http://www.fastcgi.com/dist/fcgi-2.4.1-SNAP-0311112127.tar.gz"
+
+LICENSE="FastCGI"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="html"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/fcgi-2.4.1-SNAP-0311112127"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/fcgi-2.4.0-Makefile.patch"
+ epatch "${FILESDIR}/fcgi-2.4.0-clientdata-pointer.patch"
+ epatch "${FILESDIR}/fcgi-2.4.0-html-updates.patch"
+
+ eautoreconf
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install LIBRARY_PATH="${D}/usr/$(get_libdir)" || die
+
+ dodoc README
+
+ # install the manpages into the right place
+ doman doc/*.[13]
+
+ # Only install the html documentation if USE=html
+ if use html ; then
+ dohtml "${S}"/doc/*/*
+ insinto /usr/share/doc/${PF}/html
+ doins -r "${S}/images"
+ fi
+
+ # install examples in the right place
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}/examples/"*.c
+}