summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-01-22 06:58:42 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-01-22 06:58:42 +0000
commit2aadc152c6ad303b2f2dbc4d8769e747df19fbd2 (patch)
tree70b00c128e5de5a54f92fe917c981e2158077f65 /dev-libs
parentmodular X depends... kk thx :) (diff)
downloadgentoo-2-2aadc152c6ad303b2f2dbc4d8769e747df19fbd2.tar.gz
gentoo-2-2aadc152c6ad303b2f2dbc4d8769e747df19fbd2.tar.bz2
gentoo-2-2aadc152c6ad303b2f2dbc4d8769e747df19fbd2.zip
version bump
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/botan/ChangeLog7
-rw-r--r--dev-libs/botan/Manifest2
-rw-r--r--dev-libs/botan/botan-1.4.12.ebuild78
-rw-r--r--dev-libs/botan/files/digest-botan-1.4.121
4 files changed, 87 insertions, 1 deletions
diff --git a/dev-libs/botan/ChangeLog b/dev-libs/botan/ChangeLog
index 222754481ad7..39bdce666f89 100644
--- a/dev-libs/botan/ChangeLog
+++ b/dev-libs/botan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/botan
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.14 2006/01/07 20:31:01 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/ChangeLog,v 1.15 2006/01/22 06:58:42 dragonheart Exp $
+
+*botan-1.4.12 (22 Jan 2006)
+
+ 22 Jan 2006; Daniel Black <dragonheart@gentoo.org> +botan-1.4.12.ebuild:
+ version bump
07 Jan 2006; <nixnut@gentoo.org> botan-1.4.9.ebuild:
Stable on ppc Bug #118002
diff --git a/dev-libs/botan/Manifest b/dev-libs/botan/Manifest
index 26b8b7dce5bf..9e35e1fa2c2b 100644
--- a/dev-libs/botan/Manifest
+++ b/dev-libs/botan/Manifest
@@ -1,10 +1,12 @@
MD5 a0281f6723976a53fdefad4cc7e761a2 ChangeLog 2558
MD5 c7ad182eb1036a405d6fdf92cfc0d4d1 botan-1.4.11.ebuild 2466
+MD5 c7ad182eb1036a405d6fdf92cfc0d4d1 botan-1.4.12.ebuild 2466
MD5 043543f19cd858215284f52640cd15ce botan-1.4.4.ebuild 2392
MD5 cc8e69ca2141787b033cbbacac2fac2b botan-1.4.9.ebuild 2550
MD5 2214700974b810ad0c871ae2110ff054 files/botan-1.4.4-gcc34.patch 479
MD5 f997b850a6fbcfc3be36b7d4133b029a files/botan-1.4.9-gcc-4.patch 493
MD5 9105f271f3d69095584cafe41c3131ef files/digest-botan-1.4.11 62
+MD5 dd4fc27631c5ec1ca4f874f32409860f files/digest-botan-1.4.12 62
MD5 010820c4ff5b87a3b62ea84bee465eed files/digest-botan-1.4.4 61
MD5 f35ec7d42986b3a8a270b4aaa7483817 files/digest-botan-1.4.9 61
MD5 d769a7ef93cd04ed5de9f468af0979cd metadata.xml 463
diff --git a/dev-libs/botan/botan-1.4.12.ebuild b/dev-libs/botan/botan-1.4.12.ebuild
new file mode 100644
index 000000000000..238332e17621
--- /dev/null
+++ b/dev-libs/botan/botan-1.4.12.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/botan/botan-1.4.12.ebuild,v 1.1 2006/01/22 06:58:42 dragonheart Exp $
+
+# Comments/fixes to lloyd@randombit.net (author)
+
+DESCRIPTION="A C++ crypto library"
+HOMEPAGE="http://botan.randombit.net/"
+SRC_URI="http://botan.randombit.net/files/Botan-${PV}.tgz"
+
+KEYWORDS="~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="BSD"
+IUSE="bzip2 gmp ssl zlib"
+
+S="${WORKDIR}/Botan-${PV}"
+
+RDEPEND="virtual/libc
+ bzip2? ( >=app-arch/bzip2-1.0.1 )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+ gmp? ( >=dev-libs/gmp-4.1.2 )
+ ssl? ( >=dev-libs/openssl-0.9.7d )"
+
+# configure.pl requires DirHandle, Getopt::Long, File::Spec, and File::Copy;
+# all seem included in dev-lang/perl ATM.
+DEPEND="${RDEPEND}
+ dev-lang/perl"
+
+src_compile() {
+ # Modules that should work under any semi-recent Unix
+ local modules="alloc_mmap,es_egd,es_ftw,es_unix,fd_unix,ml_unix,tm_unix,tm_posix,mux_pthr"
+
+ if useq bzip2; then modules="$modules,comp_bzip2"; fi
+ if useq zlib; then modules="$modules,comp_zlib"; fi
+ if useq gmp; then modules="$modules,eng_gmp"; fi
+ if useq ssl; then modules="$modules,eng_ossl"; fi
+ # removed?
+ #if useq qt; then modules="$modules,mux_qt"; fi
+
+ # This is also supported on i586+ - hope this is correct.
+ # documention says sparc though not enables because of
+ # http://bugs.gentoo.org/show_bug.cgi?id=71760#c11
+ if [ ${ARCH} = 'alpha' -o ${ARCH} = 'amd64' ] || \
+ [ ${ARCH} = 'x86' -a ${CHOST:0:4} != "i386" -a ${CHOST:0:4} != "i486" ]; then
+ modules="$modules,tm_hard"
+ fi
+
+ # should be enabled on mips64
+ if [ "${ARCH}" = 'alpha' -o "${ARCH}" = 'amd64' -o \
+ "${ARCH}" = 'ia64' -o "${ARCH}" = 'ppc64' -o "${PROFILE_ARCH}" = 'mips64' ]; then
+ modules="$modules,mp_asm64"
+ fi
+
+ # Enable v9 instructions for sparc64
+ if [ "${PROFILE_ARCH}" = "sparc64" ]; then
+ CHOSTARCH='sparc32-v9'
+ else
+ CHOSTARCH=$(echo ${CHOST} | cut -d - -f 1)
+ fi
+
+ cd ${S}
+ einfo "Enabling modules: " ${modules}
+
+ # FIXME: We might actually be on *BSD or OS X...
+ ./configure.pl --noauto gcc-linux-${CHOSTARCH} --modules=$modules ||
+ die "configure.pl failed"
+ emake "LIB_OPT=${CXXFLAGS}" "MACH_OPT=" || die "emake failed"
+}
+
+src_test() {
+ chmod -R ugo+rX ${S}
+ emake check || die "emake check failed"
+ env LD_LIBRARY_PATH=${S} ./check --validate || die "validation tests failed"
+}
+
+src_install() {
+ make INSTALLROOT="${D}/usr" install || die "make install failed"
+}
diff --git a/dev-libs/botan/files/digest-botan-1.4.12 b/dev-libs/botan/files/digest-botan-1.4.12
new file mode 100644
index 000000000000..9ee24af4a786
--- /dev/null
+++ b/dev-libs/botan/files/digest-botan-1.4.12
@@ -0,0 +1 @@
+MD5 0bb60ed7c9f454fab6df9a06916fbec6 Botan-1.4.12.tgz 1801371