summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2013-12-31 18:23:49 +0000
committerMatt Turner <mattst88@gentoo.org>2013-12-31 18:23:49 +0000
commit29226e6b7a852833debe378e0d08ed5f2eae39d9 (patch)
tree128ffd61f86eeeca7b1d316349f45f920826b075 /dev-libs
parentAdd missing MULTILIB_USEDEP to dependencies. (diff)
downloadgentoo-2-29226e6b7a852833debe378e0d08ed5f2eae39d9.tar.gz
gentoo-2-29226e6b7a852833debe378e0d08ed5f2eae39d9.tar.bz2
gentoo-2-29226e6b7a852833debe378e0d08ed5f2eae39d9.zip
Version bump to 1.3.0, bug 494900.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 974CA72A)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/wayland/ChangeLog7
-rw-r--r--dev-libs/wayland/wayland-1.3.0.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/dev-libs/wayland/ChangeLog b/dev-libs/wayland/ChangeLog
index 43bbaf61f60b..20378f4ae175 100644
--- a/dev-libs/wayland/ChangeLog
+++ b/dev-libs/wayland/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/wayland
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/ChangeLog,v 1.31 2013/12/31 18:11:14 mattst88 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/ChangeLog,v 1.32 2013/12/31 18:23:49 mattst88 Exp $
+
+*wayland-1.3.0 (31 Dec 2013)
+
+ 31 Dec 2013; Matt Turner <mattst88@gentoo.org> +wayland-1.3.0.ebuild:
+ Version bump to 1.3.0, bug 494900.
31 Dec 2013; Matt Turner <mattst88@gentoo.org> wayland-1.2.1-r1.ebuild:
Add missing MULTILIB_USEDEP to dependencies.
diff --git a/dev-libs/wayland/wayland-1.3.0.ebuild b/dev-libs/wayland/wayland-1.3.0.ebuild
new file mode 100644
index 000000000000..33039283795b
--- /dev/null
+++ b/dev-libs/wayland/wayland-1.3.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/wayland-1.3.0.ebuild,v 1.1 2013/12/31 18:23:49 mattst88 Exp $
+
+EAPI=5
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/${PN}/${PN}"
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ AUTOTOOLS_AUTORECONF=1
+fi
+
+inherit autotools-multilib toolchain-funcs $GIT_ECLASS
+
+DESCRIPTION="Wayland protocol libraries"
+HOMEPAGE="http://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+ KEYWORDS=""
+else
+ SRC_URI="http://wayland.freedesktop.org/releases/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="doc static-libs"
+
+RDEPEND="dev-libs/expat[${MULTILIB_USEDEP}]
+ virtual/libffi[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Remove resources-test from TESTS as it has failed since it was added.
+ sed -i -e 's/ resources-test$(EXEEXT)/ $(NULL)/' ${S}/tests/Makefile.in || die
+
+ autotools-multilib_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc documentation)
+ )
+ if tc-is-cross-compiler ; then
+ myeconfargs+=( --disable-scanner )
+ fi
+ if ! multilib_build_binaries; then
+ myeconfargs+=( --disable-documentation )
+ fi
+
+ autotools-multilib_src_configure
+}
+
+src_test() {
+ export XDG_RUNTIME_DIR="${T}/runtime-dir"
+ mkdir "${XDG_RUNTIME_DIR}" || die
+ chmod 0700 "${XDG_RUNTIME_DIR}" || die
+
+ autotools-multilib_src_test
+}