summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2010-03-14 20:22:33 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2010-03-14 20:22:33 +0000
commit1b45451a30ccee35c64ef11097def0ddfbcb4b61 (patch)
tree941cdd7582aad6801f165ed3255b0ab8b8db70a4 /dev-libs
parent- Version bump. Convert EAPI=2 and disable pam by default. Add ipv6 to IUSE t... (diff)
downloadgentoo-2-1b45451a30ccee35c64ef11097def0ddfbcb4b61.tar.gz
gentoo-2-1b45451a30ccee35c64ef11097def0ddfbcb4b61.tar.bz2
gentoo-2-1b45451a30ccee35c64ef11097def0ddfbcb4b61.zip
All: fixed one QA warning (dohtml -r needed)
Testing: added doc and static-libs USE flags, xmlto removed from dependencies, moved python to DEPEND ACK from Mike (Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/zziplib/ChangeLog11
-rw-r--r--dev-libs/zziplib/zziplib-0.13.49-r1.ebuild6
-rw-r--r--dev-libs/zziplib/zziplib-0.13.58-r1.ebuild (renamed from dev-libs/zziplib/zziplib-0.13.58.ebuild)29
3 files changed, 33 insertions, 13 deletions
diff --git a/dev-libs/zziplib/ChangeLog b/dev-libs/zziplib/ChangeLog
index c1fdda866563..16d8125db13b 100644
--- a/dev-libs/zziplib/ChangeLog
+++ b/dev-libs/zziplib/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/zziplib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/zziplib/ChangeLog,v 1.71 2010/02/21 00:12:40 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/zziplib/ChangeLog,v 1.72 2010/03/14 20:22:32 reavertm Exp $
+
+*zziplib-0.13.58-r1 (14 Mar 2010)
+
+ 14 Mar 2010; Maciej Mrozowski <reavertm@gentoo.org>
+ zziplib-0.13.49-r1.ebuild, -zziplib-0.13.58.ebuild,
+ +zziplib-0.13.58-r1.ebuild:
+ All: fixed one QA warning (dohtml -r needed), Testing: added doc and
+ static-libs USE flags, xmlto removed from dependencies, moved python
+ to DEPEND, ACK from Mike
21 Feb 2010; Jonathan Callen <abcd@gentoo.org> zziplib-0.13.58.ebuild:
Transfer prefix keywords, dep on app-text/xmlto on Darwin
diff --git a/dev-libs/zziplib/zziplib-0.13.49-r1.ebuild b/dev-libs/zziplib/zziplib-0.13.49-r1.ebuild
index 6c50ff017b8b..43fc3ee5e44b 100644
--- a/dev-libs/zziplib/zziplib-0.13.49-r1.ebuild
+++ b/dev-libs/zziplib/zziplib-0.13.49-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/zziplib/zziplib-0.13.49-r1.ebuild,v 1.14 2009/01/07 17:48:46 ken69267 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/zziplib/zziplib-0.13.49-r1.ebuild,v 1.15 2010/03/14 20:22:33 reavertm Exp $
inherit libtool fixheadtails eutils
@@ -48,5 +48,5 @@ src_test() {
src_install() {
emake DESTDIR="${D}" install install-man3 || die "make install failed"
dodoc ChangeLog README TODO
- dohtml docs/*
+ dohtml -r docs/*
}
diff --git a/dev-libs/zziplib/zziplib-0.13.58.ebuild b/dev-libs/zziplib/zziplib-0.13.58-r1.ebuild
index f23460af7924..28cccc84c367 100644
--- a/dev-libs/zziplib/zziplib-0.13.58.ebuild
+++ b/dev-libs/zziplib/zziplib-0.13.58-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/zziplib/zziplib-0.13.58.ebuild,v 1.2 2010/02/21 00:12:40 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/zziplib/zziplib-0.13.58-r1.ebuild,v 1.1 2010/03/14 20:22:33 reavertm Exp $
EAPI="2"
@@ -13,15 +13,14 @@ SRC_URI="mirror://sourceforge/zziplib/${P}.tar.bz2"
LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="sdl test"
+IUSE="doc sdl static-libs test"
-RDEPEND=">=dev-lang/python-2.4
- sys-libs/zlib
+RDEPEND="sys-libs/zlib
sdl? ( >=media-libs/libsdl-1.2.6 )"
DEPEND="${RDEPEND}
+ >=dev-lang/python-2.4
dev-util/pkgconfig
- test? ( app-arch/zip )
- kernel_Darwin? ( app-text/xmlto )"
+ test? ( app-arch/zip )"
src_prepare() {
epatch "${FILESDIR}"/${PN}-0.13.49-SDL-test.patch
@@ -33,7 +32,10 @@ src_prepare() {
src_configure() {
append-flags -fno-strict-aliasing # bug reported upstream
- econf $(use_enable sdl)
+ export ac_cv_path_XMLTO=
+ econf \
+ $(use_enable sdl) \
+ $(use_enable static-libs static)
}
src_test() {
@@ -43,7 +45,16 @@ src_test() {
}
src_install() {
- emake DESTDIR="${D}" install install-man3 || die "make install failed"
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ if ! use static-libs; then
+ find "${D}" -type f -name '*.la' -exec rm {} + \
+ || die "la removal failed"
+ fi
+
dodoc ChangeLog README TODO
- dohtml docs/*
+
+ if use doc; then
+ dohtml -r docs/* || die 'dohtml failed'
+ fi
}