summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-08-19 17:07:05 +0000
committerMike Frysinger <vapier@gentoo.org>2008-08-19 17:07:05 +0000
commit189372481a606068257014a49b4db2517d6f1067 (patch)
treec38f3ed1d382302ff59b9bc1bf5052827c6f5d53 /dev-libs
parentStable on sparc, bug #235014 (diff)
downloadgentoo-2-189372481a606068257014a49b4db2517d6f1067.tar.gz
gentoo-2-189372481a606068257014a49b4db2517d6f1067.tar.bz2
gentoo-2-189372481a606068257014a49b4db2517d6f1067.zip
Version bump #235041.
(Portage version: 2.2_rc6/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/DFB++/ChangeLog10
-rw-r--r--dev-libs/DFB++/DFB++-1.2.0.ebuild29
-rw-r--r--dev-libs/DFB++/files/DFB++-1.2.0-directfb-api.patch28
3 files changed, 65 insertions, 2 deletions
diff --git a/dev-libs/DFB++/ChangeLog b/dev-libs/DFB++/ChangeLog
index 5d2b9ac04c5d..e30cde0661c7 100644
--- a/dev-libs/DFB++/ChangeLog
+++ b/dev-libs/DFB++/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/DFB++
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/DFB++/ChangeLog,v 1.8 2007/11/10 02:04:34 tupone Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DFB++/ChangeLog,v 1.9 2008/08/19 17:07:05 vapier Exp $
+
+*DFB++-1.2.0 (19 Aug 2008)
+
+ 19 Aug 2008; Mike Frysinger <vapier@gentoo.org>
+ +files/DFB++-1.2.0-directfb-api.patch, +DFB++-1.2.0.ebuild:
+ Version bump #235041.
*DFB++-1.0.0 (10 Nov 2007)
diff --git a/dev-libs/DFB++/DFB++-1.2.0.ebuild b/dev-libs/DFB++/DFB++-1.2.0.ebuild
new file mode 100644
index 000000000000..0196f9229fea
--- /dev/null
+++ b/dev-libs/DFB++/DFB++-1.2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/DFB++/DFB++-1.2.0.ebuild,v 1.1 2008/08/19 17:07:05 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="C++ bindings for DirectFB"
+HOMEPAGE="http://www.directfb.org/dfb++.xml"
+SRC_URI="http://www.directfb.org/downloads/Extras/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/DirectFB-${PV}"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-directfb-api.patch #235041
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README
+}
diff --git a/dev-libs/DFB++/files/DFB++-1.2.0-directfb-api.patch b/dev-libs/DFB++/files/DFB++-1.2.0-directfb-api.patch
new file mode 100644
index 000000000000..6b6dfc5ba8cb
--- /dev/null
+++ b/dev-libs/DFB++/files/DFB++-1.2.0-directfb-api.patch
@@ -0,0 +1,28 @@
+fix building with DirectFB-1.2.3
+
+http://bugs.gentoo.org/235041
+
+patch by Philippe Weibel
+
+--- dfb++/idirectfbvideoprovider.cpp
++++ dfb++/idirectfbvideoprovider.cpp
+@@ -165,7 +165,7 @@
+ return level;
+ }
+
+-void IDirectFBVideoProvider::SetStreamAttributes (DFBStreamDescription attr)
++void IDirectFBVideoProvider::SetStreamAttributes (DFBStreamAttributes attr)
+ {
+ DFBCHECK( iface->SetStreamAttributes (iface, attr) );
+ }
+--- include/idirectfbvideoprovider.h
++++ include/idirectfbvideoprovider.h
+@@ -68,7 +68,7 @@
+ float GetVolume ();
+
+
+- void SetStreamAttributes (DFBStreamDescription attr);
++ void SetStreamAttributes (DFBStreamAttributes attr);
+
+ void SetAudioOutputs (DFBVideoProviderAudioUnits *audioUnits);
+ DFBVideoProviderAudioUnits GetAudioOutputs ();