summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-06-08 22:00:41 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-06-08 22:00:41 +0000
commit11aa5834abff01e36ddfb07f8869caff8d208087 (patch)
tree39611c7670485131b554f3d6a9915750cdedae50 /dev-libs
parentMarked ~hppa (bug #272692). (diff)
downloadgentoo-2-11aa5834abff01e36ddfb07f8869caff8d208087.tar.gz
gentoo-2-11aa5834abff01e36ddfb07f8869caff8d208087.tar.bz2
gentoo-2-11aa5834abff01e36ddfb07f8869caff8d208087.zip
Bump to 2.20.3. Bug fixes and translation updates. Define XDG environment variable for tests since they might not be present even when xdg-utils-1.0.2-r3 is installed, bug #269155.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/glib/ChangeLog11
-rw-r--r--dev-libs/glib/glib-2.16.6-r1.ebuild90
-rw-r--r--dev-libs/glib/glib-2.20.1.ebuild91
-rw-r--r--dev-libs/glib/glib-2.20.3.ebuild (renamed from dev-libs/glib/glib-2.20.1-r1.ebuild)9
4 files changed, 14 insertions, 187 deletions
diff --git a/dev-libs/glib/ChangeLog b/dev-libs/glib/ChangeLog
index dc3ead245b73..bff811ff8358 100644
--- a/dev-libs/glib/ChangeLog
+++ b/dev-libs/glib/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-libs/glib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.370 2009/05/18 21:37:06 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/ChangeLog,v 1.371 2009/06/08 22:00:41 eva Exp $
+
+*glib-2.20.3 (08 Jun 2009)
+
+ 08 Jun 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ -glib-2.16.6-r1.ebuild, -glib-2.20.1.ebuild, -glib-2.20.1-r1.ebuild,
+ +glib-2.20.3.ebuild:
+ Bump to 2.20.3. Bug fixes and translation updates. Define XDG environment
+ variable for tests since they might not be present even when
+ xdg-utils-1.0.2-r3 is installed, bug #269155.
18 May 2009; Gilles Dartiguelongue <eva@gentoo.org> glib-2.20.2.ebuild:
Remove unused patch.
diff --git a/dev-libs/glib/glib-2.16.6-r1.ebuild b/dev-libs/glib/glib-2.16.6-r1.ebuild
deleted file mode 100644
index e719dabecfa5..000000000000
--- a/dev-libs/glib/glib-2.16.6-r1.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.16.6-r1.ebuild,v 1.6 2009/03/26 14:03:45 armin76 Exp $
-
-inherit gnome.org libtool eutils flag-o-matic
-
-DESCRIPTION="The GLib library of C routines"
-HOMEPAGE="http://www.gtk.org/"
-
-LICENSE="LGPL-2"
-SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="debug doc fam hardened selinux xattr"
-
-RDEPEND="virtual/libc
- virtual/libiconv
- xattr? ( sys-apps/attr )
- fam? ( virtual/fam )"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.16
- >=sys-devel/gettext-0.11
- doc? (
- >=dev-libs/libxslt-1.0
- >=dev-util/gtk-doc-1.8
- ~app-text/docbook-xml-dtd-4.1.2
- )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- if use ppc64 && use hardened ; then
- replace-flags -O[2-3] -O1
- epatch "${FILESDIR}/glib-2.6.3-testglib-ssp.patch"
- fi
-
- if use ia64 ; then
- # Only apply for < 4.1
- local major=$(gcc-major-version)
- local minor=$(gcc-minor-version)
- if (( major < 4 || ( major == 4 && minor == 0 ) )); then
- epatch "${FILESDIR}/glib-2.10.3-ia64-atomic-ops.patch"
- fi
- fi
-
- # GNOME bug #538836, fix gio test failure on various arches
- sed -i -e 's:|\\<g_atomic_int\\|:|\\<g_atomic_int\\|\\<g_atomic_pointer_get\\|:' \
- "${S}/gio/pltcheck.sh"
-
- # Fix gmodule issues on fbsd; bug #184301
- epatch "${FILESDIR}"/${PN}-2.12.12-fbsd.patch
-
- # Fix g_base64 overruns. bug #249214
- epatch "${FILESDIR}"/glib2-CVE-2008-4316.patch
-
- [[ ${CHOST} == *-freebsd* ]] && elibtoolize
-}
-
-src_compile() {
- local myconf
-
- epunt_cxx
-
- # Building with --disable-debug highly unrecommended. It will build glib in
- # an unusable form as it disables some commonly used API. Please do not
- # convert this to the use_enable form, as it results in a broken build.
- # -- compnerd (3/27/06)
- use debug && myconf="--enable-debug"
-
- # always build static libs, see #153807
- econf ${myconf} \
- $(use_enable xattr) \
- $(use_enable doc man) \
- $(use_enable doc gtk-doc) \
- $(use_enable fam) \
- $(use_enable selinux) \
- --enable-static \
- --with-threads=posix || die "configure failed"
-
- emake || die "make failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- # Do not install charset.alias even if generated, leave it to libiconv
- rm -f "${D}/usr/lib/charset.alias"
-
- dodoc AUTHORS ChangeLog* NEWS* README
-}
diff --git a/dev-libs/glib/glib-2.20.1.ebuild b/dev-libs/glib/glib-2.20.1.ebuild
deleted file mode 100644
index 5e680c3cbb9a..000000000000
--- a/dev-libs/glib/glib-2.20.1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.20.1.ebuild,v 1.1 2009/05/04 21:24:07 eva Exp $
-
-EAPI="2"
-
-inherit gnome.org libtool eutils flag-o-matic
-
-DESCRIPTION="The GLib library of C routines"
-HOMEPAGE="http://www.gtk.org/"
-
-LICENSE="LGPL-2"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="debug doc fam hardened selinux xattr"
-
-RDEPEND="virtual/libc
- virtual/libiconv
- xattr? ( sys-apps/attr )
- fam? ( virtual/fam )"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.16
- >=sys-devel/gettext-0.11
- doc? (
- >=dev-libs/libxslt-1.0
- >=dev-util/gtk-doc-1.11
- ~app-text/docbook-xml-dtd-4.1.2 )"
-
-src_prepare() {
- if use ppc64 && use hardened ; then
- replace-flags -O[2-3] -O1
- epatch "${FILESDIR}/glib-2.6.3-testglib-ssp.patch"
- fi
-
- if use ia64 ; then
- # Only apply for < 4.1
- local major=$(gcc-major-version)
- local minor=$(gcc-minor-version)
- if (( major < 4 || ( major == 4 && minor == 0 ) )); then
- epatch "${FILESDIR}/glib-2.10.3-ia64-atomic-ops.patch"
- fi
- fi
-
- # Don't fail gio tests when ran without userpriv, upstream bug 552912
- # This is only a temporary workaround, remove as soon as possible
- epatch "${FILESDIR}/${PN}-2.18.1-workaround-gio-test-failure-without-userpriv.patch"
-
- # Fix gmodule issues on fbsd; bug #184301
- epatch "${FILESDIR}"/${PN}-2.12.12-fbsd.patch
-
- [[ ${CHOST} == *-freebsd* ]] && elibtoolize
-}
-
-src_configure() {
- local myconf
-
- epunt_cxx
-
- # Building with --disable-debug highly unrecommended. It will build glib in
- # an unusable form as it disables some commonly used API. Please do not
- # convert this to the use_enable form, as it results in a broken build.
- # -- compnerd (3/27/06)
- use debug && myconf="--enable-debug"
-
- # always build static libs, see #153807
- # Always use internal libpcre, bug #254659
- econf ${myconf} \
- $(use_enable xattr) \
- $(use_enable doc man) \
- $(use_enable doc gtk-doc) \
- $(use_enable fam) \
- $(use_enable selinux) \
- --enable-static \
- --enable-regex \
- --with-pcre=internal \
- --with-threads=posix
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- # Do not install charset.alias even if generated, leave it to libiconv
- rm -f "${D}/usr/lib/charset.alias"
-
- dodoc AUTHORS ChangeLog* NEWS* README || die "dodoc failed"
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- emake check || die "tests failed"
-}
diff --git a/dev-libs/glib/glib-2.20.1-r1.ebuild b/dev-libs/glib/glib-2.20.3.ebuild
index c8c706373147..afb1c51a340e 100644
--- a/dev-libs/glib/glib-2.20.1-r1.ebuild
+++ b/dev-libs/glib/glib-2.20.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.20.1-r1.ebuild,v 1.1 2009/05/04 22:06:50 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/glib/glib-2.20.3.ebuild,v 1.1 2009/06/08 22:00:41 eva Exp $
EAPI="2"
@@ -11,7 +11,7 @@ HOMEPAGE="http://www.gtk.org/"
LICENSE="LGPL-2"
SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
IUSE="debug doc fam hardened selinux xattr"
RDEPEND="virtual/libc
@@ -48,9 +48,6 @@ src_prepare() {
# Fix gmodule issues on fbsd; bug #184301
epatch "${FILESDIR}"/${PN}-2.12.12-fbsd.patch
- # Fix GIO null unref, bug #260301
- epatch "${FILESDIR}/${P}-gio-unref.patch"
-
[[ ${CHOST} == *-freebsd* ]] && elibtoolize
}
@@ -90,5 +87,7 @@ src_install() {
src_test() {
unset DBUS_SESSION_BUS_ADDRESS
+ export XDG_CONFIG_DIRS=/etc/xdg
+ export XDG_DATA_DIRS=/usr/local/share:/usr/share
emake check || die "tests failed"
}