summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-04-27 00:10:17 +0000
committerDaniel Goller <morfic@gentoo.org>2005-04-27 00:10:17 +0000
commit001d4bb7b0543881d2080e5d31ae9e6bb4c6d6ea (patch)
tree3ac47c16489cf4d02c2cca9ae90ba730574ffe9a /dev-libs
parentpyste has untested/unkeyworded deps on this arch (diff)
downloadgentoo-2-001d4bb7b0543881d2080e5d31ae9e6bb4c6d6ea.tar.gz
gentoo-2-001d4bb7b0543881d2080e5d31ae9e6bb4c6d6ea.tar.bz2
gentoo-2-001d4bb7b0543881d2080e5d31ae9e6bb4c6d6ea.zip
adding pyste support, adding bsd compatability and preliminary osx support
(Portage version: 2.0.51.20-r4)
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost/ChangeLog6
-rw-r--r--dev-libs/boost/Manifest14
-rw-r--r--dev-libs/boost/boost-1.32.0-r3.ebuild228
-rw-r--r--dev-libs/boost/files/digest-boost-1.32.0-r31
4 files changed, 237 insertions, 12 deletions
diff --git a/dev-libs/boost/ChangeLog b/dev-libs/boost/ChangeLog
index 2faf7d1a0f72..4a24e792abee 100644
--- a/dev-libs/boost/ChangeLog
+++ b/dev-libs/boost/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/boost
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.50 2005/04/20 10:28:57 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/ChangeLog,v 1.51 2005/04/27 00:10:17 morfic Exp $
+
+ 24 Apr 2005; Daniel Goller <morfic@gentoo.org> :
+ adding pyste support, adding bsd compatability and preliminary OSX
+ compatability bug 79517 and bug 84642
20 Apr 2005; Daniel Goller <morfic@gentoo.org> boost-1.32.0-r2.ebuild:
fix ! order
diff --git a/dev-libs/boost/Manifest b/dev-libs/boost/Manifest
index d6d057d52bf9..2e8abaaa56b3 100644
--- a/dev-libs/boost/Manifest
+++ b/dev-libs/boost/Manifest
@@ -1,12 +1,10 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 12f996aa5f489e4e51055e537ea059a8 boost-1.31.0.ebuild 3967
+MD5 d4a6cbfab30f1c707b234706c0b11688 boost-1.32.0-r3.ebuild 6204
MD5 8d4eca3eb59bc23e2d53b3d0cfd06c97 boost-1.32.0.ebuild 2294
MD5 d259ae434e176df207cba3deab973f61 boost-1.29.0.ebuild 1426
MD5 37f8eb8b22a26f2bc30b6101d14cb9d0 boost-1.32.0-r2.ebuild 5690
MD5 34d13e0eeb58e13e1992908d04d51b45 boost-1.30.0.ebuild 2973
-MD5 d34434c88fed7e882433ef7a69a1715c ChangeLog 7524
+MD5 d067155d58f2df47ec7d1c21cc9db30f ChangeLog 7685
MD5 ac17509c51769ef73346e3d3d7733f67 metadata.xml 347
MD5 7403141309dea4e7a191766eba147299 boost-1.32.0-r1.ebuild 5379
MD5 4759f9391ad73c487d4f6b3dbf8632a8 boost-1.30.2.ebuild 2960
@@ -17,10 +15,4 @@ MD5 4aa5a3b9a3818e9dce488a20cb5ff00b files/digest-boost-1.31.0 66
MD5 1d06245b53e5677556ae22e5f60f0df3 files/digest-boost-1.32.0 67
MD5 1d06245b53e5677556ae22e5f60f0df3 files/digest-boost-1.32.0-r1 67
MD5 1d06245b53e5677556ae22e5f60f0df3 files/digest-boost-1.32.0-r2 67
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.0 (GNU/Linux)
-
-iD4DBQFCZi2eUpKYMelfdYERAvyiAJYpXa2S3dqOoK9eLqRggHrqkKSsAJ4vR5Xm
-R0ijy7ehVErxvkwFyiS3TQ==
-=+o9C
------END PGP SIGNATURE-----
+MD5 1d06245b53e5677556ae22e5f60f0df3 files/digest-boost-1.32.0-r3 67
diff --git a/dev-libs/boost/boost-1.32.0-r3.ebuild b/dev-libs/boost/boost-1.32.0-r3.ebuild
new file mode 100644
index 000000000000..42cbeee0c08c
--- /dev/null
+++ b/dev-libs/boost/boost-1.32.0-r3.ebuild
@@ -0,0 +1,228 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/boost/boost-1.32.0-r3.ebuild,v 1.1 2005/04/27 00:10:17 morfic Exp $
+
+# This ebuild was generated by Ebuilder v0.4.
+inherit python distutils multilib eutils
+
+DESCRIPTION="Boost Libraries for C++"
+HOMEPAGE="http://www.boost.org/"
+BOOST_PV1=${PV/./_}
+BOOST_PV=${BOOST_PV1/./_}
+SRC_URI="mirror://sourceforge/boost/${PN}_${BOOST_PV}.tar.bz2"
+LICENSE="freedist Boost-1.0"
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc ~ppc64"
+IUSE="debug icc pyste static threads threadsonly"
+
+DEPEND="!icc? ( sys-devel/gcc )
+ icc? ( >=dev-lang/icc-8.0.055 )
+ dev-lang/python"
+
+RDEPEND="pyste? ( dev-cpp/gccxml dev-python/elementtree ) ${DEPEND}"
+
+S="${WORKDIR}/${PN}_${BOOST_PV}"
+
+pkg_setup() {
+
+ if [ "${ARCH}" == "amd64" ]; then
+ arch=
+ else
+ arch=${ARCH}
+ fi
+
+ if use icc ; then
+ BOOST_TOOLSET="intel-linux"
+ TOOLSET_NAME="icc"
+ SOSUFFIX="so"
+ elif use ppc-macos ; then
+ BOOST_TOOLSET="darwin"
+ TOOLSET_NAME="darwin"
+ SOSUFFIX="dylib"
+ else
+ BOOST_TOOLSET="gcc"
+ TOOLSET_NAME="gcc"
+ SOSUFFIX="so"
+ fi
+
+ if use static ; then
+ BUILD="release <runtime-link>static"
+ else
+ BUILD="release <runtime-link>dynamic"
+ fi
+
+ if use debug ; then
+ BUILD="${BUILD} debug"
+ fi
+
+ if use threads && use threadsonly ; then
+ BUILD="${BUILD} <threading>multi"
+ fi
+
+ if use threads && ! use threadsonly ; then
+ BUILD="${BUILD} <threading>single/multi"
+ fi
+
+ if ! use threads ; then
+ BUILD="${BUILD} <threading>single"
+ fi
+
+ BOOSTJAM=./tools/build/jam_src/bin.*/bjam
+
+ # we dont like what get_number_of_jobs does, so we borrow what counts to us,
+ # thanks H?kan Wessberg <nacka-gentoo@refug.org>, bug #13565
+
+ if [ "`egrep "^[[:space:]]*MAKEOPTS=" /etc/make.conf | wc -l`" -gt 0 ]; then
+ ADMINOPTS="`egrep "^[[:space:]]*MAKEOPTS=" /etc/make.conf | cut -d= -f2 | sed 's/\"//g'`"
+ ADMINPARAM="`echo ${ADMINOPTS} | gawk '{match($0, /-j *[0-9]*/, opt); print opt[0]}'`"
+ NUMJOBS="${ADMINPARAM}"
+ fi
+
+ python_version
+
+}
+
+src_compile() {
+ # Build bjam, a jam variant, which is used instead of make
+ cd "${S}/tools/build/jam_src"
+ ./build.sh ${BOOST_TOOLSET} || die "Failed to build bjam"
+ cd "${S}"
+
+ if use icc ; then
+ export CPLUS_INCLUDE_PATH="/opt/intel/compiler80/include/c++"
+ export GXX_INCLUDE="/usr/include"
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sINTEL_PATH="/opt/intel/compiler80/" \
+ -sBUILD="${BUILD}" \
+ --prefix=${D}/usr \
+ --layout=system
+
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sINTEL_PATH="/opt/intel/compiler80/" \
+ -sBUILD="${BUILD}" \
+ --prefix=${D}/usr \
+ --layout=system
+
+ else
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sBUILD="${BUILD}" \
+ --prefix=${D}/usr \
+ --layout=system
+
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sBUILD="${BUILD}" \
+ --prefix=${D}/usr \
+ --layout=system
+
+ fi
+
+ if use pyste; then
+ cd ${S}/libs/python/pyste/install
+ distutils_src_compile
+ fi
+}
+
+src_install () {
+ # install build tools
+ cd "${S}/tools/build"
+ #do_whatever is too limiting here, need to move bunch of different stuff recursively
+ insinto /usr/share/${PN}
+ doins -a b* index.html v1/ v2/ ${D}/usr/share/${PN} || die "failed to install docs"
+ cd "${S}"
+
+ if use icc ; then
+ export CPLUS_INCLUDE_PATH="/opt/intel/compiler80/include/c++"
+ export GXX_INCLUDE="/usr/include"
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sBUILD="${BUILD}" \
+ -sINTEL_PATH="/opt/intel/compiler80/" \
+ --prefix=${D}/usr \
+ --layout=system \
+ install || die "Install failed"
+ else
+ ${BOOSTJAM} ${NUMJOBS} -sBOOST_ROOT="${S}" \
+ -sPYTHON_ROOT=/usr \
+ -sPYTHON_VERSION=${PYVER} \
+ -sTOOLS=${BOOST_TOOLSET} \
+ -sBUILD="${BUILD}" \
+ --prefix=${D}/usr \
+ --layout=system \
+ install || die "Install failed"
+ fi
+
+ # Install documentation; seems to be mostly under ${S}/lib
+ # install documentation
+ dodoc README
+ dohtml index.htm google_logo_40wht.gif c++boost.gif boost.css \
+ -A pdf -r more-r people -r doc
+
+ find libs -type f -not -regex '^libs/[^/]*/build/.*' \
+ -and -not -regex '^libs/.*/test[^/]?/.*' \
+ -and -not -regex '^libs/.*/bench[^/]?/.*' \
+ -and -not -regex '^libs/[^/]*/tools/.*' \
+ -and -not -name \*.bat \
+ -and -not -name Jamfile\* \
+ -and -not -regex '^libs/[^/]*/src/.*' \
+ -and -not -iname makefile \
+ -and -not -name \*.mak \
+ -and -not -name .\* \
+ -and -not -name \*.dsw \
+ -and -not -name \*.dsp \
+ -exec \
+ install -D -m0644 \{\} ${D}/usr/share/doc/${PF}/html/\{\} \;
+
+ #and finally set "default" links to -gcc-mt versions
+ cd ${D}/usr/lib
+
+ for fn in `ls -1 *.${SOSUFFIX}|cut -d- -f1|sort|uniq`; do
+ if [ -f "$fn.${SOSUFFIX}" ] ; then
+ dosym $fn.${SOSUFFIX} /usr/lib/$fn-${TOOLSET_NAME}.${SOSUFFIX}
+ fi
+ if [ -f "$fn-mt.${SOSUFFIX}" ] ; then
+ dosym $fn-mt.${SOSUFFIX} /usr/lib/$fn-${TOOLSET_NAME}-mt.${SOSUFFIX}
+ fi
+ if [ -f "$fn-d.${SOSUFFIX}" ] ; then
+ dosym $fn-d.${SOSUFFIX} /usr/lib/$fn-${TOOLSET_NAME}-d.${SOSUFFIX}
+ fi
+ if [ -f "$fn-mt-d.${SOSUFFIX}" ] ; then
+ dosym $fn-mt-d.${SOSUFFIX} /usr/lib/$fn-${TOOLSET_NAME}-mt-d.${SOSUFFIX}
+ fi
+ done
+
+ for fn in `ls -1 *.a|cut -d- -f1|sort|uniq`; do
+ if [ -f "$fn.a" ] ; then
+ dosym $fn.a /usr/lib/$fn-${TOOLSET_NAME}.a
+ fi
+ if [ -f "$fn-mt.a" ] ; then
+ dosym $fn-mt.a /usr/lib/$fn-${TOOLSET_NAME}-mt.a
+ fi
+ if [ -f "$fn-d.a" ] ; then
+ dosym $fn-d.a /usr/lib/$fn-${TOOLSET_NAME}-d.a
+ fi
+ if [ -f "$fn-mt-d.a" ] ; then
+ dosym $fn-mt-d.a /usr/lib/$fn-${TOOLSET_NAME}-mt-d.a
+ fi
+ done
+
+ [[ $(get_libdir) == "lib" ]] || mv ${D}/usr/lib ${D}/usr/$(get_libdir)
+
+ if use pyste; then
+ cd ${S}/libs/python/pyste/install
+ distutils_src_install
+ fi
+}
diff --git a/dev-libs/boost/files/digest-boost-1.32.0-r3 b/dev-libs/boost/files/digest-boost-1.32.0-r3
new file mode 100644
index 000000000000..f5cfec51b895
--- /dev/null
+++ b/dev-libs/boost/files/digest-boost-1.32.0-r3
@@ -0,0 +1 @@
+MD5 e1d1fc7b8fc8c51df4564c2188ca51cb boost_1_32_0.tar.bz2 10181552